public-webapps@w3.org from October to December 2010 by subject

1st CFP: IJCAI-11 Workshop on Discovering Meaning On the Go in Large & Heterogeneous Data (LHD-11)

[Bug 10007] Async callbacks should fire in the same order the async requests are made in IndexedDB.

[Bug 10027] Remove explicit add/remove functions from IDBIndex

[Bug 10058] Specify order for indexes which contain duplicate key values

[Bug 10088] The spec does not define what happens if an object store is modified while a cursor is iterating it.

[Bug 10269] Step 2 of the WebIDL [[Delete]] algorithm is wrong

[Bug 10302] Introduce exception handlers at the transaction/database scope

[Bug 10303] Transactions should not commit if code unwinds because of an exception

[Bug 10304] Rename "remove" method on object store to "delete"

[Bug 10305] [IndexedDB] Transactions need to be clarified

[Bug 10336] "optional" should be allowed even if subsequent arguments aren't optional

[Bug 10382] [IndexedDB] Note on avoiding reader/writer starvation

[Bug 10396] [IndexedDB] LEFT_BOUND and RIGHT_BOUND could be a bit more clear

[Bug 10397] [IndexedDB] "upper" and "lower" bounds would be much clearer than right/left

[Bug 10402] [IndexedDB] IDBCursor.remove/update behavior when at end of range unspecified

[Bug 10426] [IndexedDB] All interfaces (except IDBEnvironment*) should not have NoInterfaceObject

[Bug 10430] [IndexedDB] We need to make it more clear IDBRequests can be reused and spec readyState's behavior

[Bug 10430] New: [IndexedDB] We need to make it more clear IDBRequests can be reused and spec readyState's behavior

[Bug 10431] [IndexedDB] Remove IDBDatabase.objectStore()

[Bug 10527] [IndexedDB] Result of IDBCursor.remove and update unspecified.

[Bug 10546] It looks like at least some browsers restrict legend display values to "block"

[Bug 10583] [Selection] toString should return only the text within the selection that is visible to the user

[Bug 10584] toString does not represent what WebKit and Mozilla do, which is to return only the text within the selection that is visible to the user.

[Bug 10590] [IndexedDB] Default timeout duration needs to be specced

[Bug 10597] Array type missing from IDL grammar

[Bug 10609] DOMTimeStamp should be defined in Web IDL

[Bug 10624] [Selection] Selection anchorNode/anchorOffset/focusNode/focusOffset do not match existing browser behaviour

[Bug 10674] [IndexedDB] Changes to indexes (and their cursors)

[Bug 10691] [Selection] Specify extend method for Selection objects

[Bug 10765] [IndexedDB] Need to add an onblocked event to what's returned from setVersion

[Bug 10765] New: [IndexedDB] Need to add an onblocked event to what's returned from setVersion

[Bug 10798] [Selection] Find a new home for Selection

[Bug 10798] Find a new home for Selection

[Bug 10896] enable device independent access to event handlers

[Bug 10930] CanvasPixelArray out of range behavior needs clarification

[Bug 10977] New: Properties should be on prototypes, not on objects, in the ECMAScript binding

[Bug 10977] Properties should be on prototypes, not on objects, in the ECMAScript binding

[Bug 10985] New: The sentence "The subprotocol names must all be non-empty ASCII strings with no control characters and not spaces in them (i.e. only characters in the range U+0021 to U+007E)." should actually read: "The subprotocol names must all be non-empty ASCII strin

[Bug 10985] The sentence "The subprotocol names must all be non-empty ASCII strings with no control characters and not spaces in them (i.e. only characters in the range U+0021 to U+007E)." should actually read: "The subprotocol names must all be non-empty ASCII strin

[Bug 11094] [IndexedDB] IDBIndex.get* don't define which item is returned in the case of duplicates

[Bug 11094] New: [IndexedDB] IDBIndex.get* don't define which item is returned in the case of duplicates

[Bug 11097] New: [IndexedDB] Behavior of .close() is not completely specified

[Bug 11104] [IndexedDB] removeObjectStore/Index should be renamed to delete___

[Bug 11104] New: [IndexedDB] removeObjectStore/Index should be renamed to delete___

[Bug 11113] New: [IndexedDB] The spec should be more explicit about the queuing of setVersion transactions

[Bug 11117] New: this is a test message

[Bug 11117] this is a test message

[Bug 11157] carasen

[Bug 11157] New: carasen

[Bug 11164] New: There is no way to get from an error event to other objectStores

[Bug 11187] [IndexedDB] Repeated calls to IDBCursor.continue() should throw

[Bug 11187] New: [IndexedDB] Repeated calls to IDBCursor.continue() should throw

[Bug 11190] New: Make scripts created by createContextualFragment() executable

[Bug 11246] New: Remove IDBCursor(Sync).count

[Bug 11246] Remove IDBCursor(Sync).count

[Bug 11257] New: Should IDBCursor.update be able to create a new entry?

[Bug 11266] Add IDBObjectStore.clear()

[Bug 11266] New: Add IDBObjectStore.clear()

[Bug 11269] New: Evaluating keyPaths needs to be better specified

[Bug 11270] New: Interaction between in-line keys and key generators

[Bug 11276] New: Specify deleteDatabase

[Bug 11276] Specify deleteDatabase

[Bug 11280] IDBFactory.databases doesn't work

[Bug 11280] New: IDBFactory.databases doesn't work

[Bug 11348] New: [IndexedDB] Overhaul of the event model

[Bug 11349] [IndexedDB] Null should not be a valid key type

[Bug 11349] New: [IndexedDB] Null should not be a valid key type

[Bug 11350] New: [IndexedDB] ObjectStores should have a way to hint that they're "evictable"

[Bug 11351] New: [IndexedDB] Should we have a maximum key size (or something like that)?

[Bug 11358] New: Should addEventListener's last argument be optional?

[Bug 11375] New: [IndexedDB] Error codes need to be assigned new numbers

[Bug 11376] New: IDBObjectStore.put's DATA_ERR description needs clarification

[Bug 11385] New: Bring the sync APIs back in sync with the async ones

[Bug 11389] IDBTransaction.READ_ONLY should probably be 0

[Bug 11389] New: IDBTransaction.READ_ONLY should probably be 0

[Bug 11394] New: We should throw if continue() is called with a key <= the current position

[Bug 11396] New: Add a callback to IDBDatabaseSync.transaction

[Bug 11398] New: [IndexedDB] Methods that take multiple optional parameters should instead take an options object

[Bug 11401] New: [IndexedDB] We should disallow .transaction() from within setVersion transactions

[Bug 11406] New: [IndexedDB] IDBDatabase.transaction needs to specify exception for invalid mode parameter

[Bug 11407] [IndexedDB] IDBDatabase.createObjectStore: autoIncrement should not default to true

[Bug 11407] New: [IndexedDB] IDBDatabase.createObjectStore: autoIncrement should not default to true

[Bug 11419] New: Local Storage Data Not Retained Between Sessions When Running Browser Locally

[Bug 11425] New: [IndexedDB] Transaction timeout parameter should probably be a double

[Bug 11439] New: Extend ProgressEvent with position and totalSize attributes

[Bug 11527] New: Remove dynamic transactions from the spec

[Bug 11527] Remove dynamic transactions from the spec

[Bug 11528] New: We should add some form of dynamic transaction to IndexedDB

[Bug 11530] New: No transaction should start until after all others that were created first and whose scope overlaps

[Bug 11530] No transaction should start until after all others that were created first and whose scope overlaps

[Bug 11552] New: We should remove timeout from IndexedDB.

[Bug 11553] New: Ensure indexedDBSync is on the right worker interface

[Bug 11564] New: Remove all references to manually populated indexes

[Bug 11567] New: IndexedDB should utilize the new WebIDL static feature

[Bug 11570] New: Can't find the posibility for user authentication by connecting to a websocket! Missing?

[Bug 11571] http://mntaxwaste.blogspot.com/ what is this and where did it come from

[Bug 11571] New: http://mntaxwaste.blogspot.com/ what is this and where did it come from

[Bug 11581] New: Is there really need to drop http compability ? This will cause lot of troubles in some http-servers and browsers. This will force developers to use ugly hacks like flash/java based implementations. Is there any reason, wht not to create real robust http-

[Bug 11589] New: It is said that "Values can be any data type supported by the structured clone algorithm", but the algorithm is not described. In fact is it deeply buried in the HTML5 specification, open to fuzzy interpretations. Values are a fundamental part of any data

[Bug 11606] New: wanted: awareness of non-persistent web storage

[Bug 11615] New: save text from an editor in a file system

[Bug 11619] New: who is the president of the United States?

[Bug 11619] who is the president of the United States?

[Bug 9514] [Selection] Specify Selection.modify()

[Bug 9562] Opening a database with a different description is underspecified

[Bug 9769] IDBObjectStoreRequest/Sync.put should be split into 3 methods

[Bug 9790] Request is not a good suffix for all the async interfaces in IndexedDB

[Bug 9882] Behavior when attempting to write data to an objectStore opened as read only unspecified

[cors] 27 July 2010 CORS feedback

[CORS] Access-Control-Expose-Headers

[CORS] Multiple origin values?

[DataCache] Status and plans for Programmable HTTP Caching and Serving?

[Embedding] running widgets in a regular web page ???

[eventsource] Some data re Server-sent Events LC

[File API] abort()

[Important] W3C Account Phishing Scam

[IndexedDB] .value of no-duplicate cursors

[IndexedDB] Behavior of IDBObjectStore.get() and IDBObjectStore.delete() when record doesn't exist

[IndexedDB] Compound and multiple keys

[IndexedDB] Do we need a timeout for VERSION_CHANGE?

[IndexedDB] Events and requests

[IndexedDB] Explicitly stablishing the timing of clone creation

[IndexedDB] IDBKeyRange cleanup

[IndexedDB] KeyRange factory methods

[IndexedDB] Need a method to clear an object store

[IndexedDB] Need a method to remove a database

[IndexedDB] Should removeIndex/ObjectStore be renamed to match s/remove/delete/ elsewhere?

[IndexedDB] versionchange event gone?

[IndexedDB] Why rely on run-to-completion?

[progress-events] default action suggestion

[progress-events] Update

[ProgressEvents] How to deal with compressed transfer encodings

[WebIDL] outstanding bugs?

[widget] Draft agenda for 7 October 2010 voice conf

[widget] proposal to add defaultlocale attribute to widget element (P&C Spec), was Re: [widgets] Span example

[Widgets] and OAuth or other similar redirect-based protocols

[widgets] Best practice / recommendation for widget id scheme?

[Widgets] Default values in P&C

[widgets] Draft agenda for 18 November 2010 voice conf

[widgets] Draft agenda for 21 October 2010 voice conf

[widgets] Draft minutes for 18 November 2010 voice conf

[widgets] Draft minutes from 21 October 2010 voice conf

[widgets] Draft minutes from 23 September 2010 voice conf

[widgets] Draft minutes from 7 October 2010 voice conf

[widgets] Error in i18n tests for features

[widgets] Error in test case "bm"

[widgets] Icon i18n width/height tests

[widgets] missing tests?

[Widgets] Mozilla open apps

[widgets] No call November 11

[widgets] Reminder: RfC: LCWD of Widget Packaging and Configuration; comment deadline October 26

[widgets] Removed test-cases/ta-xGYcVTMoAX/000/ds.wgt

[widgets] removed test-cases/ta-ZjcdAxFMSx/002/

[widgets] RfC: LCWD of Widget Packaging and Configuration; comment deadline October 26

[Widgets] running widgets in a regular web page ???

[widgets] Seeking review of Widgets Dig Sig Test Suite

[widgets] Some possible i18n test bugs

[widgets] Storage keys and ECMAScript incompatibility?

[widgets] test "bn" in error

[widgets] test "dl" is in error

[widgets] test "viewh" in error

[widgets] Test widget has wrong content

[widgets] Tiny bug in spec in section 9.1.16

[widgets] VMMF Test suite

[widgets] WARP test bugs

[widgets] Widget API Test Suite Updated, was Re: ACTION-585: After TWI test suite updated, send an annoucement to public-webapps (Web Applications Working Group)

[widgets] Widget Updates

[Workers] NavigatorOnLine

[XHR2] Comments on the 7 September working draft

[XHR2] HTTP Trailers

[XHR2] overrideMimeType behavior

[XHR2] responseType / response / overrideMimeType proposal

[XHR2] why have an asBlob attribute at all?

A URL API

ACTION-591: Checkin updates for issues 150 and 151 (Web Applications Working Group)

Added 'locale' to Text, Keyboard, and Composition Events [ISSUE-119]

Agendas for WebApps' Nov 1-2 f2f meeting

Attn: Account Subscriber

Call for Editors for Server-sent Events, Web Storage, and Web Workers

Can we remove forminput and formchange events and related dispatch methods?

CfC: FPWD of File API: Directories and System + WD of File API: Writer; deadline October 22

CfC: FPWD of Web Messaging; deadline November 13

CfC: Last Call Working Draft of Progress Events; deadline Nov 29

CfC: publish a new WD of Progress Events; deadline October 14

CfC: publish a new Working Draft of Web IDL; deadline October 18

CfC: to publish Web SQL Database as a Working Group Note; deadline November 13

CfC: WD of File API; deadline October 22

clipboard events

Comment on Widget Interface...

Comments on the http://www.w3.org/TR/widgets/

continue as a reserved word and a conflict with IndexedDB

CORS & ISSUE-108

createBlobURL

createBlobURL (was: Re: CfC: WD of File API; deadline October 22)

Discussion of File API at TPAC in Lyon

DOM collections index out of bounds and JavaScript.

DOM event detection

DOM3 Events last call comment

Embedding WebSocket Servers in Web Pages

Feedback requested on returning null/void or throwing an exception

File descriptors

file-system-api: filename restrictions

FileAPI editorial nit

FileAPI use case: making an image downloading app

FileSystem API: Avoiding Upload Forms And Temporary Downloads

FPWD of Web Messaging; deadline November 13

Fwd: CfC: Last Call Working Draft of Progress Events; deadline Nov 29

Fwd: ECMA TC 39 WebIDL meeting open to W3C members

Fwd: Re: CfC: publish a new WD of Progress Events; deadline October 14

Fwd: XBL2: First Thoughts and Use Cases

Hash functions

IndexedDB TPAC agenda

Interacting with notifications

Issue in DIgital Signature test suite

ISSUE-122 (add mousewheel): Consider adding 'mousewheel' again [DOM3 Events]

ISSUE-135 (DOMAttributeChangeRequestEvent): Consider adding DOMAttributeChangeRequestEvent

ISSUE-136 (getCoordsAt): Consider adding MouseEvent.getCoordsAt(element)

ISSUE-137 (IME-keypress): Should keypress events fire when using an IME? [DOM3 Events]

ISSUE-138 (keyboard mapping): Define "keyboard mapping" [DOM3 Events]

ISSUE-139 (clarify key repeat): Define which events repeat when a key is held down [DOM3 Events]

ISSUE-140 (textInput keydown keypress): textInput event as default action of both keydown and keypress? [DOM3 Events]

ISSUE-141 (IME examples): IME examples [DOM3 Events]

ISSUE-142 (multiple keypress): one keydown might fire multiple keypress/textInput events [DOM3 Events]

ISSUE-143 (editorial d3e): DOM3 Events section 3 editorial errors [DOM3 Events]

ISSUE-144 (propagation exceptions): exceptions in handlers during event propagation [DOM3 Events]

ISSUE-145 (event handler ordering): Ordering event handlers registered by different means [DOM3 Events]

ISSUE-146 (capture-phase targets): Capture-phase listeners invoked on targets [DOM3 Events]

ISSUE-147 (event re-dispatching): re-dispatching an event that already has its flow started [DOM3 Events]

ISSUE-148 (modularize d3e): Consider modularizing DOM3 Events [DOM3 Events]

ISSUE-149 (missing key values): The multiply and other key values are missing [DOM3 Events]

ISSUE-150: [widgets] Email and param name and value as 'Keyword attributes' is causing confusion in Widgets P&C Spec

ISSUE-151: [widgets] P&C Spec.... If feature-name is not a valid IRI, and required-feature is true, then the user agent must treat this widget as an invalid widget package. but doesnt say anything about the case when it is not required.

ISSUE-152: [widgets] P&C test suite needs a few more XML entity cases to check for well-formed XML

ISSUE-173 (ericu): terminal FileWriter progress events should be queued [File API: Writer]

ISSUE-2 (OnFoo Attributes): Event Handler Attributes (onfoo Attributes) and Add/Remove Event Listener [DOM3 Events]

Last Call of WOFF File Format 1.0; comment deadline December 14

Local Storage Not Retaining Data Between Local Browser Sessions

Making non-cookie requests to another domain... possible DoS attack by forcing session expiration?

Minutes from WebApps' 2 November 2010 meeting

Notes from WebApps' 1 November 2010 "Gathering"

PFWG requirements: enable device independent access to event handlers

PIPP network protocol

progress events in sync XHR not entirely ruled out

Questions about API Design, composability and multiple arguments

Relational Data Model Example

Rename XBL2 to something without X, B, or L?

Replacing WebSQL with a Relational Data Model.

Request for Last Call review of RDFa Core 1.1

Request for Last Call review of RDFa Core 1.1; deadline

requestAnimationFrame

revokeObjectURL behavior

Seeking agenda items for WebApps' Nov 1-2 f2f meeting

Seeking feedback on Widget Interface: LocalizableString

Seeking status of Server-sent Events, Web Storage and Web Workers

Structured clone in WebStorage

Testing Requirements

to publish Web SQL Database as a Working Group Note; deadline November 13

Typo in http://www.w3.org/TR/widgets-apis/ Section 5.1.1

Updates to FileAPI

Use cases for Range::createContextualFragment and script nodes

using BlobBuilder append method with generated binary data

W3C XML Digital Signature Object Element Processing Issue

Web Notifications: please use public-web-notification [Was: Interacting with notifications]

Web workers: synchronously handling events

Widget Embedding [was: Re: [widgets] running widgets in a regular web page ???]

Widget packaging spec: make it clear in the Abstract or Intro that P&C widgets != UI controls

Widgets and OAuth or other similar redirect-based protocols

XBL2 CR and the Sept 2010 version of XBL [Was: Re: Comments on proposed editor's draft of XBL2 from Forms WG]

XBL2: First Thoughts and Use Cases

XHR responseArrayBuffer attribute: suggestion to replace "asBlob" with "responseType"

XHR2 proposal: support for informational responses

XHR: Unicode signature stripping

XML base after redirection

答复: Call for Editors for Server-sent Events, Web Storage, and Web Workers

Last message date: Thursday, 30 December 2010 23:43:21 UTC