W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2010

Re: [progress-events] Update

From: Anne van Kesteren <annevk@opera.com>
Date: Tue, 05 Oct 2010 19:36:27 +0200
To: "Olli Pettay" <Olli.Pettay@helsinki.fi>, Olli@pettay.fi
Cc: "WebApps WG" <public-webapps@w3.org>
Message-ID: <op.vj35uvag64w2qv@anne-van-kesterens-macbook-pro.local>
On Tue, 05 Oct 2010 19:31:12 +0200, Olli Pettay <Olli.Pettay@helsinki.fi>  
> May I ask why you think the interface member names are terrible?

I should probably have left out that comment. It is just that they are  
inconsistent — lengthComputable vs total — and seem to imply a specific  
kind of process — loaded. I would have preferred hasMax, value, and max /  
hasTotal/totalKnown, current, and total or some such. Anyway, changing  
this is not worth it.

Anne van Kesteren
Received on Tuesday, 5 October 2010 17:37:12 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:13:13 UTC