W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2010

Re: XHR responseArrayBuffer attribute: suggestion to replace "asBlob" with "responseType"

From: Jeremy Orlow <jorlow@chromium.org>
Date: Wed, 27 Oct 2010 14:17:24 +0100
Message-ID: <AANLkTi=+gxZa66+tJ4skbgeioOD4uYJAcpwSBeP+UU4r@mail.gmail.com>
To: Boris Zbarsky <bzbarsky@mit.edu>
Cc: Anne van Kesteren <annevk@opera.com>, Chris Rogers <crogers@google.com>, Web Applications Working Group WG <public-webapps@w3.org>, Eric Uhrhane <ericu@google.com>, michaeln@google.com, Darin Fisher <darin@google.com>, Alexey Proskuryakov <ap@webkit.org>, Chris Marrin <cmarrin@apple.com>, Geoffrey Garen <ggaren@apple.com>
On Wed, Oct 27, 2010 at 2:10 PM, Boris Zbarsky <bzbarsky@mit.edu> wrote:

> On 10/27/10 5:54 AM, Anne van Kesteren wrote:
>> Okay, so even for responseBlob you think it should be the implementor
>> handling the complexity.
> I think we should at least seriously consider that, yes.
> I realize the webkit folks will disagree en masse.  ;)
> Would be good to hear what others think.  In particular, people who
> actually work on JS libraries.

Agreed.  Because I'm skeptical that nested libraries trying to access the
data both ways will be an issue.

Received on Wednesday, 27 October 2010 13:18:24 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:13:13 UTC