W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2010

Re: XHR responseArrayBuffer attribute: suggestion to replace "asBlob" with "responseType"

From: Chris Rogers <crogers@google.com>
Date: Wed, 10 Nov 2010 14:05:40 -0800
Message-ID: <AANLkTinHapbSLbADpBWXJ76j5r=+S=HmhySFzm8195HY@mail.gmail.com>
To: "Tab Atkins Jr." <jackalmage@gmail.com>
Cc: David Flanagan <david@davidflanagan.com>, Boris Zbarsky <bzbarsky@mit.edu>, public-webapps@w3.org, Jonas Sicking <jonas@sicking.cc>, Maciej Stachowiak <mjs@apple.com>, Geoffrey Garen <ggaren@apple.com>, Darin Fisher <darin@chromium.org>, Anne van Kesteren <annevk@opera.com>, Eric Uhrhane <ericu@google.com>, michaeln@google.com, Alexey Proskuryakov <ap@webkit.org>, jorlow@google.com, jamesr@chromium.org
> After discussion with Anne and James, I retract my support for a new
> constructor.  I'm in favor of .responseType.
> Specifically, .responseType would take values like "" (for legacy
> treatment) / "text" / "document" / "arraybuffer" / "blob" / etc.  If
> the value is "", then .responseText and .responseXML are filled
> appropriately, while .response is empty.  Otherwise, .responseText and
> .responseXML are empty (or throw or something), while .response
> contains the value in the chosen format.  .responseType must be set at
> some appropriately early time; after the response is received, changes
> to .responseType are ignored or throw.
> ~TJ

So you prefer that .responseType take a string value as opposed to an
integer enum value?  Darin Fisher had the idea that introspection of the
supported values would be easier as an enum.

Received on Wednesday, 10 November 2010 22:06:10 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:13:13 UTC