Re: XHR responseArrayBuffer attribute: suggestion to replace "asBlob" with "responseType"

I just had a short talk with Darin Fisher and he suggested that instead of
.responseType taking a string value, that it could be an enum value of
XMLHttpRequest, something like:

        const unsigned short RESPONSETYPE_DEFAULT = 0;
        const unsigned short RESPONSETYPE_BINARY = 1;
        const unsigned short RESPONSETYPE_BLOB = 2;
        const unsigned short RESPONSETYPE_STREAM = 3;

Then it would be more easily discoverable if a particular type was
supported.

Chris

Received on Tuesday, 2 November 2010 23:00:16 UTC