public-webapps-github@w3.org from March 2015 by subject

[dom] Convert DOM to use bikeshed (#15)

[dom] Indicate GitHub issues can now be used (#14)

[fetch] Aborting a fetch (#27)

[fetch] Add support for federated token binding to fetch (#30)

[fetch] Add timeout option (#20)

[fetch] Clear response body under certain conditions (#31)

[fetch] consider different default context value than "fetch" for new Request() (#29)

[fetch] consider providing a json serializer for Request and Response (#22)

[fetch] Deprecate fetch (#28)

[fetch] Distinguishing between errors (#25)

[fetch] Operate on internal response (#23)

[fetch] Prevent modifying headers on Responses (#24)

[fetch] URLs with username/password (#26)

[filesystem-api] Define AbortableProgressPromise (#2)

[filesystem-api] Update links to subresources (#3)

[fullscreen] Add transform:none to the UA style sheet (#1)

[gamepad] Specification (#1)

[manifest-csp] Minor editorial suggestion for Abstract (#7)

[manifest] A means to control the "theme color" (#225)

[manifest] A way to link to related applications (#326)

[manifest] Add a lang member (#322)

[manifest] Add a language tag (#322)

[manifest] add a license field (#328)

[manifest] Add note about i18n (#323)

[manifest] Add recommended width and height (#310)

[manifest] Add related_applications and prefer_related_applications. (#344)

[manifest] Add requirements when the Manifest is used by crawlers (#343)

[manifest] Add theme_color member (closes #225) (#325)

[manifest] Add theme_color member (closes #225) (c74ab60)

[manifest] Added lang member (closes #322) (#324)

[manifest] Added lang member (closes #322) (cbd8343)

[manifest] Are "hosted apps" in scope? (#340)

[manifest] Clarified opening deep link (closes #301) (#302)

[manifest] Clarify "scope" in step #3 of Section 3 (#320)

[manifest] clarify display-mode and UAs and iframes (closes #309) (#318)

[manifest] clarify display-mode and UAs and iframes (closes #309) (b517aef)

[manifest] Clarify display-mode relationship to iframes and legacy content (#309)

[manifest] Convert "Icon object" into a generic "image object" (#327)

[manifest] Define identity of a web app. (#272)

[manifest] Defined identity based on manifest URL (closes #272) (#329)

[manifest] Defined identity based on manifest URL (closes #272) (853182c)

[manifest] Defined identiy based on manifest URL (closes #272) (#329)

[manifest] Defined identiy based on manifest URL (closes #272) (27cdbb5)

[manifest] difference between lang and default_locale (#345)

[manifest] Echidna (#333)

[manifest] Fixed scopeURL typo (closes #320) (#321)

[manifest] Fixed scopeURL typo (closes #320) (cddb540)

[manifest] For `lang`, add formal defintion of language tag (#331)

[manifest] Graceful handling of no network connectivity in hosted apps (#339)

[manifest] i18n - RTL/LTR issues (#10)

[manifest] i18n: No language metadata for 'name' (#335)

[manifest] i18n: No language metadata for 'name'; [I18N-ISSUE-415] (#335)

[manifest] i18n: No localization model (#338)

[manifest] i18n: No localization model; [I18N-ISSUE-412] (#338)

[manifest] i18n: No localized examples (#337)

[manifest] i18n: No means of obtaining correctly localized manifest (#336)

[manifest] i18n: No means of obtaining correctly localized manifest; [I18N-ISSUE-414] (#336)

[manifest] Incorrect argument (#341)

[manifest] Integration with service workers (#161)

[manifest] Manifest format should support some way of including a splash screen (#9)

[manifest] Move to using Echidna (#315)

[manifest] Native API Permissions (#319)

[manifest] No direction metadata for 'name' (#334)

[manifest] Resolve start_url against manifest URL (#330)

[manifest] shouldn't the default scope be bounded? (#332)

[manifest] Support for Actionable Notifications in the manifest (#347)

[manifest] The use of the `.manifest` file extension may be problematic / confusing ? (#346)

[manifest] typo found (#342)

[packaged-webapps] NoInterfaceObject missing or in wrong path (#1)

[packaging-on-the-web] Security use cases for packaging (#21)

[permissions] A "dismissed" state (#4)

[permissions] Add getUserMedia permissions (#10)

[permissions] Add Promise.all() example for multiple queries (#19)

[permissions] Could we ask for several permissions at a time ? (#6)

[permissions] Exposition (Window,Worker) should be explicit (#16)

[permissions] Extensibility: make sure we have it right (#17)

[permissions] Fix typo around Promise.all (#21)

[permissions] Have an instance of Permissions on Navigator and WorkerNavigator. (#18)

[permissions] Is `Permissions.get` the right name? (#5)

[permissions] Permission states (#3)

[permissions] Redundant assertion (#2)

[permissions] Renamed .get to .check (closes #5) (#7)

[permissions] Should 'prompt' be renamed as 'default'? (#12)

[permissions] Should Permissions be an interface with static objects? (#11)

[permissions] Should we add a global change event? (#15)

[permissions] Should we have a more explicit enumerating process? (#13)

[permissions] Specify how to behave when an extended Permission dictionary doesn't match requirements (#14)

[permissions] Version of the API that should be simple, extensible and ready for MVP. (#20)

[permissions] What should "retrieve the permission state" do for context related permissinos? (#9)

[permissions] What should "retrieve the permission state" do for context related permissions? (#9)

[permissions] What should "retrieve the permission state" do for pickers? (#8)

[push-api] Add a PushSubscriptionOptions dictionary with a userVisible option. (#131)

[push-api] Add optional userVisibleOnly parameter to register & hasPermission (#87)

[push-api] Allow UAs to unsubscribe offline "successfully" (#122)

[push-api] Any implementation ? (#119)

[push-api] Consider exposing meta-information on push message (#81)

[push-api] Define a serializer for PushSubscription (#125)

[push-api] Delete the 'master' branch please (#127)

[push-api] Describe process for subscription updates (#132)

[push-api] Fixing definition of push message (#126)

[push-api] How to handle service worker unregister? (#121)

[push-api] Move to using just endpoint (#129)

[push-api] Nit: Any -> any (#133)

[push-api] Permission checks in the push API (#75)

[push-api] Push API should recommend implementing ServiceWorkerRegistration.showNotification (#118)

[push-api] Push events should Soft Update service worker (#115)

[push-api] Push service definition (#128)

[push-api] pushsubscriptionchange - Initial feedback (#120)

[push-api] Remove [NoInterfaceObject] from PushMessageData (#123)

[push-api] Removed NoInterfaceObject from PushMessageData (closes #123) (#124)

[push-api] Straw man for encryption (#130)

[screen-orientation] Natural shouldn't be equivalent to *-secondary. Fixes #83 (#84)

[screen-orientation] The orientation type 'Natural' should only lock to x-primary (#83)

[selection-api] Selection.toString is under specified (#7)

[ServiceWorker] "conforming to ECMAScript 6 Map objects"? (#491)

[ServiceWorker] "messaging occurs as per usual with Web Workers" (#484)

[ServiceWorker] [[UpdateState]] does not define event loop (#481)

[ServiceWorker] A worker that fails to activate should relinquish its controllees (#659)

[ServiceWorker] Add an API to take over uncontrolled pages (or pages controlled by another service worker) (#586)

[ServiceWorker] Add Quota Management APIs to the SW Global Execution Scope (#229)

[ServiceWorker] Allowing multiple scopes (& should scopes be primary key?) (#566)

[ServiceWorker] Association between a service worker and global objects (#652)

[ServiceWorker] Backpressure on fetch integrated with Streams (#452)

[ServiceWorker] Cache should sanitize the stored Request in put/add/addAll (#664)

[ServiceWorker] Can we replace event.default() with something less magic? (#607)

[ServiceWorker] Cancelling HTTP fetch (#592)

[ServiceWorker] Cause a Content-Security-Policy: sandbox header to unregister the Service Worker at that scriptURL. (#389)

[ServiceWorker] client objects should have an .id (#634)

[ServiceWorker] Clients & postMessage (#609)

[ServiceWorker] Define environment settings object for service workers (#526)

[ServiceWorker] Define security policy (#113)

[ServiceWorker] Do we need InstallEvent's activeWorker? (#661)

[ServiceWorker] Drop client from fetchEvent/request? (#575)

[ServiceWorker] Equivalent of Shared Worker Port in Service Worker? (#662)

[ServiceWorker] Event queuing model for SW (#649)

[ServiceWorker] Expose environment ids? (#643)

[ServiceWorker] FetchEvent not defined (#645)

[ServiceWorker] HEAD request on Cache API should not return response with body (#655)

[ServiceWorker] How do I get from a script to a service worker registration (#504)

[ServiceWorker] How to set the client for the requests initiated from within user agent's internal context? (#615)

[ServiceWorker] https should not be mandatory (#658)

[ServiceWorker] importScripts() should throw? (#642)

[ServiceWorker] Interacting with HTTP/2 push (#215)

[ServiceWorker] Navigate and redirects (#654)

[ServiceWorker] navigator.serviceWorker.postMessage should populate messageEvent.source & ports (#290)

[ServiceWorker] Not Found Error instead of undefined response (#666)

[ServiceWorker] object/embed (#249)

[ServiceWorker] openWindow(url)'s same origin check should be done against the origin of the final response's url? (#646)

[ServiceWorker] Optimization opportunity for SW (Should sync/push event target a specific server?) (#644)

[ServiceWorker] Pattern for handling fingerprinted assets in cache? (#657)

[ServiceWorker] Pattern for handling fingerprinted assets? (#657)

[ServiceWorker] Prefetch/prerender & Client id (#210)

[ServiceWorker] Relationship to Caches & ScriptCache in ServiceWorkerGlobalScope (#473)

[ServiceWorker] Remove "parsed" state mention (#663)

[ServiceWorker] Remove ignoreMethod (#653)

[ServiceWorker] Resources shared across documents controlled by different service workers (#244)

[ServiceWorker] Response streaming and SW lifetime (#651)

[ServiceWorker] Returning a FetchPromise from fetch() (#625)

[ServiceWorker] Send a changelog to the UA (#650)

[ServiceWorker] Serialize the steps of Update/Install/Activate algorithms instead of running them 'atomically' in parallel. (240054c)

[ServiceWorker] Service Worker constructor instead of navigator.serviceWorker (#660)

[ServiceWorker] Service Worker doesn (#667)

[ServiceWorker] Service Worker doesn't catch favicon requests (#668)

[ServiceWorker] service-worker.d.ts.... (#576)

[ServiceWorker] ServiceWorker constructor instead of navigator.serviceWorker (#660)

[ServiceWorker] ServiceWorker inherits from Worker (#410)

[ServiceWorker] ServiceWorker objects should have an .id (#635)

[ServiceWorker] ServiceWorker's postMessage method is not defined (#479)

[ServiceWorker] ServiceWorkerClient can't be a MessageEvent.source because it's not a WindowProxy or MessagePort (#453)

[ServiceWorker] should Cache support VARY:*,otherheader or only VARY:* (#656)

[ServiceWorker] Should sync event target a specific server? (#644)

[ServiceWorker] Should UUID for unique IDs be mandated? (#647)

[ServiceWorker] SW spec never hooks into the "runs a worker" term that the CSP spec uses to enforce CSPs (#378)

[ServiceWorker] SW spec should expose Resource Timing and User Timing (#553)

[ServiceWorker] under what conditions should sandboxed iframes be intercepted? (#648)

[ServiceWorker] what should Cache put operations do if the body errors out after resolving promise? (#665)

[ServiceWorker] Why would `WindowClient` ever have `frameType` of `none`? (#632)

[spec-reviews] CSS Regions Review Draft (#44)

[spec-reviews] Fixed typos (#46)

[spec-reviews] http-problem (#37)

[spec-reviews] permissions API (#45)

[spec-reviews] Revise CSS regions draft based on outcome of 19-March discussion (#47)

[spec-reviews] Update CSS Regions.md (#48)

[streams] Add BufferFeedableReadableByteStream (#282)

[streams] Add readableAmount getter to ReadableByteStream (#279)

[streams] Add some more texts to Requirements.md about byte streams (#299)

[streams] Byte streams (#300)

[streams] Byte streams tracking bug (#300)

[streams] Byte streams: write up design rationales and vision for how they are used/what they enable (#177)

[streams] can streams be transferred via postMessage()? (#276)

[streams] Change the model for ReadableStream to have async read() (#288)

[streams] Change the model for ReadableStream to have async read() (#296)

[streams] consider allowing a stream to be removed from a pipeline (#307)

[streams] Define "tee"ing a stream (#271)

[streams] Defined behavior of each method on ByobByteStreamReader without detailed algorithm (5056a21)

[streams] Do we need error-after-drain functionality? (#172)

[streams] Do we need to pass enqueue and close as parameters to UnderlyingSource.pull? (#292)

[streams] Ensure the JS thread doesn't have to get hit when piping two streams to each other (#97)

[streams] Factor out portions of a test suite that can be run against already-constructed streams (#264)

[streams] First draft at tee algorithms, for critique (#302)

[streams] Generalized and precise flow/buffer control (#301)

[streams] getting and releasing reader (#297)

[streams] Getting errored/closed reader, Auto-releasing reader, Forcible cancel() on a stream (#297)

[streams] How will ReadableByteStream work with seekable resources? (#253)

[streams] Implement teeing, plus a bunch of stage-setting tweaks (#311)

[streams] Implementation of net.Socket (#305)

[streams] Initial job, with hacks, that seems to work! Some algorithms converted! (7937dc0)

[streams] Introduce readable stream controller class (#310)

[streams] Investigate (F)RP literature (#88)

[streams] Is Node's "unshift" necessary? (#3)

[streams] Made "Multiple readers can access the stream in sequence" test robust (#306)

[streams] Making the "queue manipulator (#309)

[streams] Making the "queue manipulator" its own class (#309)

[streams] Maybe giving async readInto (and read?) another shot (#290)

[streams] Move algorithms to Ecmarkup/Ecmarkdown (02e0a64)

[streams] New proposal for byte stream uses cases (#289)

[streams] Operation stream (#287)

[streams] Performance Check vs. Node Streams (#304)

[streams] Prototyping several changes for better support for reading bytes (#287)

[streams] ReadableByteStreams: missing APIs (#176)

[streams] ReadableStream.getReader name is a bit misleading (#308)

[streams] Requirement on promises equality (#266)

[streams] Should readable streams start right away? (#269)

[streams] simpler, less stateful basic streams? (#104)

[streams] Support reading bytes into buffers allocated by user code on platforms where only async read is available (#253)

[streams] Test ReadableStream does not call pull multiple times after previous pull finishes is incorrectly specified. (#291)

[streams] Throw on underlying source double-close or double-error (#303)

[streams] Update ReadableByteStream to follow the style rule employed for the main... (#283)

[streams] Warning misbehaving underlying sources (#298)

[streams] What should we call ReadableByteStream.prototype.getBYOBReader()? (#294)

[streams] What types does ReadableByteStream's reader's read(x) accept and return? (#295)

[streams] Why is the reference implementation calling promise callbacks synchronously? (#293)

[touch-events] Define the ontouch* event handler attributes (#11)

[touch-events] Note about PFWG's non-normative event mapping document (#4)

[touch-events] Setup IRC hook for commits (#1)

[touch-events] Touch Event Extensions note should add arguments to CreateTouch (#12)

[touch-events] TouchEvent should have a constructor (#10)

[webcomponents] add autolinking as a preprocessor (#36)

[webcomponents] inflexible extends as fixed element type (#33)

[webcomponents] Link to CSS Scoping module spec? (#37)

[webidl] Add a platform object [[Set]] internal method so we can have prototype setters show through even if an object has a named property of the same name and can have named creators work correctly on [OverrideBuiltins] objects even if thre is a property with the same name on the prototype. (#45)

[webidl] Make the DOMException constructor accept a name (#22)

Last message date: Tuesday, 31 March 2015 23:37:29 UTC