public-webapps-github@w3.org from May 2018 by subject

[heycam/webidl] "float" is the name of two distinct things in the grammar (#558)

[heycam/webidl] Allow a mixin to include a mixin (#537)

[heycam/webidl] Async constructors? (`new Foo()` returning Promise<Foo>) (#563)

[heycam/webidl] Disallow multiple keywords for SpecialOperation (#562)

[heycam/webidl] Editorial: deprecate/remove "convert a DOMString to a sequence of Unicode scalar values" (#553)

[heycam/webidl] Fix a wrong description `[LenientThis]` (#560)

[heycam/webidl] How to tell the type of "construct a callback function"? (#557)

[heycam/webidl] Intent to use Constants (#556)

[heycam/webidl] Introduce new string type for names/keys with length limit (#552)

[heycam/webidl] Is a dictionary which has an inherited dictionary with a non-JSON-type member a JSON type? (#555)

[heycam/webidl] iterable's should have more than just forEach() (#561)

[heycam/webidl] Permit [SameObject] for nullable types? (#559)

[heycam/webidl] Remove [LegacyArrayClass] (#291)

[heycam/webidl] Terminal symbol -/. are only in Other, never used elsewhere (#554)

[w3c/clipboard-apis] Clarify promise rejection value (#76)

[w3c/clipboard-apis] Explicitly require current focused document check in algorithm (#78)

[w3c/clipboard-apis] merging official fork of the spec with my fork with changes. (#77)

[w3c/clipboard-apis] test (#77)

[w3c/clipboard-apis] User gesture requirement for Clipboard API access (#52)

[w3c/editing] insertParagraph definition is different from current browsers' behavior when selection is collapsed at end of inline element(s) (#172)

[w3c/editing] Should deleting cell's content on a table inside a contenteditable area imply the whole table has to be deleted ? (#163)

[w3c/editing] Standardize execCommand("insertParagraph") in inline editing host (#175)

[w3c/FileAPI] Define WebKit's underlying file changes behavior (#47)

[w3c/FileAPI] Disallow mutating state of Blob/File objects (#75)

[w3c/FileAPI] Does the specification define input[type=file] .files expected behaviour to relevant to reflecting real-time changes to user selected file? (#99)

[w3c/gamepad] Add [Exposed] to all interfaces (#63)

[w3c/gamepad] Add missing type argument to the GamepadEvent constructor (#51)

[w3c/gamepad] GamepadEvent constructor is missing the type argument (#35)

[w3c/gamepad] spec vibrationActuator gamepad extension (#68)

[w3c/gamepad] Standard mapping image should be described in text (#57)

[w3c/gamepad] Wide review tracker (#69)

[w3c/IndexedDB] Add IDBFactory/databases() (#240)

[w3c/IndexedDB] API to enumerate databases (#31)

[w3c/IndexedDB] Draft of IDBFactory/databases() (#240)

[w3c/IndexedDB] How should commit() failures be surfaced when freezing / unloading (#237)

[w3c/IndexedDB] Intent to begin work on Indexed Database API 3.0 (#239)

[w3c/IndexedDB] Make "cleanup IDB transactions" return a value (#232)

[w3c/IndexedDB] Proposal: Add "writeonly" transaction mode (#234)

[w3c/IndexedDB] Update the web-platform-tests URL (#241)

[w3c/IndexedDB] WindowOrWorkerGlobalScope is a mixin (#238)

[w3c/manifest] (editorial) Fix a broken local reference (#682)

[w3c/manifest] Ability to dynamically change app icon (#663)

[w3c/manifest] Add (optional) "category" member (#569)

[w3c/manifest] Add optional `author` member (#675)

[w3c/manifest] Add optional `translations` member (#676)

[w3c/manifest] Add support for "share_target" property (#665)

[w3c/manifest] Added an Uninstallation section. (#678)

[w3c/manifest] App shortcuts / actions (#582)

[w3c/manifest] beforeinstallprompt not firing automatically (#680)

[w3c/manifest] Clarify rule of navigating away from the navigation scope (#646)

[w3c/manifest] Display mode "standalone" inconsistently handled by browsers (#673)

[w3c/manifest] Document the unique identifier or tuple of identifiers for a PWA (#586)

[w3c/manifest] Editorial fix to the `orientation` member (#672)

[w3c/manifest] editorial: fix a broken local reference (#682)

[w3c/manifest] editorial: use auto pluralize (#683)

[w3c/manifest] Fix some text relating to fullscreen display mode (#679)

[w3c/manifest] Make unbounded navigation scope less broad (#550)

[w3c/manifest] Manifest processing should not be a function of document URL (#668)

[w3c/manifest] minimal-ui "similar to fullscreen" should read "similar to standalone" (#677)

[w3c/manifest] Misc chores (#671)

[w3c/manifest] Question: Able to manually call beforeinstallprompt event? (#674)

[w3c/manifest] Remove the default value for start_url (#670)

[w3c/manifest] start_url should be mandatory (#669)

[w3c/manifest] start_url should not default to document URL (#669)

[w3c/manifest] Updated Blink implementation status to point to Chrome Platform Status. (#681)

[w3c/manifest] Use case for appuninstall event (#636)

[w3c/manifest] Use WebIDL to describe the manifest data structure (#611)

[w3c/permissions] Add optional consent due to GDPR (#169)

[w3c/permissions] Clarify/resolve elationship of PermissionName enum values to Feature Identifier values (#177)

[w3c/permissions] Clipboard permissions (#175)

[w3c/permissions] Delineate relationship between Permissions and Feature Policy (#176)

[w3c/permissions] describe implicitly-granted permissions (#178)

[w3c/permissions] Using Web IDL to describe WebDriver JSON is a bit unusual (#174)

[w3c/pointerlock] movementX/Y to be double instead of long (#24)

[w3c/push-api] A subscription with a different application server key already exists. (#296)

[w3c/push-api] Any overview of spec implementation status for browsers? (#295)

[w3c/push-api] customize push server (#293)

[w3c/push-api] Update privacy and server choice... (#294)

[w3c/quota-api] Fix WebIDL grammar mistake in index.html (#14)

[w3c/screen-orientation] "Security" condition should be something else (#82)

[w3c/screen-orientation] "unlocked" not explicitly defined (#81)

[w3c/screen-orientation] Add interaction with WCAG 2.1 (#117)

[w3c/screen-orientation] Add Privacy and Security Considerations section (#115)

[w3c/screen-orientation] Clarify in which animation frame task events are fired (#97)

[w3c/screen-orientation] Clarify orientation.angle behavior (#79)

[w3c/screen-orientation] Clarify the behavior of ScreenOrientation.angle (#114)

[w3c/screen-orientation] Deal with fragment navigation (#87)

[w3c/screen-orientation] more detailed privacy considerations (#116)

[w3c/screen-orientation] Orientation angle cannot be precisely mapped to orientation type for devices with 1:1 screen size ratio (#99)

[w3c/screen-orientation] Spec is unclear about how locks work across multiple screens and display context switches (#105)

[w3c/screen-orientation] Steps for updating orientation information are misleading (#100)

[w3c/screen-orientation] Where are terms 'primary' and 'secondary' defined within spec? (#113)

[w3c/ServiceWorker] A way to control which client (or type of client) receives a navigation (#758)

[w3c/ServiceWorker] Allow active service worker to manage fetch for the update logic (#1318)

[w3c/ServiceWorker] Building Spec: 9a6b738771d1e3d235b539bbdc896e88803573e8 (#1314)

[w3c/ServiceWorker] Clients.get: block on reserved clients. (#1315)

[w3c/ServiceWorker] consider allowing multiple worker thread instances for a single registration (#756)

[w3c/ServiceWorker] Expose GeoLocation to workers (#745)

[w3c/ServiceWorker] Handle Fetch does a dubious SecureContext check on a reserved client (#1311)

[w3c/ServiceWorker] importScripts() on ServiceWorkerGlobalScope (#1319)

[w3c/ServiceWorker] Is it possible to register a service worker on a not fully HTTPS webapp? (#1317)

[w3c/ServiceWorker] Is resultingClientId preserved over redirects? (#1316)

[w3c/ServiceWorker] Query Cache algorithm should copy objects it manipulates (#1320)

[w3c/ServiceWorker] Remove foreign fetch (#1188)

[w3c/ServiceWorker] serviceworker for iframes with srcdoc (#765)

[w3c/ServiceWorker] should document.open() inherit the controller (#1313)

[w3c/ServiceWorker] should document.open() inherit the controller? (#1313)

[w3c/ServiceWorker] sometimes, we cannot find the request in webview when we use the serviceworker (#1312)

[w3c/ServiceWorker] The Cache objects do not expire unless authors *or users* delete the entries. (#1276)

[w3c/ServiceWorker] When should "imported scripts updated flag" be unset? (#1021)

[w3c/uievents] Add a note about inheritance of UIEvent. (#178)

[w3c/uievents] Add specification for AltGraph key & modifier behaviour (#147)

[w3c/uievents] Needs alternative WheelEvent.deltaMode, WheelEvent.delat(X|Y|Z) (#181)

[w3c/webcomponents] [imports]: The relationship between import and browsing context should be stated more clearly (bugzilla: 26682) (#197)

[w3c/webcomponents] [Template Instantiation] Layering and additional use cases (#747)

[w3c/webcomponents] changing slot text node is overly verbose (#753)

[w3c/webcomponents] Custom 'void' or self-closing elements (HTML parser changes) (#624)

[w3c/webcomponents] How should various document internal references work when SVG is being used in shadow DOM (#179)

[w3c/webcomponents] HTML module should require a new MIME type (#742)

[w3c/webcomponents] HTML module should require a new top level element (#752)

[w3c/webcomponents] HTML Modules (#645)

[w3c/webcomponents] Isolate (#751)

[w3c/webcomponents] Isolate WebComponent JS libraries (#751)

[w3c/webcomponents] Need callback for form submit data (#187)

[w3c/webcomponents] Provide a lightweight mechanism to add styles to a custom element (#468)

[w3c/webcomponents] The is="" attribute is confusing? Maybe we should encourage only ES6 class-based extension. (#509)

[w3ctag/design-reviews] `sec-metadata` (#280)

[w3ctag/design-reviews] Async local storage (#278)

[w3ctag/design-reviews] Background fetch (#279)

[w3ctag/design-reviews] BCP56bis (#232)

[w3ctag/design-reviews] Carriage of Web Resource in ISOBMFF (#285)

[w3ctag/design-reviews] CSS ::part and ::theme pseudo elements (#230)

[w3ctag/design-reviews] CSS Logical Properties and Values (#286)

[w3ctag/design-reviews] Deprecating nonsecure cookie delivery. (#239)

[w3ctag/design-reviews] Dusting off Web Speech API? (#214)

[w3ctag/design-reviews] HTML General Review: HTML Ruby (#248)

[w3ctag/design-reviews] HTML General Review: Web Sockets (#268)

[w3ctag/design-reviews] Keyboard Map (#238)

[w3ctag/design-reviews] Layered APIs (#276)

[w3ctag/design-reviews] Notification Inline Replies (#284)

[w3ctag/design-reviews] Page Lifecycle for system initiated Discarding & Freezing (#283)

[w3ctag/design-reviews] Payment Handler (#231)

[w3ctag/design-reviews] Permission Delegation (#225)

[w3ctag/design-reviews] ReportingObserver (#195)

[w3ctag/design-reviews] Request review of (text only) Async Clipboard API (#222)

[w3ctag/design-reviews] Request review of Gamepad API (#281)

[w3ctag/design-reviews] Request TAG review of HTML5.3 (#275)

[w3ctag/design-reviews] Review Accessibility Object Model (#134)

[w3ctag/design-reviews] Review OffscreenCanvas, including ImageBitmapRenderingContext (#141)

[w3ctag/design-reviews] Review request for WebVR (#185)

[w3ctag/design-reviews] Review Request: WebUSB on Dedicated and Shared Workers (#277)

[w3ctag/design-reviews] Signed Exchanges (#235)

[w3ctag/design-reviews] Spatial Navigation (#287)

[w3ctag/design-reviews] TextEncoderStream and TextDecoderStream (#282)

[w3ctag/design-reviews] Web Components Guidelines Doc? (#227)

[w3ctag/design-reviews] Web Share Target API (#221)

[whatwg/dom] Add AbstractRange and StaticRange (#589)

[whatwg/dom] Change DOMTokenList's replace() to return boolean (#582)

[whatwg/dom] Define cloning steps for an select element (#644)

[whatwg/dom] Determine spec of copying the internal state of node when "clone a node" (#644)

[whatwg/dom] Editorial: improve clarity in event dispatch model (#645)

[whatwg/dom] Editorial: improve clarity in event dispatch model`` (#645)

[whatwg/dom] Editorial: make traverser object associations more explicit (#631)

[whatwg/dom] form.disabled to disable the form submission (#646)

[whatwg/dom] Iterable NamedNodeMap (#648)

[whatwg/dom] Meta: fix link to the DOM Standard twitter page (#649)

[whatwg/dom] Meta: Review Draft infrastructure (#650)

[whatwg/dom] No longer allow the context object to be omitted (#647)

[whatwg/encoding] "html" error mode somewhat incompatible with URLs (#139)

[whatwg/encoding] Add Streams Explainer (#143)

[whatwg/encoding] Add Streams support (#72)

[whatwg/encoding] Allow conformant implementations to support non-UTF-8 encodings (#144)

[whatwg/encoding] Be clearer on which user agents the API applies to (#136)

[whatwg/encoding] Include the character whose pointer is zero in BMP coverage visualizations (#140)

[whatwg/encoding] Meta: remove FTP dependency from tools-index.py (#141)

[whatwg/encoding] Meta: Review Draft infrastructure (#145)

[whatwg/encoding] Meta: use HTTPS rather than FTP for UnicodeData.txt (#142)

[whatwg/encoding] Non-browser versus JavaScript (#87)

[whatwg/fetch] "construct a ReadableStream object" doesn't specify the realm (#730)

[whatwg/fetch] "no-cors" POST and 307/308 redirects (#593)

[whatwg/fetch] Abort refactoring led to variable errors (#706)

[whatwg/fetch] Add Accept-CH-lifetime cache and CH header handling (#729)

[whatwg/fetch] Add device-memory and network quality client hints to the list (#725)

[whatwg/fetch] Add Request's isHistoryNavigation (#718)

[whatwg/fetch] Add several ports to the "bad ports" list. (#482)

[whatwg/fetch] Add three new client hint headers to the fetch spec: rtt, downlink, ect (#720)

[whatwg/fetch] Add { 548, 'afp' } to the blocked bad ports (#694)

[whatwg/fetch] Allow range header to be set by APIs (#560)

[whatwg/fetch] Associate import() with the "script" destination (#724)

[whatwg/fetch] Avoid using the CORS flag to reset request's origin in redirects (#594)

[whatwg/fetch] Block AFP ports (427, 548) (#738)

[whatwg/fetch] Block more X11 ports? (#740)

[whatwg/fetch] Browsers preserve fragments on redirects (#505)

[whatwg/fetch] Cache-mode and upstream Cache-Control (#722)

[whatwg/fetch] Client hints difference between navigation and subresources (#707)

[whatwg/fetch] consider exposing and allowing script to set Request priority (#436)

[whatwg/fetch] CORB: 3xx redirects, 304, 401, and 407 responses (#728)

[whatwg/fetch] CORB: blocking of nosniff and 206 responses (#686)

[whatwg/fetch] CORB: empty response VS erroring out (#727)

[whatwg/fetch] CORS request-header Content-Type check should be on a combined value (#748)

[whatwg/fetch] CORS-preflight fetch (#741)

[whatwg/fetch] Cross-Origin Read Blocking (CORB) (#681)

[whatwg/fetch] Define Cross-Origin-Resource-Policy response header (#733)

[whatwg/fetch] Editorial: avoid normative keywords in domintro block (#734)

[whatwg/fetch] Editorial: replace UTF-8 encode with isomorphic encode (#742)

[whatwg/fetch] Editorial: turn CORS-preflight cache into a list (#744)

[whatwg/fetch] Expose Content-Length header in CORS requests (#622)

[whatwg/fetch] fetch() "no-cors": cross-origin to same-origin redirect taints response (#737)

[whatwg/fetch] Fixing variable definitions and scoping. Fixes #706. (#749)

[whatwg/fetch] From-Origin (#687)

[whatwg/fetch] Further cleanup the CORS-preflight cache (#735)

[whatwg/fetch] Integrate Acccept-CH-Lifetime to populate "client hint list" (#566)

[whatwg/fetch] Integrate latest Client Hints updates (#726)

[whatwg/fetch] Make CORS-preflight fetches set the CORS flag (#743)

[whatwg/fetch] Meta: Review Draft infrastructure (#746)

[whatwg/fetch] More CORB-protected MIME types (#721)

[whatwg/fetch] Move definition of "reload-navigation flag" (#739)

[whatwg/fetch] Move definition of reload-navigation flag (#732)

[whatwg/fetch] Nghi's (#723)

[whatwg/fetch] Odd format for fetch callbacks (#536)

[whatwg/fetch] Port blocking: "Typical service" (#750)

[whatwg/fetch] Proposal: `Sec-Site` should capture information about the requester of a resource (#700)

[whatwg/fetch] Response body stream from SW has wrong realm (#731)

[whatwg/fetch] Safelist Content-Length header (#626)

[whatwg/fetch] Some servers seem to expect 'Accept-Encoding : identity' to serve Range requests (#747)

[whatwg/fetch] Strengthen requirements on CORS-safelisted request-headers (#736)

[whatwg/fetch] Support full-duplex HTTP streaming (#229)

[whatwg/fetch] Update Fetch to support Token Binding (#715)

[whatwg/fetch] Update WPT link (#745)

[whatwg/fetch] Vary HTTP cache on credentials mode (#307)

[whatwg/fullscreen] Adjust algorithm for FullyExitFullscreen. (#126)

[whatwg/fullscreen] Meta: add id=removing-steps for linkability of the removing steps (#127)

[whatwg/fullscreen] Meta: Review Draft infrastructure (#125)

[whatwg/fullscreen] Remove from top layer synchronously for not connected elements (#128)

[whatwg/fullscreen] Remove nodes from top layer as part of the removing steps (#102)

[whatwg/storage] Meta: Review Draft infrastructure (#62)

[whatwg/streams] A couple Bikeshed warnings (#929)

[whatwg/streams] Add some missing exclamation marks (#927)

[whatwg/streams] Add two demos using streams for PNG manipulation (#911)

[whatwg/streams] Assert that desiredSize is non-null in ReadableStreamDefaultControllerShouldCallPull (#919)

[whatwg/streams] Changes to Example 8.9: Fix code issue, add const, add text decode step (#924)

[whatwg/streams] Communication between workers/windows via Streams API (#244)

[whatwg/streams] Meta: Review Draft infrastructure (#928)

[whatwg/streams] Numeric conversion is not done on autoAllocateChunkSize (#921)

[whatwg/streams] ReadableStream constructor: standard text and reference implementation doesn't match (#917)

[whatwg/streams] reader.read() inside strategy.size() doesn't work (#794)

[whatwg/streams] Remove preconditions from ReadableStreamDefaultControllerError (#925)

[whatwg/streams] Run ReadableStream tests against ReadableByteStream (#217)

[whatwg/streams] ShouldCallPull: Assert desiredSize is not null (#926)

[whatwg/streams] What are the preconditions for ReadableStreamDefaultControllerError? (#920)

[whatwg/url] Change query state slightly to better deal with non-UTF-8 encodings (#386)

[whatwg/url] Consider adding support for fragment parameters (#389)

[whatwg/url] Define hosts' public suffix and registrable domain. (#391)

[whatwg/url] Disallow comma in hosts (#390)

[whatwg/url] Give host parser a suitable default for the HTML Standard (#388)

[whatwg/url] How should "everything after the scheme" URLs work? (#385)

[whatwg/url] Investigate aligning application/x-www-form-urlencoded with URL's query (#18)

[whatwg/url] Meta: Review Draft infrastructure (#387)

[whatwg/url] Remove 'type' from from data entries. (#384)

[whatwg/xhr] Abandon hope of removing sync XHR from the web platform? (#20)

[whatwg/xhr] Don't fire "progress" event for sync XHR (#208)

[whatwg/xhr] Error : Snychronous XMLHttpRequest on main thread is deprecated (#209)

[whatwg/xhr] Meta: Review Draft infrastructure (#211)

[whatwg/xhr] Remove 'type' mapping for 'entry'. (#206)

[whatwg/xhr] Replace "form data set" with "entry list" to follow an HTML specifica… (#210)

[whatwg/xhr] Should sync XHR fire a progress event? (#207)

Last message date: Thursday, 31 May 2018 23:58:06 UTC