public-webapps-github@w3.org from April 2021 by subject

[heycam/webidl] `record<unsigned short, ...` (#978)

[heycam/webidl] Allow constants on namespaces (#977)

[heycam/webidl] Dictionary mixins (#195)

[heycam/webidl] Dictionary types being nullable doesn't make sense (#967)

[heycam/webidl] Does it make sense for an interface mixin to declare [Default] object toJSON()? (#979)

[heycam/webidl] Editorial: simplify the example on default toJSON() (#980)

[heycam/webidl] More fixes for `undefined` (#965)

[heycam/webidl] Replace the word "quoted" from IDL grammar section (#976)

[heycam/webidl] Session idea: Using BikeShed (#975)

[heycam/webidl] Session idea: using ReSpec (#974)

[heycam/webidl] undefined can't be a member of a union type (#962)

[heycam/webidl] update Ecmarkup link (#973)

[heycam/webidl] What does FrozenArray mean in dictionaries? (#900)

[w3c/DOM-Parsing] Editorial: Align with Web IDL specification (#64)

[w3c/editing] [charter] "on the web" implies protocol work; does this charter expect any? (#297)

[w3c/editing] [charter] Background: purely editorial (#298)

[w3c/editing] [charter] consider a more specific name for the Group (#296)

[w3c/editing] [charter] Define the Success Criteria (#281)

[w3c/editing] [charter] describe deliverables (#294)

[w3c/editing] [charter] publication status link broken (#293)

[w3c/editing] [charter] rename the group and update the success criteria (#301)

[w3c/editing] [charter]describe deliverables, align with the latest template (#295)

[w3c/editing] Add subscript command to overview, fixes #288 (#290)

[w3c/editing] INPUT/TEXTAREA should support subset of execCommand (#160)

[w3c/editing] Should EditContext be associated with a Node representing the "view"? (#300)

[w3c/editing] Should we modify the clipboard API spec to match Safari's behavior for HTML-referenced media? (#285)

[w3c/editing] Updated the intro material to better reflect the current status. (#302)

[w3c/editing] Updates to execCommand spec (#288)

[w3c/editing] Web developers cant get phonetic runs that are sent from some East Asian IMEs (#299)

[w3c/FileAPI] Align with ReadableStream changes (#165)

[w3c/FileAPI] CI: Enable autopublishing to W3C TR space (#167)

[w3c/FileAPI] CI: Set W3C status in spec-prod config file (#168)

[w3c/FileAPI] Clarify UUID version (#163)

[w3c/FileAPI] Editorial: Change index.bs status to WD (from ED) (#168)

[w3c/FileAPI] Editorial: move from context object to this (#164)

[w3c/FileAPI] features request:add SynFileReader for Avoid Callback Hell Programming from FileReader (#162)

[w3c/FileAPI] fix: no special character replacement in fileName (#171)

[w3c/FileAPI] Issues with MIME types (#170)

[w3c/FileAPI] Remove Previous Version from .bs file (#169)

[w3c/FileAPI] Remove the / -> : replacement from the File constructor (#41)

[w3c/FileAPI] Update stream creation and manipulation (#166)

[w3c/FileAPI] Use GitHub workflows instead of travis.org for CI and publishing. (#160)

[w3c/gamepad] Add gamepad light indicator extension (#143)

[w3c/gamepad] Add global event handler attributes (#144)

[w3c/gamepad] Define ongamepadconnected/ongamepaddisconnected attributes (#141)

[w3c/gamepad] Fast button presses could get lost (#77)

[w3c/gamepad] GamepadHapticActuator pulse should support frequency parameter (#148)

[w3c/IndexedDB] boolean should be a valid key (#76)

[w3c/IndexedDB] Define flush-to-disk guarantees and control (#50)

[w3c/manifest] [WIP] i18n Self Review (#971)

[w3c/manifest] Add a unique identifier for a PWA (#586)

[w3c/manifest] Add optional `translations` member (#676)

[w3c/manifest] Add protocol handlers to the explainer and spec (#863)

[w3c/manifest] Adding protocol handlers (#972)

[w3c/manifest] Adding protocolhandlers (#969)

[w3c/manifest] Change the default value for start_url (#670)

[w3c/manifest] Could you review Chrome/Firefox implementation regarding `fullscreen` display mode on Mac? (#934)

[w3c/manifest] Editorial: clarify what document URL is (#959)

[w3c/manifest] Editorial: remove installability signals (#966)

[w3c/manifest] Editorial: remove word 'chrome' when talking about fullscreen (#960)

[w3c/manifest] Extension of the Application Manifest -> MiniApps Manifest (#974)

[w3c/manifest] manifest.webmanifest or manifest.json (#689)

[w3c/manifest] Media type registration: `charset` optional parameter (#973)

[w3c/manifest] multiple natural language text fields share language/direction [I18N] (#968)

[w3c/manifest] processing a manifest steps refer to "document URL", but doesn't define what that URL is (#946)

[w3c/manifest] Register media type with IANA (#970)

[w3c/manifest] related_applications is single engine feature (#956)

[w3c/manifest] Remove query & fragment components from scope URL (#961)

[w3c/manifest] Scope should remove the query and fragment at parse time (#793)

[w3c/manifest] User-approved permissions (#967)

[w3c/permissions] Add "gamepad" permission (#200)

[w3c/permissions] Add "payment" permission (#239)

[w3c/permissions] Add "web-share" to PermissionName? (#236)

[w3c/permissions] Add Gamepad permission (#200)

[w3c/permissions] Editorial: cleanup (#238)

[w3c/permissions] Explicitly limit permission lifetimes (#231)

[w3c/permissions] Permission lifetimes (#233)

[w3c/permissions] PermissionStatus should have a `name` (#237)

[w3c/permissions] previousResult not really stored anywhere (#234)

[w3c/permissions] Remove clipboard-read (#222)

[w3c/permissions] Remove clipboard-read from PermissionName (#228)

[w3c/permissions] Should we SecureContext the API (#235)

[w3c/permissions] The "prompt" permission state maps poorly across browsers (#230)

[w3c/permissions] Use media device permission revocation algorithm. (#225)

[w3c/push-api] userVisibleOnly should be standardized to match browser behaviour (#313)

[w3c/ServiceWorker] <object> having issue with service workers registration, failing with error message Service worker registration failed with: DOMException: Failed to register a ServiceWorker: The document is in an invalid state. (#1546)

[w3c/ServiceWorker] [BUG] setTimeout/setInterval mix with importScripts leads to DOMExeption (#1580)

[w3c/ServiceWorker] Adapt to policy container (#1588)

[w3c/ServiceWorker] Add note that chunking is not preserved with ReadableStream. (#1583)

[w3c/ServiceWorker] Allow service workers to detect light/dark mode (#1577)

[w3c/ServiceWorker] Exempt path restriction for for static import in a module service worker (#1586)

[w3c/ServiceWorker] Expose a "service worker timing info" struct (#1581)

[w3c/ServiceWorker] Expose GeoLocation to workers (#745)

[w3c/ServiceWorker] Feature detection for type="module" support (#1582)

[w3c/ServiceWorker] fetch request catching in service worker with iframe (#1587)

[w3c/ServiceWorker] How should import() work in service workers? (#1585)

[w3c/ServiceWorker] Maintain timing for worker start/ready, for navigation requests. (#1575)

[w3c/ServiceWorker] New "setup" lifecycle for service worker (#1576)

[w3c/ServiceWorker] Old React.JS App with sw.js never ditches and switches to new Svelte.JS App with service-worker.js (#1578)

[w3c/ServiceWorker] Service worker fetch request problem with iframe (#1589)

[w3c/ServiceWorker] Service worker struct should be exported without a 'for' attribute (#1590)

[w3c/ServiceWorker] Service Worker Subresource Filter (#1584)

[w3c/ServiceWorker] Should synthetic responses be validated? (#1571)

[w3c/ServiceWorker] Using BroadcastChannel to wake up a service worker (#975)

[w3c/uievents] Add [Exposed=Window] to interface MutationEvent (#304)

[w3ctag/design-reviews] API for display-capturing the current tab (#625)

[w3ctag/design-reviews] App history API (#605)

[w3ctag/design-reviews] ARIA in HTML review (#614)

[w3ctag/design-reviews] Back/Forward Cache (#628)

[w3ctag/design-reviews] CanvasRenderingContext2D API Improvements (#627)

[w3ctag/design-reviews] Client Hint Reliability mechanisms (#549)

[w3ctag/design-reviews] Compute Pressure API (#621)

[w3ctag/design-reviews] CORS-RFC1918 (#572)

[w3ctag/design-reviews] Cryptographically secure random UUIDs (#623)

[w3ctag/design-reviews] CSS Scrollbars: scrollbar-color, scrollbar-width (#563)

[w3ctag/design-reviews] CSS: contain-intrinsic-size: auto, and converting to a shorthand property (#624)

[w3ctag/design-reviews] Declarative Link Capturing (#589)

[w3ctag/design-reviews] Early design review for the FLoC API (#601)

[w3ctag/design-reviews] Early design review of modal close signals/ModalCloseWatcher (#594)

[w3ctag/design-reviews] Early design review: Sanitizer API (#619)

[w3ctag/design-reviews] First-Party Sets (#342)

[w3ctag/design-reviews] Managed Device Web API (#606)

[w3ctag/design-reviews] MediaStreamTrack Insertable Media Processing using Streams (#603)

[w3ctag/design-reviews] Realms API ECMAScript Proposal (#542)

[w3ctag/design-reviews] Storage Buckets API (#562)

[w3ctag/design-reviews] Virtual Keyboard API - boundaries of docked overlay keyboard (#507)

[w3ctag/design-reviews] VirtualKeyboard API - show/hide policy (#498)

[w3ctag/design-reviews] WebCodecs (again!) (#612)

[w3ctag/design-reviews] WebGPU and WGSL (#626)

[w3ctag/design-reviews] WebID (#622)

[w3ctag/design-reviews] WebXR Plane Detection Module (#620)

[whatwg/dom] " 4.3.1. Interface MutationObserver" (#967)

[whatwg/dom] `:active` pseudo-class specification doesn't account for children of disabled form elements (#976)

[whatwg/dom] Add Imperative Slot API (#860)

[whatwg/dom] Add Imperative Slot API (#966)

[whatwg/dom] Add ShadowRoot.prototype.delegatesFocus attribute (#974)

[whatwg/dom] Add the IDL of XSLTProcessor (#972)

[whatwg/dom] Allow custom "get the parent" algorithms for EventTargets (#583)

[whatwg/dom] Declarative Shadow DOM (#831)

[whatwg/dom] Define XSLTProcessor (#181)

[whatwg/dom] Disconnect single target instead of all (#126)

[whatwg/dom] Editorial: major change to align with IDL and Infra (#969)

[whatwg/dom] Editorial: remove context object concept (#973)

[whatwg/dom] Editorial: use modern dictionary syntax (#970)

[whatwg/dom] Expose document fragment serialization algorithm (#965)

[whatwg/dom] Increase the ability to query whether the host environment supports a specific event (#968)

[whatwg/dom] Make ShadowRoot.prototype.delegatesFocus mutable? (#975)

[whatwg/dom] Meta: remove redundant quotes (#971)

[whatwg/dom] Proposal: New method to reorder child nodes (#891)

[whatwg/dom] Proposal: ParentNode.replaceAll() / ParentNode.replaceChildren() (#478)

[whatwg/dom] Proposal: Storage Access API (#560)

[whatwg/dom] ShadowRoot's delegatesFocus (#931)

[whatwg/dom] Support `AbortSignal`s in `addEventListener`s options to unsubscribe from events? (#911)

[whatwg/encoding] Big5 encoding mishandles some trailing bytes, with possible XSS (#171)

[whatwg/fetch] "no-cors" and credentials mode (#169)

[whatwg/fetch] @ (#1223)

[whatwg/fetch] [Accessibility] Declarative permissions in parent scope for filesystem access via fileURLs (#1210)

[whatwg/fetch] [Security] Declarative network permissions in parent scope for safe request default mode (#1209)

[whatwg/fetch] [Suggestion] Add more per-file (custom) header to multipart (#1130)

[whatwg/fetch] Add a flow diagrams for in-browser/client-side request flow and response flow (#1227)

[whatwg/fetch] Add a limited size buffer for streaming upload in HTTP request. (#1204)

[whatwg/fetch] Add chunk type checking of requestForServiceWorker's body's stream (#1199)

[whatwg/fetch] Allow detecting whether request method has changed (e.g. due to redirect) (#1212)

[whatwg/fetch] B (#1222)

[whatwg/fetch] Block port 10080 (#1214)

[whatwg/fetch] Block subresource requests whose URLs include credentials. (#465)

[whatwg/fetch] Clarify which network errors create a resource timing entry (#1215)

[whatwg/fetch] Consider shifting the "bad port list" to an allowlist. (#1189)

[whatwg/fetch] Editorial: tweak wording for "The Web Origin Concept" obsolescence (#1206)

[whatwg/fetch] Expose `transfer size` for resource timing (#1203)

[whatwg/fetch] Fetch (#1211)

[whatwg/fetch] FetchObserver (for a single fetch) (#607)

[whatwg/fetch] Hanan (#1219)

[whatwg/fetch] Headers object's guard (request-no-CORS) (#9)

[whatwg/fetch] hi (#1218)

[whatwg/fetch] Hi (#1220)

[whatwg/fetch] Integrate early hints https://tools.ietf.org/html/rfc8297 (#1225)

[whatwg/fetch] Limit the network stack replay cache on uploading if body is stream. (#1204)

[whatwg/fetch] Meta: anchor HR-TIME and RESOURCE-TIMING terms (#1224)

[whatwg/fetch] New Resource Timing issues (#1201)

[whatwg/fetch] processResponseDone should receive a response (#1202)

[whatwg/fetch] Prohibit file: URL access from non-file: URLs (#1195)

[whatwg/fetch] Request body streams that cannot be retried (#538)

[whatwg/fetch] Request with GET/HEAD method cannot have body. (#551)

[whatwg/fetch] Script-created redirects responses have no location URL (#1146)

[whatwg/fetch] Should credentialed, same-site, cross-origin requests be easier to enable? (#1226)

[whatwg/fetch] Should we block port 10080? (#1191)

[whatwg/fetch] TAO check and child frame navigations (#1221)

[whatwg/fetch] Use a ReadableStream with byte source (formerly called ReadableByteStream) for .body (#267)

[whatwg/fetch] Use structured fields for CORS headers (#1216)

[whatwg/fetch] When response comes from a worker, some of the timing-info should pass through (#1208)

[whatwg/storage] Persistence for data structures other than key-value store (#125)

[whatwg/streams] Add piping helpers for other specs (#1113)

[whatwg/streams] Allow other specifications to create readable byte streams (#1121)

[whatwg/streams] Editorial: fix links to WritableStreamController methods (#1120)

[whatwg/streams] Fix cancelPromise in ReadableStreamTee being resolved twice (again) (#1118)

[whatwg/streams] Permitting transferable stream optimisation (#1124)

[whatwg/streams] ReadableStream.from(asyncIterable) (#1083)

[whatwg/streams] Support teeing readable byte streams (#1114)

[whatwg/streams] Test: "default ReadableStream getReader() should only accept mode:undefined" (#1122)

[whatwg/streams] Various fixes for readable byte streams (#1123)

[whatwg/url] Add a note that `searchParams` is not unicode-aware (#596)

[whatwg/url] Base URL Windows drive sometimes favoured over input string drive (#574)

[whatwg/url] Consider adding a constructor to make a URL from parts (#354)

[whatwg/url] Option to avoid unnecessary trailing ='s in search params (#594)

[whatwg/url] Parsing square brackets ([]) in path, query, and fragment (#595)

[whatwg/url] Proposal of .toString({ concise: true }) for nicer output with empty values (#469)

[whatwg/xhr] features request:add SynXMLHttpRequest for Avoid Callback Hell Programming (#323)

[whatwg/xhr] Resource Timing integration (#319)

[WICG/webcomponents] "open-stylable" Shadow Roots (#909)

[WICG/webcomponents] [idea] New Lifecycle Callback: `willConnectCallback` for initializing attributes (#919)

[WICG/webcomponents] [scoped-registries] Element upgrade ordering (#923)

[WICG/webcomponents] [scoped-registries] Interaction with declarative shadow DOM (#914)

[WICG/webcomponents] [Shadow]: url fragment identifiers should be followed into ShadowDOM (bugzilla: 23161) (#66)

[WICG/webcomponents] `:target` failing inside web components. (#924)

[WICG/webcomponents] Add `customElements.upgrade` (#710)

[WICG/webcomponents] Add delegatesLabel and a content attribute to specify the label element within a shadow tree (#916)

[WICG/webcomponents] CSS Shadow Parts Selector ::part() does not work in combination with :disabled pseudo-class in Chrome (#918)

[WICG/webcomponents] Custom 'void' or self-closing elements (HTML parser changes) (#624)

[WICG/webcomponents] How should various document internal references work when SVG is being used in shadow DOM (#179)

[WICG/webcomponents] Issue while exporting calendar event from Microsoft Graph Api (#920)

[WICG/webcomponents] New Lifecycle Callback: `willConnectCallback` for initializing attributes (#919)

[WICG/webcomponents] Provide a mechanism to prevent or coalesce upgrades when defining new custom elements (#922)

[WICG/webcomponents] RfC: API design for aria delegation mechanism (#917)

[WICG/webcomponents] RfC: Expose owner root on shadow root instance (#921)

[WICG/webcomponents] Scoped Custom Element Registries (#716)

[WICG/webcomponents] Scoped Custom Element Registry: Moving elements with shadow roots between documents (#907)

[WICG/webcomponents] Spring 2021 Virtual Meeting (#911)

[WICG/webcomponents] Support for pseudo elements with ::slotted() selectors (#655)

[WICG/webcomponents] Target Event Missing in shadow-root. Cannot apply pure CSS on header. (#924)

[WICG/webcomponents] Theming options for shadow roots (#864)

[WICG/webcomponents] There is no way to navigate to a fragment inside a shadow tree (#924)

Last message date: Friday, 30 April 2021 22:57:52 UTC