public-webapps-github@w3.org from September 2015 by subject

[charter-html] Added RF and licensing statement in success criteria (#128)

[charter-html] Added WebTV IG (#126)

[charter-html] Added WHATWG relatsionships (#121)

[charter-html] Apple comments (#123)

[charter-html] Apple timed media comments (#129)

[charter-html] Call it like it is (#107)

[charter-html] Comments from Josh Soref (#116)

[charter-html] David Singer's comments (#120)

[charter-html] DOM Parsing and Serialization now uses Github (#113)

[charter-html] Find formal resolutions of the group (#118)

[charter-html] Indicate relationship with the WHATWG (#112)

[charter-html] Move some specs towards incubation. Canvas is maintenance. Added WICG. (#124)

[charter-html] Moz comments (#125)

[charter-html] Pointer Lock now uses Github (#114)

[charter-html] Removed webvtt (#127)

[charter-html] Require CfC for group decisions (136bb1f)

[charter-html] Using CfC for Decisions (#117)

[charter-html] Various minor edits (#122)

[charter-html] WebVTT and Caption API from Timed Media (#119)

[clipboard-apis] Should queryCommandEnabled(cut|copy|paste) trigger onbefore* events? (#4)

[clipboard-apis] The ClipboardEvent constructor is strange (#10)

[directory-upload] Consider how HTMLInputElement.getFilesAndDirectories could be used to avoid I/O blocking for FILE picking (#11)

[directory-upload] directory content attribute not defined (#17)

[directory-upload] Don't respecify the superinterface when specifying partial interface HTMLInputElement (#12)

[directory-upload] FileSystem API and this draft conflict (#19)

[directory-upload] getFilesAndDirectories should match that in FileSystem API (#7)

[directory-upload] HTMLInputElement.getFilesAndDirectories should not throw (#20)

[directory-upload] IDL members not defined in terms of "apply" and "do not apply" (#18)

[directory-upload] Is "sequence<File or Directory>" syntax correct/legal? (#9)

[directory-upload] It isn't clear whether Directory.path should include the name of the directory itself (#10)

[directory-upload] polyfill: folder -> directory (#5)

[directory-upload] Repository redirect or Organization redirect to MicrosoftEdge (#4)

[directory-upload] Specify what HTMLInputElement::getFilesAndDirectories returns when the input type is not 'file' (#13)

[directory-upload] The spec should define integration with FormData (#14)

[directory-upload] This should be part of whatwg/html (#15)

[directory-upload] UI musts are a no-no (#16)

[DOM-Parsing] innerHTML needs special case for <template> (#1)

[dom] "A DOMSettableTokenList object is equivalent to ..." (#81)

[dom] Add caniuse info boxes like the HTML spec (#69)

[dom] Add EventListenerOptions (#82)

[dom] Attributes need case-insensitive matching on getting (#41)

[dom] Clarify intro text on non-normative sections (#83)

[dom] Consider banning insertNode() of the Range's start node (#63)

[dom] Consider making `timestamp` a DOMHighResTimestamp (#80)

[dom] Consider specifying document.evaluate and document.createNSResolver (#67)

[dom] Factor getElementsBy* into ParentNode or NonElementParentNode? (#68)

[dom] High resolution timing for events (#23)

[dom] Incorrect link in createEvent definition (#73)

[dom] Make createAttribute() lowercase the input in HTML documents (#72)

[dom] Make createAttribute() lowercase the input in HTML documents (#75)

[dom] Make two loops to adopt a node (#71)

[dom] Missing spaces in rendered spec HTML (#65)

[dom] MutationObserver callbacks should be called before executing defer scritps (#78)

[dom] MutationObserver with querySelector for elements (#77)

[dom] Path HTML's base URL stuff to be in terms of DOM (#61)

[dom] Read-only OS time formatting preferences (#79)

[dom] removeEventListener doesn't handle currently dispatching events (#84)

[dom] Run latest bikeshed (#70)

[dom] Run the adopting steps recursively (#66)

[dom] Should EventInit contain 'timestamp'? (#76)

[dom] Use Boilerplate: omit feedback-header to remove redundant GitHub link (#74)

[editing] change of event names beforeInput -> beforeEdit -> beforeInput? (#87)

[editing] Firefox 41+ supports the cut and copy commands without setting a pref (#89)

[editing] list all required editTypes for beforeEdit/Edit events (#79)

[editing] RESOLUTION: have a relatedEvent to point to the UI event that caused a DI event to be fired (#82)

[editing] The web doesn't need another badly implemented API (#88)

[encoding] Big5 encoder treats a code point as error when both an HKSCS and non-HKSCS pointer exists for the code point (#9)

[fetch] 206/304 handling broken? (#97)

[fetch] Aborting a fetch (#27)

[fetch] Add "Streams" section. (#119)

[fetch] Add a missing quote. (#123)

[fetch] Add description for suspension, resuming and garbage collection. (#121)

[fetch] Add Response.body (#118)

[fetch] allow opaqueredirect to be returned for any Request with "manual" RedirectMode (#127)

[fetch] Allow operation to outlive the document unloading (beacon) (#124)

[fetch] Automatically set request's "Content-Type" to "application/json" for POJOs (#47)

[fetch] blob scheme with non-GET method (#125)

[fetch] Cache mode: security review (#39)

[fetch] Content-Length on HEAD (#135)

[fetch] Creating an ArrayBuffer can fail (#134)

[fetch] Deal with nested browsing contexts (#120)

[fetch] Drafting the patches to HTML (#106)

[fetch] Fix "nosniff?" link in order to avoid anolis bug. (#122)

[fetch] Fix quotation of "error" response type. (#117)

[fetch] Fix typo conneciton -> connection (#133)

[fetch] force-Origin-header flag set for no-cors requests (#91)

[fetch] Handling of data URLs (#111)

[fetch] Introduce "connection pool" and a concept of a "connection" (#114)

[fetch] Introduce "navigate" mode (#126)

[fetch] Introduce Response.body. (#118) (#128)

[fetch] Is it safe to use Fetch API already? (#132)

[fetch] Navigate likely needs to be "no-cors" after all, need to update security checks (#126)

[fetch] Option to require response.ok (#103)

[fetch] POST calls - Request Payload is not shown with native fetch (#59)

[fetch] Preconnect via Fetch? (#114)

[fetch] Proposal: response.xml() (#16)

[fetch] provide a way to construct a new Request from an old Request and an overriding URL (#129)

[fetch] Reconnect and Retry-After (#116)

[fetch] Reference ABNF spec (#131)

[fetch] Request for support for certificate pinning (#98)

[fetch] RequestCredentials "same-origin" does not work in "no-cors" mode (#130)

[fetch] The empty string is rejected as header values (#115)

[fetch] Track request originator. (#45)

[fetch] URLs with username/password (#26)

[FileAPI] Cloning a Blob and then close the original one, does it change the state of the cloned one? (#18)

[FileAPI] Constructing a new blob from a closed blob (#17)

[fullscreen] ::backdrop of root (#24)

[fullscreen] Cannot scroll in IE11 while in fullscreen by Fullscreen API (#23)

[fullscreen] Compute sticky position? (#21)

[fullscreen] Fullscreen on non-HTML elements? (#22)

[fullscreen] Propose not to render ::backdrop if the corresponding element is not rendered (#20)

[fullscreen] Propose to always render elements in the top layer as if it is fixed positioned (#19)

[img-conversion] "The spec includes a section on some potential alternative solutions, including this one" (#9)

[img-conversion] Add explainer document (#1)

[img-conversion] Add explainer document (#7)

[img-conversion] canDecodeType \ canEncodeType could be "supports" (#12)

[img-conversion] canDecodeType \ canEncodeType could be supports() (#12)

[img-conversion] Convert to spec (#14)

[img-conversion] Editorial changes (#10)

[img-conversion] Encode and decode should take/produce streams (#15)

[img-conversion] Examples from spec should be in explainer (#8)

[img-conversion] Explainer should explain how to use the API for common cases (#11)

[img-conversion] How to understand this extension (#6)

[img-conversion] toBlob() Having two optional kinda sucks... let's merge them. (#13)

[IndexedDB] Add locale-aware sorting (#38)

[IndexedDB] Allow more explicit control over transaction lifetimes (#34)

[IndexedDB] Migrate feature requests from Wiki (#39)

[manifest] Integration with service workers (#161)

[manifest] List expected permissions in the manifest. (#395)

[manifest] Maintain list of sites that have a manifest (#404)

[manifest] Remove feature at risk for theme_color (closes #356) (#403)

[manifest] Remove feature at risk for theme_color (closes #356) (5101b33)

[manifest] Support for platform hints on icons (#405)

[manifest] What's the use case for theme_color? (#356)

[permissions] Add "nfc" to enum PermissionName (#47)

[permissions] Add getUserMedia permissions (#10)

[permissions] Add screen sharing permissions (#45)

[permissions] navigator.permissions.request (#48)

[permissions] request/revoke (#46)

[push-api] Adding make check and circle CI support (#162)

[push-api] Making checks in the makefile solid; fixing tidy shortcoming (#167)

[push-api] Making pushsubscriptionchange event extendable; defining algorithm (#164)

[push-api] Mark `PushMessageData` methods as throwable (#165)

[push-api] Message encryption (#130)

[push-api] Multiple consecutive messages (#168)

[push-api] pushregistrationlost event must inherit from ExtendableEvent (#65)

[push-api] Rewriting push event handling; allowing data to be optional. (#166)

[push-api] What push daily sending limit have GCM from single account? (#163)

[selection-api] Draft WD for publication in October 2015 (#62)

[selection-api] Event handlers missing (#60)

[selection-api] Fix syntax/typo (#61)

[selection-api] Make some arguments optional (#30)

[selection-api] Selection events for text controls (#53)

[ServiceWorker] "no-cors" CSS SOP violation (#719)

[ServiceWorker] 24 hour spontaneous update doesn't seem specced (#514)

[ServiceWorker] Add xrefs to creation URL in HTML. (19de693)

[ServiceWorker] allow self-signed certificates (#691)

[ServiceWorker] consider allowing multiple worker thread instances for a single registration (#756)

[ServiceWorker] Consider producing distinct objects for the same entity to enable garbage collection (#416)

[ServiceWorker] consult document CSP in Register algorithm (#755)

[ServiceWorker] Event queuing model for SW (#649)

[ServiceWorker] Expose GeoLocation to workers (#745)

[ServiceWorker] FetchEvent is non cancelable yet checks canceled flag (#741)

[ServiceWorker] Fix spelling error: arguement -> argument (#748)

[ServiceWorker] Foreign fetch (#751)

[ServiceWorker] How are unloaded tabs represented? (#626)

[ServiceWorker] how does SoftUpdate "force bypass cache flag" get set? (#753)

[ServiceWorker] importScripts() should throw? (#642)

[ServiceWorker] Interception of the fallback requests initiated from a SW for cross-origin resources (#684)

[ServiceWorker] Is fetchEvent.client a performance concern? (#723)

[ServiceWorker] Make secure context requirements more explicit (#754)

[ServiceWorker] openWindow with a WebApp manifests (#720)

[ServiceWorker] Possible run-to-completion violation in "Handle Service Worker Client Unload" (#746)

[ServiceWorker] s/arguement/argument/g (#747)

[ServiceWorker] ServiceWorker scriptURL XSS Filtering (#743)

[ServiceWorker] Should ServiceWorker.scriptURL have fragment removed? (#742)

[ServiceWorker] Specify .focus() and .openWindow() behaviour (#602)

[ServiceWorker] Start with trying to spec foreign fetch. (#749)

[ServiceWorker] Typescript file and spec are not in sync (#750)

[ServiceWorker] Use a new algorithm and hooks for importScripts(urls) called on a ServiceWorkerGlobalScope. (59e3745)

[ServiceWorker] WindowClient.navigate() for the same origin but off-scope clients (#752)

[ServiceWorker] Worker-As-A-Service service workers (#744)

[spec-reviews] "With Credentials" flag possibly inconsistent with web architecture (#76)

[spec-reviews] Automotive Working Group - API Refactor or Not? (#81)

[spec-reviews] Browser Fingerprinting Document (#38)

[spec-reviews] Clear Site Data (#62)

[spec-reviews] Create a "advice for spec authors" page (#78)

[spec-reviews] Credential Management API (#49)

[spec-reviews] Cross-spec device identification & association (#64)

[spec-reviews] CSP (#42)

[spec-reviews] CSS font-display (#71)

[spec-reviews] CSSOM View document.scrollingElement (#51)

[spec-reviews] Feedback on Keygen (#82)

[spec-reviews] File URI Scheme (#59)

[spec-reviews] Find out if the Battery Status API people need our feedback (#68)

[spec-reviews] Fixed typos (#46)

[spec-reviews] Frame Timing API (#56)

[spec-reviews] General review of Shadow DOM 2015 updates (#79)

[spec-reviews] HTTP Opportunistic Security (#80)

[spec-reviews] Indexed DB getAll(), openKeyCursor() and objectStoreNames (#84)

[spec-reviews] Media Capture and Streams (#57)

[spec-reviews] Media TF discussion (#69)

[spec-reviews] Motion path spec (#66)

[spec-reviews] Navigation Timing 2 (#18)

[spec-reviews] Network Information API (#86)

[spec-reviews] Performance API review (#83)

[spec-reviews] Potential for coordination about task scheduling (#72)

[spec-reviews] Presentation API Request for Feedback (#61)

[spec-reviews] requestIdleCallback (#70)

[spec-reviews] Review Payments Working Group Charter (#67)

[spec-reviews] Secure / Powerful / Features / Contexts (#75)

[spec-reviews] Security Questionnaire (#77)

[spec-reviews] Start File URI feedback (#65)

[spec-reviews] Storage persistence (#85)

[spec-reviews] Unblocking the HTTPS Transitions (#74)

[spec-reviews] Update CSS Regions.md (#48)

[spec-reviews] Web NFC API (#22)

[spec-reviews] WebRTC (#14)

[spec-reviews] Write up the Secure Stop issue for ddorwin (#73)

[streams] Add an example of piping to a writable stream for consuming a readable stream (#393)

[streams] Add IsReadableStreamDisturbed predicate (#385)

[streams] Fixed test about cancelling a released reader, promise should reject. (#394)

[streams] Port precise flow control to writable streams (#318)

[streams] Removed reduntant test for negative strategy.highWaterMark (#395)

[touch-events] force property? (#30)

[touch-events] Not all touch events should be synchronous and uncancelable (#6)

[uievents] #event-type-input and #event-type-beforeinput appear to have gone missing (#2)

[uievents] dfn cleanup (9283fab)

[uievents] Please mark some definitions as not exported (#6)

[uievents] Remove "(formerly DOM Level 3 Events)" from the title? (#1)

[uievents] specify how compositionend works if the caret has been moved to a different element (#5)

[uievents] Travisleithead dfncleanup (#7)

[webcomponents] "Assigned slot" is not well defined (#307)

[webcomponents] "Assigned slot" is undefined (#307)

[webcomponents] [Custom Elements] Import module (#329)

[webcomponents] [Custom Elements] the `extends` property cannot be replaced (#326)

[webcomponents] [Fix #307] Define "Assigned Slot" (ce3fe1c)

[webcomponents] [Shadow] How should element.requestFullscreen(); work in shadow dom (bugzilla: 27379) (#180)

[webcomponents] [Shadow] Need equivalent of ownerDocument for Elements in a shadow tree to get to their ShadowRoot (#315)

[webcomponents] [Shadow] Section 2.4 - CSS inherit by default? (#314)

[webcomponents] [Shadow] Style attributes in Shadow DOM Cascade Order Proposal (#316)

[webcomponents] [Shadow]: Add "closed" flag to createShadowRoot (bugzilla: 20144) (#100)

[webcomponents] [Shadow]: Figure out a good replacement for /deep/ in testing scenarios (bugzilla: 28591) (#78)

[webcomponents] [Shadow]: Node should expose their scope so that shared state can be scoped to components. (bugzilla: 22080) (#80)

[webcomponents] Add a custom pseudo-elements proposal (#299)

[webcomponents] Add a non-normative note stating elements in shadow trees aren't exposed as named properties (#304)

[webcomponents] assignedSlot should be defined on Node (#310)

[webcomponents] assignedSlot should be of type HTMLSlotElement (#320)

[webcomponents] attachShadow must throw a TypeError when mode is omitted (#311)

[webcomponents] attachShadow should fail on a slot element (#327)

[webcomponents] attachShadow shouldn't have a fixed list of elements to throw (#309)

[webcomponents] caretPositionFromPoint, elementFromPoint, and elementsFromPoint should respect shadow boundary (#313)

[webcomponents] Clarify whether the empty string is a valid slot name or not (#319)

[webcomponents] Composition Algorithm shouldn't unwrap slots (#308)

[webcomponents] Consider adding a new node type for ShadowRoot (#324)

[webcomponents] Consider making ShadowRoot directly inherit from Node (#325)

[webcomponents] css3-ui no longer defines nav-index (#333)

[webcomponents] Define the behavior of '::slotted' (the former name is '::content'). (#331)

[webcomponents] Disallow attachShadow on replaced elements (#312)

[webcomponents] Disallow attachShadow(...) for some elements. (#110)

[webcomponents] Draft WD to be published on or around 2015-Oct-08 (#332)

[webcomponents] Enumerate the element names which don't support createShadowRoot(), instead of looking at the binding property (#110)

[webcomponents] Event path trimming should only happen for mouseover and mouseout (#330)

[webcomponents] Fragment error for "#encapsulation" (#334)

[webcomponents] How the current model and the v1 model should interact? (#130)

[webcomponents] Interaction between CSS and composed tree needs to be better defined (#305)

[webcomponents] Introduction section shouldn't refer to a Shadow DOM 101 article (#301)

[webcomponents] Introduction section shouldn't refer to Shadow DOM 101 article (#301)

[webcomponents] Is there a custom pseudo-elements proposal or spec anywhere? (#298)

[webcomponents] ownerDocument of a node in a shadow tree isn't well defined (#303)

[webcomponents] Proposal: Add namespace property to ElementRegistrationOptions parameter of Document.registerElement (#328)

[webcomponents] Remove the constraint that slot can't have another slot as an ancestor (#321)

[webcomponents] Rename Distributed Nodes Algorithm to Slot Assignment Algorithm (#323)

[webcomponents] Rename getDistributedNodes() to getAssignedNodes() (#322)

[webcomponents] Replace getDistributedNodes with getAssignedNodes (#322)

[webcomponents] Sharing styles across custom elements (#282)

[webcomponents] slot element's fallback contents is never used (#317)

[webcomponents] Spec examples need to be updated to use the new syntax (#318)

[webcomponents] Spec the v1 (#289)

[webcomponents] Support Custom Pseudo-elements (#300)

[webcomponents] The definitions of slot and slot elements are unclear (#306)

[webcomponents] The order of node trees is not well defined when one tree is not inside a shadow tree (#302)

[webcomponents] The order of tree of trees is not well defined when one node is not inside a shadow tree (#302)

[webcomponents] Type extensions in SVG use shadow trees--specify, or add a note if no specification is necessary (#335)

[webidl] "it is not possible for a single platform object to implement both interfaces" (#59)

[webidl] Allow unions of dictionaries with a common base dictionary, in return values (#57)

[webidl] Fix the SerializerRest production rule (#58)

[xhr] Creating an ArrayBuffer can fail (#26)

[xhr] Make setRequestHeader() normalize header values just like Fetch does and update HTTP references. Fixes https://www.w3.org/Bugs/Public/show_bug.cgi?id=27797 (90c79d0)

[xhr] Resture the filename argument to FormData.append(name, blob) (#25)

Last message date: Wednesday, 30 September 2015 23:45:28 UTC