public-webapps-github@w3.org from April 2019 by subject

[heycam/webidl] [[Set]] algorithm for legacy platform objects does not seem to be compatible with the Storage interface (#366)

[heycam/webidl] [WIP] Define Web IDL Modules (#675)

[heycam/webidl] Add [AllowShared] in the list of applicable-to-types (#695)

[heycam/webidl] Allow dictionary default values to reference type members (#717)

[heycam/webidl] Clarify "applicable extended attributes" (#708)

[heycam/webidl] Correct the effective overload set use for named constructors (#699)

[heycam/webidl] Define a callback constructor type (#701)

[heycam/webidl] Define that interface objects are constructors (#698)

[heycam/webidl] Define Web IDL Modules (#675)

[heycam/webidl] Editorial: Add littledan to the acknowledgements (#711)

[heycam/webidl] Editorial: Remove a duplicate emu-nt start tag (#710)

[heycam/webidl] Editorial: Shorten the conditions in the [[Set]] algorithm (#713)

[heycam/webidl] Fix a grammar mistake in the 'partial interface' definition (#693)

[heycam/webidl] Grammar does not allow non-readonly regular attributes in mixin (#702)

[heycam/webidl] Hard to find terminology to talk about optional arguments (#707)

[heycam/webidl] Idea for [AllowShared] (handling SharedArrayBuffer safely) (#638)

[heycam/webidl] Introduce a SameRealmBrandCheck extended attribute (#718)

[heycam/webidl] Introduce an UnenumerableOperations extended attribute (#719)

[heycam/webidl] Is [AllowShared] an applicable-to-types attribute? (#687)

[heycam/webidl] JavaScript defines typeof fully now (#712)

[heycam/webidl] Limit the special case in the [[Set]] algorithm to [OverrideBuiltins] interfaces (#715)

[heycam/webidl] ReadWriteAttribute production should not allow using "readonly" with inherit (#703)

[heycam/webidl] Remove "supports indexed/named properties" (#714)

[heycam/webidl] Remove a check for array index in [[Set]] (#706)

[heycam/webidl] Remove unused callback interface functionality (#696)

[heycam/webidl] Rendering bug in Attributes section (#709)

[heycam/webidl] Should callback interfaces with more than one operation be supported? (#661)

[heycam/webidl] Stop claiming callback interfaces are interfaces (#705)

[heycam/webidl] Stop using extended attributes for constructors (#700)

[heycam/webidl] String marshaling/interop for wasm and asm.js scenarios (#716)

[heycam/webidl] Tighten the grammar for the 'inherit' keyword (#704)

[w3c/clipboard-apis] The "focused node" when determining event target needs to be defined (#70)

[w3c/DOM-Parsing] It should be noted that parseFromString can throw exceptions (#51)

[w3c/DOM-Parsing] Serialization of the XML declaration (#50)

[w3c/editing] "The removeFormat command" section should include `<del>` as target of the command (#192)

[w3c/editing] When an 'insertHTML' command should be applied as sibling or child of a <font> element ? (#191)

[w3c/editing] When an 'insertHTML' command should be applied as sibling or child of a styled 'span' element ? (#191)

[w3c/editing] When an 'insertHTML' command should be applied inside a sibling <font> element ? (#191)

[w3c/FileAPI] "package data" reuses type variable (#124)

[w3c/FileAPI] Add method to read file into user given Uint8Array (#83)

[w3c/FileAPI] Add simpler reading methods to Blob interface. (#117)

[w3c/FileAPI] chore:add PULL_REQUEST_TEMPLATE.md (#113)

[w3c/FileAPI] Consider dropping lowercasing requirement for the type attribute (#122)

[w3c/FileAPI] Consider reserializing type attributes, not just parsing them. (#123)

[w3c/FileAPI] Disallow mutating state of Blob/File objects (#75)

[w3c/FileAPI] Fix escaping that doesn't work in <xmp> (#127)

[w3c/FileAPI] Modernize Blob constructor a tiny bit (#125)

[w3c/FileAPI] Readonly attributes without setters? (#126)

[w3c/FileAPI] Streams are hot, FileReader.readAs____ is not (#40)

[w3c/gamepad] Light Indicator (#67)

[w3c/gamepad] Move deprecated WebVR-specific extensions to WebVR (#92)

[w3c/IndexedDB] Consider adding some way to retrieve secondary keys when using IDBIndex.getAllKeys (#71)

[w3c/IndexedDB] cursor.request (#255)

[w3c/IndexedDB] Extract common steps of `IDBObjectStore`'s `put()` and`add()` (#261)

[w3c/IndexedDB] Key Paths: Support iteration step operator (#35)

[w3c/IndexedDB] Mark IDBCursor's request property as [SameObject] (#262)

[w3c/IndexedDB] Mark IDBCursor's request property as [SameObject] (#263)

[w3c/IndexedDB] Promise-based API (#42)

[w3c/manifest] API to get details about browser heuristics. (#727)

[w3c/manifest] App shortcuts / actions (#582)

[w3c/manifest] Broken fragments in spec (#735)

[w3c/manifest] Change platform android by play in exemple (#581)

[w3c/manifest] Color processing steps are incorrect (#760)

[w3c/manifest] Control over webapp installation & launch (#705)

[w3c/manifest] Deep linking - need proper use cases and requirements analysis (#363)

[w3c/manifest] editiorial: relocate AppBannerPromptOutcome section (#759)

[w3c/manifest] Feat (start_url): add privacy consideration (closes #399) (75f5a56)

[w3c/manifest] Install button on another domain (#726)

[w3c/manifest] MIME type in HTML <link type="application/manifest+json" rel="manifest"> (#721)

[w3c/manifest] Missing private indicator for install is showing. (#761)

[w3c/manifest] Navigation during installation (#762)

[w3c/manifest] Payment Handler spec defines IDL types very similar to manifest (#652)

[w3c/manifest] Privacy Review: handle start_url tracking (#399)

[w3c/manifest] Provide VR display mode (#583)

[w3c/manifest] Representing Spatial Icons for WebApps (#763)

[w3c/manifest] Respec validator (#740)

[w3c/manifest] Should appinstalled and beforeinstallprompt events be optional? (#699)

[w3c/manifest] Simple Example and Complex Example (#553)

[w3c/manifest] Support for deep integrations, e.g. OpenSearch (#421)

[w3c/manifest] The list of known Web Manifest platform values is confusing (#538)

[w3c/manifest] Use WebIDL to describe the manifest data structure (#611)

[w3c/permissions] Add "wake-lock" permission type (#192)

[w3c/permissions] Need a procedure reference for "request permission" (#62)

[w3c/pointerlock] chore:add PULL_REQUEST_TEMPLATE.md (#38)

[w3c/pointerlock] Option needed to disable OS-level adjustment for mouse acceleration (#36)

[w3c/push-api] A javascript api for sending push notifications to others (#303)

[w3c/push-api] chore:add PULL_REQUEST_TEMPLATE.md (#304)

[w3c/push-api] Should PushManager.subscribe() return the existing subscription or a new one? (#305)

[w3c/selection-api] Add APIs to save/restore selection (#42)

[w3c/selection-api] Changing the selection creates a Range object (#103)

[w3c/selection-api] chore:add PULL_REQUEST_TEMPLATE.md (#101)

[w3c/ServiceWorker] Browsers should not consume the stream right away on ReadableStream responses with 'Content-Disposition: attachment' header. (#1398)

[w3c/ServiceWorker] Casing convention for acronyms (ie `clientId`) (#1402)

[w3c/ServiceWorker] Casing convention for acronyms vs abbrev. (ie `clientId`) (#1402)

[w3c/ServiceWorker] consider fetching service worker scripts with no-cache by default (#893)

[w3c/ServiceWorker] Is respondWith(fetch(event.request)) always the same as not calling respondWith()? (#1395)

[w3c/ServiceWorker] No credentials prompt with basic auth (401) (#1400)

[w3c/ServiceWorker] Pass credentials on navigator.serviceWorker.register("/service_worker.js"); (#1399)

[w3c/ServiceWorker] postMessage keeps service workers alive indefinitely (#980)

[w3c/ServiceWorker] provide a way to execute work after browser has consumed a response (#1397)

[w3c/ServiceWorker] Tracking JS issue in firefox pwa (#1401)

[w3c/uievents] MouseEvent.fromElement/toElement (#84)

[w3c/uievents] onbeforeinput (#218)

[w3c/uievents] Proposal: Add KeyboardEvent.unmodifiedKey (#229)

[w3c/uievents] UI events containing lone surrogates (#227)

[w3c/uievents] What happened to the 'resize' event? (#228)

[w3c/webcomponents] [idea] childConnectedCallback and childDisconnectedCallback (#550)

[w3c/webcomponents] [templates] Ensure that template instantiation actually improves the platform (#704)

[w3c/webcomponents] CSS Modules (#759)

[w3c/webcomponents] Custom pseudo-classes for host elements via shadow roots (:state) (#738)

[w3c/webcomponents] Discussion: Templates that Don't Destroy Element References (#777)

[w3c/webcomponents] Document "layers" for single-use components (#806)

[w3c/webcomponents] How to handle non-type=”module” scripts in HTML Modules? (#798)

[w3c/webcomponents] HTML Modules as a leaf node in the module graph or not? (#805)

[w3c/webcomponents] HTML modules spec draft editorial feedback (#783)

[w3c/webcomponents] HTMLElement.prototype.offsetParent leaks a node inside a shadow tree (#497)

[w3c/webcomponents] Include updated info on HTML Modules (#799)

[w3c/webcomponents] Lazy Custom Element Definitions (#782)

[w3c/webcomponents] Make JavaScript Files a Valid Entry Point to a Web Page (#807)

[w3c/webcomponents] Mechanism for setting the tabindex focus flag without sprouting tabindex attribute? (#762)

[w3c/webcomponents] Need a callback for when children changed or parser finished parsing children (#809)

[w3c/webcomponents] Need callback for form submit data (#187)

[w3c/webcomponents] Proposal: a native solution for virtual scrolling (#791)

[w3c/webcomponents] Proposal: Allow custom elements to be in any namespace (#634)

[w3c/webcomponents] Serialize shadow DOM for use in javascript disabled user agents (#788)

[w3c/webcomponents] Shadow tree encapsulation and CSS (#804)

[w3c/webcomponents] ShadowRoot.styleSheets should return an empty StyleSheetList if the shadow root is not connected (#526)

[w3c/webcomponents] Spring 2019 F2F Agenda (#802)

[w3c/webcomponents] Support for pseudo elements with ::slotted() selectors (#655)

[w3c/webcomponents] The is="" attribute is confusing? Maybe we should encourage only ES6 class-based extension. (#509)

[w3c/webcomponents] Using private fields and methods in template instantiation (#808)

[w3c/webcomponents] Web Components F2F Spring 2019 (#786)

[w3ctag/design-reviews] Add simpler reading methods to Blob interface. (#363)

[w3ctag/design-reviews] Additional reading methods on Blob and File (#359)

[w3ctag/design-reviews] Async Clipboard - image/delayed content (#350)

[w3ctag/design-reviews] Audiobooks (#345)

[w3ctag/design-reviews] Autoplay Detection API (#356)

[w3ctag/design-reviews] CSS Properties and Values API Level 1 (#318)

[w3ctag/design-reviews] Element Timing API for img (#326)

[w3ctag/design-reviews] First-Party Sets (#342)

[w3ctag/design-reviews] fix GitHub capitalization (#364)

[w3ctag/design-reviews] Form Participation API (#305)

[w3ctag/design-reviews] Gamepad Light Indicator extension API (#362)

[w3ctag/design-reviews] hrefTranslate attribute (#301)

[w3ctag/design-reviews] HTTP State Tokens (#297)

[w3ctag/design-reviews] IFrame Execution Pausing (#369)

[w3ctag/design-reviews] IndexedDB Transaction Explicit Commit API (#316)

[w3ctag/design-reviews] IntersectionObserver V2 (#328)

[w3ctag/design-reviews] JS Self-Profiling API (#366)

[w3ctag/design-reviews] Media Capabilities (#218)

[w3ctag/design-reviews] MediaStream Image Capture API (Pan/Tilt feature) (#358)

[w3ctag/design-reviews] Meta: ISSUE_TEMPLATE.md should better handle cases of active disagreement (#368)

[w3ctag/design-reviews] Periodic Background Sync (#367)

[w3ctag/design-reviews] Portals (#331)

[w3ctag/design-reviews] Request review of the Gamepad Light Indicator extension API (#362)

[w3ctag/design-reviews] Serialization of natural language in data formats such as JSON [I18N] (#178)

[w3ctag/design-reviews] Storage Quota Usage Details (#365)

[w3ctag/design-reviews] TAG review for LazyLoad (#361)

[w3ctag/design-reviews] TAG review of whether element.pseudo(":unknown") should return null or throw (#348)

[w3ctag/design-reviews] User Activation Delegation through postMessages (#347)

[w3ctag/design-reviews] User Idle Detection (#336)

[w3ctag/design-reviews] Verifiable Credentials Data Model 1.0 (#343)

[w3ctag/design-reviews] Web of Things (WoT) Architecture (#355)

[w3ctag/design-reviews] Web of Things (WoT) Thing Description (#357)

[w3ctag/design-reviews] Web Publications review (#344)

[whatwg/dom] "create an event" does not work with required members (#600)

[whatwg/dom] [Proposal] Add EventTarget.getEventListeners() (#412)

[whatwg/dom] Add ParentNode.prototype.replaceContents(nodes) (#755)

[whatwg/dom] Bubbling submit events and nested forms (#756)

[whatwg/dom] Composed and non bubbling event semantic dispatched in shadow tree (#742)

[whatwg/dom] Custom element callback/promise for "connected and parsed" (#662)

[whatwg/dom] Declarative Shadow DOM (#510)

[whatwg/dom] Define mutation events (#305)

[whatwg/dom] Definition of valid shadow elements is ambiguous (#745)

[whatwg/dom] Dispatching events section may not match browsers (#746)

[whatwg/dom] Don't allow adopting DocumentFragment of a template element (#744)

[whatwg/dom] Editorial: rename item to current target (#753)

[whatwg/dom] Editorial: use IDL to simplify create an element (#751)

[whatwg/dom] isEqualNode and <template> (#737)

[whatwg/dom] Jdj (#752)

[whatwg/dom] jquery.min.js:2 [Violation] Added non-passive event listener to a scroll-blocking 'touchstart' event. Consider marking event handler as 'passive' to make the page more responsive (#748)

[whatwg/dom] Manage slot manipulation centrally and special case replace operations (#695)

[whatwg/dom] Non-bubbling event should run non-capture listeners (#750)

[whatwg/dom] Proposal: a DocumentFragment whose nodes do not get removed once inserted (#736)

[whatwg/dom] Proposal: Element.assign() (#477)

[whatwg/dom] Proposal: ParentNode.replaceAll() (#478)

[whatwg/dom] Proposal: ParentNode.replaceAll() / ParentNode.replaceChildren() (#478)

[whatwg/dom] Proposal: ParentNode.replaceChildren() (#478)

[whatwg/dom] Run adopt as part of insert (#754)

[whatwg/dom] Set current node to sibling when iterating the TreeWalker. Fixes #667. (#747)

[whatwg/dom] The dispatch algorithm should account for changing the target to the associated labeled control, if available (#749)

[whatwg/dom] TreeWalker's nextNode() method can result in an infinite loop because the value of node never changes if it doesn't have a child (#667)

[whatwg/encoding] Consider adding TextEncoder.containsLoneSurrogates() static (#174)

[whatwg/encoding] Consider defining Japanese encoding sniffing (#157)

[whatwg/encoding] Editorial: use IDL's this (#175)

[whatwg/encoding] TextDecoder's serialize stream algorithm seems unnecessarily convoluted. (#154)

[whatwg/fetch] "`" (#891)

[whatwg/fetch] "no-CORS-safelisted request-header" definition can be simplified (#898)

[whatwg/fetch] Add a speculative flag to `Request` as well as related processing (#881)

[whatwg/fetch] Add device-memory and network quality client hints to the list (732bd89)

[whatwg/fetch] Add Stale While Revalidate Handling (#853)

[whatwg/fetch] Body.json reviver (#104)

[whatwg/fetch] Cache-Friendly Access-Control-Allow-Origin (#890)

[whatwg/fetch] CORB should not block application/dash+xml videos (#886)

[whatwg/fetch] Cross-Origin-Resource-Policy (was: From-Origin) (#687)

[whatwg/fetch] Cross-Origin-Resource-Policy shouldn't apply to browser-initiated requests (e.g. downloads) (#896)

[whatwg/fetch] Define behavior in the presence of TLS Early Data (#888)

[whatwg/fetch] fix description of Access-Control-Request-Method population (#895)

[whatwg/fetch] fix grammar: "is a not a" (#894)

[whatwg/fetch] New connections and port blocking (#889)

[whatwg/fetch] Please add support for an indicator as to whether the page was resolved via a temporary redirect or a permanent one (#892)

[whatwg/fetch] Reinvestigate redirects to data URLs (#393)

[whatwg/fetch] Sketch out a CORP-only mode. (#893)

[whatwg/fetch] Uploading a Request made from a ReadableStream body (#425)

[whatwg/fetch] XMLHttpRequest.send() with a SharedArrayBuffer as a source? (#897)

[whatwg/fullscreen] "Fullscreen Element" defintion not exported? (#150)

[whatwg/fullscreen] How :fullscreen CSS pseudo class works in shadow dom? (#149)

[whatwg/fullscreen] Meta: export the fullscreen element concept (#151)

[whatwg/storage] "persistent" (#68)

[whatwg/storage] Add UsageDetails dictionary (#69)

[whatwg/streams] can streams be transferred via postMessage()? (#276)

[whatwg/streams] ReadableStreamTee pulls too many chunks (#996)

[whatwg/streams] ReadableStreamTee: do not read when already pulling (#997)

[whatwg/url] Consider adding a constructor to make a URL from parts (#354)

[whatwg/url] Definition of "valid opaque-host string" contradicts parser (#437)

[whatwg/url] http://40000000000 considered as being a wrong URL (#436)

[whatwg/url] Restructure URL rendering section and add additional guidance (#434)

[whatwg/xhr] [do not merge] Specify target of progress events (#246)

[whatwg/xhr] Clarify allowed behavior when response is "too big" to "fit" in memory/on disk? (#244)

[whatwg/xhr] Please add support for an indicator as to whether the page was resolved via a temporary redirect or a permanent one (#243)

[whatwg/xhr] Specify target of progress events (#246)

[whatwg/xhr] XMLHttpRequest.send() with a SharedArrayBuffer as a source? (#245)

Last message date: Tuesday, 30 April 2019 22:52:05 UTC