public-webapps-github@w3.org from February 2020 by subject

[heycam/webidl] Added a definition of {{StringContext}} extended attribute. (#841)

[heycam/webidl] Allow `object` for attribute names? (#845)

[heycam/webidl] Allow ES2020 BigInt values to be passed to operations taking integers. (#828)

[heycam/webidl] Can we use ObjectCreate in object creation? + other editorial tweaks (#655)

[heycam/webidl] Consider renaming number types to match the equivalent WebAssembly types (#843)

[heycam/webidl] Enumeration order of interface members (#432)

[heycam/webidl] Introduce the observable array type (#836)

[heycam/webidl] Introduce the observable array type (proxy-based) (#840)

[heycam/webidl] Project (#844)

[heycam/webidl] Should EnforceRange be allowed on consts and return types? (#842)

[w3c/clipboard-apis] Chore: Add tidyconfig to spec (#110)

[w3c/clipboard-apis] Editorial: Remove redefinition of `editing host`. Link mentions of it to its HTML spec definition (#109)

[w3c/clipboard-apis] Is "clipboard" permission replaced by "clipboard-read" and "clipboard-write"? (#101)

[w3c/clipboard-apis] Update `clipboard.write()` example to use a `ClipboardItem` list. (#111)

[w3c/DOM-Parsing] Editorial refactoring (#10)

[w3c/DOM-Parsing] fix: Add `<dfn>` for the `[CEReactions]` IDL extended attribute (#57)

[w3c/DOM-Parsing] fragment parsing algorithm appears to be wrong when invoked from innerHTML setter of template element (#61)

[w3c/editing] Add reference to Selection API spec (#227)

[w3c/editing] Editing TF meeting 02/14/2020 - Agenda (#230)

[w3c/editing] editorial: remove editing host definition and update references to it (#229)

[w3c/editing] inputPanelPolicy as a way to control software keyboard (#225)

[w3c/editing] Move some items from contenteditable to HTML (#228)

[w3c/editing] Move some items from contenteditable to HTML? (#228)

[w3c/editing] Remove editing host definition and update references to it (#229)

[w3c/editing] run html5 tidy on spec (#231)

[w3c/editing] Should execCommand dispatch beforeinput or not? (#200)

[w3c/gamepad] [gamepad-extensions] Align with Web IDL specification (#126)

[w3c/IndexedDB] Editorial: Call out browser versions for new features (#321)

[w3c/IndexedDB] Editorial: Fix some incorrect capitalization, and make sections less shouty (#320)

[w3c/IndexedDB] Editorial: Improve example's text around uniqueness. (#318)

[w3c/IndexedDB] Promise-based API (#42)

[w3c/IndexedDB] Simplify transaction starting constraints to match reality (#319)

[w3c/IndexedDB] Where unique key goes (#181)

[w3c/manifest] Add a "tabbed application" mode (#737)

[w3c/manifest] Add option to replace title bar with a display a smaller caption control overlay (#847)

[w3c/manifest] Add optional `author` member (#675)

[w3c/manifest] Add reference to (#849)

[w3c/manifest] Allow installed PWA to run on OS login (#845)

[w3c/manifest] BREAKING CHANGE: Replace "badge" with "monochrome" (#833)

[w3c/manifest] i18n support (#848)

[w3c/manifest] Icon purpose "splashscreen" and splashscreen text (#844)

[w3c/manifest] Procedure for moving manifests and Apps (#850)

[w3c/permissions] Consider making `request-permission-to-use` aware of user activation (#194)

[w3c/pointerlock] The frequency of the security popup (#58)

[w3c/push-api] Make automatic failing normative (#322)

[w3c/selection-api] Bahavior without browsing context (#82)

[w3c/selection-api] containsNode could return true for a node that doesn't intersect the selection at all (#116)

[w3c/selection-api] Determine whether addRange() and removeAllRanges() should reset direction (#3)

[w3c/selection-api] Editorial: Remove redefinition of `editing host`. Relink to its HTML spec definition (#119)

[w3c/selection-api] Link editing host to html definition (#119)

[w3c/selection-api] Throw InvalidNodeType on DocumentType nodes (#118)

[w3c/selection-api] Throw InvalidNodeTypeError on DocumentType nodes (#118)

[w3c/selection-api] What task source do we queue events on? (#117)

[w3c/ServiceWorker] Add FetchEvent.handled (#1397) (#1496)

[w3c/ServiceWorker] Allow Caching of POST requests (#977)

[w3c/ServiceWorker] Chrome: serviceWorker.ready() resolves before service worker is active after unregistering (#1505)

[w3c/ServiceWorker] Define Purge Service Worker Registrations (#1506)

[w3c/ServiceWorker] Expose GeoLocation to workers (#745)

[w3c/ServiceWorker] Recovering from start failures (#1503)

[w3c/ServiceWorker] Service worker spec meetup (#1501)

[w3c/ServiceWorker] Size limits with synchronous WebAssembly functions (#1499)

[w3c/ServiceWorker] Very Strange Issue about refresh. (#1504)

[w3c/uievents] Change the type of click and auxclick to PointerEvent (#259)

[w3c/uievents] Event order of onKeyDown, onKeyPress, onKeyUp, and onPaste when using pasting (CMD + v) in Mac OS X (#261)

[w3c/uievents] Update index.html with the latest bikeshed (#260)

[w3c/webcomponents] 2020 Spring F2F (#855)

[w3c/webcomponents] [templates] Ensure that template instantiation actually improves the platform (#704)

[w3c/webcomponents] Add Scoped CustomElementRegsitry explainer (#865)

[w3c/webcomponents] Disallow attachShadow(...) for some elements. (#110)

[w3c/webcomponents] Make JavaScript Files a Valid Entry Point to a Web Page (#807)

[w3c/webcomponents] Mechanism for setting the tabindex focus flag without sprouting tabindex attribute? (#762)

[w3c/webcomponents] Theming options for shadow roots (#864)

[w3c/webcomponents] Update Imperative-Shadow-DOM-Distribution-API.md (#866)

[w3ctag/design-reviews] <link> rel="modulepreload" (#213)

[w3ctag/design-reviews] [WebComponents] Custom state pseudo class (#428)

[w3ctag/design-reviews] Cookie Store API (#469)

[w3ctag/design-reviews] CSS intrinsic-size (#437)

[w3ctag/design-reviews] Curve25519 in Web Cryptography (#466)

[w3ctag/design-reviews] Delegated Ink Trail (#473)

[w3ctag/design-reviews] EditContext API (#416)

[w3ctag/design-reviews] Feature Policy: Document Policies (#408)

[w3ctag/design-reviews] Foldables CSS (#472)

[w3ctag/design-reviews] Gamepad Light Indicator extension API (#362)

[w3ctag/design-reviews] HR review of IMSC 1.2 FPWD (#474)

[w3ctag/design-reviews] HTTP State Tokens (#297)

[w3ctag/design-reviews] isInputPending (#475)

[w3ctag/design-reviews] JavaScript Memory API (#386)

[w3ctag/design-reviews] MathML Core (#438)

[w3ctag/design-reviews] Media Feeds API (#477)

[w3ctag/design-reviews] MiniApp URI Scheme (#478)

[w3ctag/design-reviews] Native File System API (#390)

[w3ctag/design-reviews] Partial freezing of the User-Agent string (#467)

[w3ctag/design-reviews] Requesting a TAG review of Personalization Semantics Explainer and  Module 1 (#476)

[w3ctag/design-reviews] Review different cross-domain import mechanisms and their security models (#446)

[w3ctag/design-reviews] Same-Origin iframe document-access limiting attribute (#397)

[w3ctag/design-reviews] Scheduling APIs (#338)

[w3ctag/design-reviews] Securer Contexts (#471)

[w3ctag/design-reviews] SMS Receiver API (#391)

[w3ctag/design-reviews] Trusted Types (#198)

[w3ctag/design-reviews] Web NFC (#461)

[w3ctag/design-reviews] WebOTP API (#391)

[w3ctag/design-reviews] WebRTC DSCP Control API (#465)

[w3ctag/design-reviews] WebXR Anchors Module (#479)

[w3ctag/design-reviews] WebXR DOM Overlay Module (#470)

[w3ctag/design-reviews] WebXR Hit Test Module (#463)

[whatwg/dom] "Remove a node from a parent" reaction callback stuff needs to be conditional on the node being connected before the operation (#773)

[whatwg/dom] [infra] Integrating generation of W3C-ready review drafts into build pipeline (#832)

[whatwg/dom] [proposal] Node.containingShadowRoot (#826)

[whatwg/dom] Add attribute validate steps. (#809)

[whatwg/dom] Avoid enqueuing "disconnectedCallback" on detached custom elements (#827)

[whatwg/dom] Catch errors while upgrading customized built-in elements (#797)

[whatwg/dom] createElementNS() QName/Name confusion (#671)

[whatwg/dom] Declarative Shadow DOM (#510)

[whatwg/dom] Declarative Shadow DOM (#831)

[whatwg/dom] Editorial: Missing definitive article (#834)

[whatwg/dom] Editorial: Specify `ParentNode.replaceChildren` implementation. (#835)

[whatwg/dom] Node insertion step 7.7 isn't upgrading disconnected uncustomized elements that browsers do upgrade (#833)

[whatwg/dom] Proposal: A Range.prototype.replaceContents(...) (#837)

[whatwg/dom] Proposal: ParentNode.replaceAll() / ParentNode.replaceChildren() (#478)

[whatwg/dom] Specify `ParentNode.replaceChildren` implementation. (#835)

[whatwg/dom] Update the "convert nodes into a node" to accept arrays of nodes. (#828)

[whatwg/dom] Which target could we expose in Event Timing? (#838)

[whatwg/encoding] Editorial: change the remaining flags to booleans (#198)

[whatwg/encoding] Label single-byte visualization rows by byte value (#197)

[whatwg/fetch] "Set internalResponse’s CSP list" never sets it on the non-internal response? (#1002)

[whatwg/fetch] `only-if-cached` divergence from HTTP (#1001)

[whatwg/fetch] Accept 'sec-'-prefixed headers as CORS-safelisted. (#1000)

[whatwg/fetch] Add support for Content-DPR response header (#971)

[whatwg/fetch] Browser caching does not work for the first range request on Chrome and Safari (#1003)

[whatwg/fetch] Clarify the way CORB should be applied to beacons (#882)

[whatwg/fetch] Cookies not sent across origins with credentials: 'include' and Content-Type: application/json (#997)

[whatwg/fetch] Developer-controlled streams for request/response (#88)

[whatwg/fetch] Distinguishing between errors (#25)

[whatwg/fetch] FetchObserver (for a single fetch) (#607)

[whatwg/fetch] Handling Partial Content / 206 (#144)

[whatwg/fetch] Header to opt out of opaque redirect (#601)

[whatwg/fetch] HTTP cache partitioning (#943)

[whatwg/fetch] Integrate with Fetch Metadata. (#993)

[whatwg/fetch] More CORB-protected MIME types - safelist-based approach (#721)

[whatwg/fetch] Proposal: Allow servers to take full responsibility for cross-origin access protection (#878)

[whatwg/fetch] Provide ability to encode content from browser/runtime in fetch API. (#653)

[whatwg/fetch] Request body streams should use chunked encoding (#966)

[whatwg/fetch] Response constructor should handle SharedArrayBuffer (#1004)

[whatwg/fetch] Revisit `destination` for `<iframe>`, `<frame>`, `<embed>`, and `<object>`. (#948)

[whatwg/fetch] Safelist request headers starting with `Sec-` (#880)

[whatwg/fetch] Why does Fetch specify a max redirect count of 20? (#576)

[whatwg/storage] "A schemeless origin group" has maybe been obsoleted? (#77)

[whatwg/storage] Editorial: remove schemeless origin group (#78)

[whatwg/streams] Add checks before Close and Enqueue in tee() (#1027)

[whatwg/streams] Add state checks to Close() and Enqueue() (#1029)

[whatwg/streams] Idiomatic Way to Explicitly Tell an Underlying Transform Stream to Flush to the Sink (#960)

[whatwg/streams] ReadableStream.from(X) (#1018)

[whatwg/streams] ReadableStream.prototype.arrayBuffer() (#1019)

[whatwg/streams] Reset for TransformStream (and WritableStream?) (#1026)

[whatwg/streams] Review Draft Publication: February 2020 (#1028)

[whatwg/url] appmodif.com (#465)

[whatwg/url] Bug in methods - entries() and forEach() (#462)

[whatwg/url] Review Draft Publication: February 2020 (#463)

[whatwg/url] URL.relative proposal (#421)

[whatwg/url] URLSearchParams.appendAll(iterable) (#461)

[whatwg/url] What should resolveRelativeUrl(base=..., relative="10.0.0.7:8080/foo.html") return? (#464)

[whatwg/xhr] Review Draft Publication: August 2019 (#252)

[whatwg/xhr] Review Draft Publication: February 2020 (#267)

Last message date: Saturday, 29 February 2020 22:14:42 UTC