public-webapps-github@w3.org from August 2015 by subject

[charter-html] DOM Parsing and Serialization now uses Github (#113)

[charter-html] Pointer Lock now uses Github (#114)

[charter-html] Styling for readability (#115)

[clipboard-apis] integrate "integration with rich text editing apis" into cut/copy/paste actions (#18)

[clipboard-apis] Move script-created events out of "fire a clipboard event" (#16)

[clipboard-apis] The ClipboardEvent constructor is strange (#10)

[clipboard-apis] Wording around default actions needs updating (#14)

[dom] Cleanup "equals" usage (#40)

[dom] cloneNode underspecified for attribute copying (#30)

[dom] Consider banning insertNode() of the Range's start node (#63)

[dom] Design base URL change notification system (#61)

[dom] DOMTokenList#toggle: don't treat everything non-undefined as true (#64)

[dom] High resolution timing for events (#23)

[dom] insert/remove hooks need to be invoked for ancestor changes too (#34)

[dom] Make cloning more explicit regarding attributes. Fixes #30. (39e6a33)

[dom] matches, querySelector, etc. shouldn't throw on an unrecognized selector (#39)

[dom] More bikeshed problems (#62)

[dom] Path HTML's base URL stuff to be in terms of DOM (#61)

[dom] Upgrade addedNodes and removedNodes to FrozenArray? (#54)

[editing] "CE Events Container" should be replaced by "editing host" (#66)

[editing] Added missing caption exception (#69)

[editing] Can composition contain element boundaries? (#77)

[editing] Can we use textnodes, and block/inline nodes as shadow roots for transparent IME handling? (#57)

[editing] Change name of contentEditable=typing to contentEditable=intent (#60)

[editing] change of event names beforeInput -> beforeEdit -> beforeInput? (#87)

[editing] ContentEditable with UserSelect=None needs to be documented (#20)

[editing] Definition of "Invisible elements" is vague (#68)

[editing] Definition of legal caret positions before/after inline elements is unclear (#74)

[editing] Definitions of inline and block elements are imprecise (#67)

[editing] Do everything needed to do block direction movement of the caret when in cE=Events? (#65)

[editing] Do we need to spec device specific events? (#62)

[editing] fixing typos (#63)

[editing] How can sites access browser spellchecking? (#36)

[editing] How do we switch the caret between overtype and insert mode? (#55)

[editing] InputEvent.targetRange in <input> (#72)

[editing] Legal caret positions – invisible text nodes (#75)

[editing] list all required beforeEdit/Edit events (#79)

[editing] list all required editTypes for beforeEdit/Edit events (#79)

[editing] Make dependent events polyfillable (#78)

[editing] move all caret movement events from beforeinput to beforeselectionchange? (#73)

[editing] move all caret movement intention events from beforeinput to beforeselectionchange? (#73)

[editing] Reference actions in clipboard API spec for execCommand copy/cut/paste (#61)

[editing] remove the targetRange from edit events, if the targetRange is equal to the selection (#80)

[editing] remove the targetRange from edit events, if the targetRange si equal to the selection (#80)

[editing] RESOLUTION: have a relatedEvent to point to the UI event that caused a DI event to be fired (#82)

[editing] RESOLUTION: We are going to focus on describing ce=typing as a priority. (#85)

[editing] RESOLUTION: We think we want strict subsets - events is a subset of caret is a subset of typing which is a subset of true. (#86)

[editing] RESOLUTION: We want to be able to insert newline or new paragraph (#81)

[editing] RESOLUTION: We will ask the accessibility people to look at IMEs and the problems we should have considered here but didn’t. (#83)

[editing] RESOLUTION: We will have typing with compositionstart (cancelable) when you can set a selection point, then a series on non cancelable beforeinputs to replace text, and two kinds of delete events - one inside composition not cancelable, and a "normal" one to be handled by the application (#84)

[editing] set targetRange to null for all editTypes where the targetRange would always have been equal to the selection range (#80)

[editing] Should cE=events (or cE=whatever now) handle selection? (#71)

[editing] Should Device-Specific Input Events say what Responsive Input Event they will cause? (#25)

[editing] should not use the shadow DOM for beforeInput (#76)

[editing] Should the caret move by default, and should we define this behavior? (#58)

[editing] spell checking should be able to span multiple Typing Nodes (#50)

[editing] Track the source of Intentions (#19)

[editing] What browser internals can be exposed to help us move the caret in (and against) the block direction? (#56)

[editing] What caret positions do we need to allow? (#51)

[editing] What do we need to integrate with the clipboard api? (#64)

[editing] What intentions do we need? (#52)

[editing] What to do with contentEditableTrue? (#54)

[editing] What to do with execCommand? (#53)

[editing] When should UA synthesize heights of an element? (#70)

[encoding] Add more labels to the replacement encoding (#8)

[encoding] Benefits of "Legacy" Encodings – Byte Counter (#4)

[fetch] 204 and json (#113)

[fetch] 206/304 handling broken? (#97)

[fetch] Access to the HTTP trailer (#34)

[fetch] Add timeout option (#20)

[fetch] Allow "manual" redirect fetches with caveats (#66)

[fetch] Allow context to be set (#48)

[fetch] Body.json reviver (#104)

[fetch] Botched up that null body status check in the Response constructor. Sorry. Fixes #96. (1e0918d)

[fetch] consider reordering manual and follow redirect flag cases in http fetch (#107)

[fetch] Consider updating HTTP references to RFC 7230. (#99)

[fetch] Drafting the patches to HTML (#106)

[fetch] Error Handle Chinese character for Charset=UTF-8 (#102)

[fetch] force-Origin-header flag set for no-cors requests (#91)

[fetch] Handling of data URLs (#111)

[fetch] Header value validation (#100)

[fetch] HTTP fetch status code section needs to operate on internal response (#105)

[fetch] HTTP/2 server push support (#51)

[fetch] Introduce convenience property for request's context (#93)

[fetch] link BufferSource to definition (#108)

[fetch] Observer API for fetch registry (#65)

[fetch] Option to require response.ok (#103)

[fetch] Preconnect via Fetch? (#114)

[fetch] Redesign request's context and context frame type features (#93)

[fetch] redirecting from same-origin to cross-origin CORS with userpass should fail (#112)

[fetch] Referrer (#80)

[fetch] Referrer: Referer header value for "client" referrer (#110)

[fetch] Referrer: Should request constructor fail when parsing referrer fails? (#109)

[fetch] Request for support for certificate pinning (#98)

[fetch] Response content-length header almost always wrong (#67)

[fetch] should navigation requests really be same-origin or no-cors? (#101)

[fetch] XHR option to trigger busy indicators (#19)

[FileAPI] .msg MimeType Not Recognized (#15)

[FileAPI] Not expose FileReaderSync to service worker (#16)

[fullscreen] Requesting fullscreen on the current fullscreen element should be an error (#17)

[fullscreen] Styles of former fullscreen elements (#18)

[IndexedDB] Allow expressions in addition to keyPaths when creating indexes (#33)

[IndexedDB] Allow more explicit control over transaction lifetimes (#34)

[IndexedDB] Allow multiEntry + Array keyPath (#36)

[IndexedDB] API to enumerate databases (#31)

[IndexedDB] DOMStringList has been removed from DOM (#28)

[IndexedDB] Don't expose GC behavior (#29)

[IndexedDB] IDBObjectStore.index() is missing step to throw if transaction is finished (#37)

[IndexedDB] Import issues from Bugzilla (#15)

[IndexedDB] Key Paths: Support iteration step operator (#35)

[IndexedDB] Proposal: Queue a microtask to unset active on transaction (#27)

[IndexedDB] Report data loss to script (#30)

[IndexedDB] Return number of records deleted (#32)

[manifest] Add background_color member (close #394). (#396)

[manifest] Add background_color member. (#396)

[manifest] Add background_color to represent the content's background color (#394)

[manifest] Add support for disabling default overscroll actions (#398)

[manifest] Add support for disabling pull-to-refresh (#398)

[manifest] Deep linking - need proper use cases and requirements analysis (#363)

[manifest] Fixed up titles and dfns (#393)

[manifest] Fixed up titles and dfns (#397)

[manifest] List expected permissions in the manifest. (#395)

[manifest] Privacy Review: cross origin persistent state (#400)

[manifest] Privacy Review: handle start_url tracking (#399)

[manifest] Privacy Review: how to handle navigation to a fullscreen'd application? (#402)

[manifest] Privacy Review: mention that users should vouch for sensitive information (#401)

[manifest] Triage privacy issues (#348)

[permissions] Minor editorial fixes (#44)

[push-api] Add and Encryption Key array to the PushRegistration interface (#89)

[push-api] Add optional userVisibleOnly parameter to register & hasPermission (#87)

[push-api] Adding typedef for JSON matching the fetch spec. (#158)

[push-api] Any -> any or use JSON similar to Fetch API (#133)

[push-api] Binary messages and use of `USVString` in `PushMessageDataInit` (#159)

[push-api] eventInitDict is always present when constructing an event (#157)

[push-api] Is reliance on Web Push Protocol normative? (#44)

[push-api] Make `PushEvent.data` nullable (#161)

[push-api] Making cardinality clear (#148)

[push-api] Making PushMessageDataInit a union (#160)

[push-api] Message encryption (#130)

[push-api] Moving to using data-lt= rather than title= for a and dfn (#156)

[push-api] Multiple registrations per origin/SW (#71)

[push-api] Nit: Clarify wording of "univocal" identifier (#76)

[push-api] Protocol updates (#154)

[push-api] Push event shouldn't be dispatched to an activating worker (#147)

[push-api] Push events should Soft Update service worker (#115)

[push-api] Removing tidy warnings with haxx (#153)

[push-api] Rewording abstract text again (#152)

[push-api] The push event (#145)

[screen-orientation] Deal with fragment navigation (#87)

[selection-api] Add APIs to save/restore selection (#42)

[selection-api] Add beforeselectionchange event (#56)

[selection-api] Add Selection.type to the spec (#14)

[selection-api] caret-based selection movement (#27)

[selection-api] Clarify selectstart event behaviour (#50)

[selection-api] Clarify the additions of this spec to GlobalEventHandlers (#54)

[selection-api] Define caret behavior around replaced, SVG, and MathML elements (#47)

[selection-api] Expand selectstart to cover use cases for contenteditable=typing (#45)

[selection-api] Expose with which bidi-level caret is affiliated as well as API to set it (#57)

[selection-api] Is Selection.removeAllRanges() and Selection.removeRange(range) doing the same thing? (#48)

[selection-api] Make some arguments optional (#30)

[selection-api] Need an API to get the current caret rects (#58)

[selection-api] Selection events for text controls (#53)

[selection-api] setPosition/collapse should taken an optional argument for whether the caret is before or after a line break (#51)

[selection-api] Should selectionchange be fired when the Range object is directly mutated (#52)

[selection-api] Specify Selection.empty() as an alias of removeAllRanges() (#36)

[selection-api] Specify Selection.modify()? (#37)

[selection-api] Specify Selection.setPosition()? (#38)

[selection-api] The spec doesn't define event handlers onselectstart and onselectionchange (#55)

[selection-api] unsigned long is never negative (#33)

[selection-api] Use https for respec. (#49)

[selection-api] We need to expose line direction coordinate as a property (#59)

[ServiceWorker] "unload" event and Service Workers (#731)

[ServiceWorker] 24 hour spontaneous update doesn't seem specced (#514)

[ServiceWorker] Concerns about `cache.addAll` not filtering non-200 (#407)

[ServiceWorker] Describe waitUntil() behavior in terms of Promise.all() (#738)

[ServiceWorker] Event queuing model for SW (#649)

[ServiceWorker] Expanded on the update() Note: (#616)

[ServiceWorker] FetchEvent is non cancelable yet checks canceled flag (#741)

[ServiceWorker] Handle Fetch needs to use new hooks (#729)

[ServiceWorker] Interception of the fallback requests initiated from a SW for cross-origin resources (#684)

[ServiceWorker] Limit Cache API to HTTPS (#709)

[ServiceWorker] Make FetchEvent.prototype.client nullable (#631)

[ServiceWorker] Make importScripts() fail outside install (#730)

[ServiceWorker] Make the Cache API deal with request's redirect mode not being "follow" (#737)

[ServiceWorker] Mention self.skipWaiting() instead of event.replace() (#733)

[ServiceWorker] navigator.serviceWorker is not defined (#689)

[ServiceWorker] Need for linkable and reusable section that defines the https restriction (#601)

[ServiceWorker] openWindow(url)'s same origin check should be done against the origin of the final response's url? (#646)

[ServiceWorker] Please distinguish URL strings from URL records (#736)

[ServiceWorker] Please mention relationship to HTTP cookies (#509)

[ServiceWorker] Remove frameType, maybe add ancestorOrigins (#732)

[ServiceWorker] Should FileReaderSync be exposed to service workers? (#735)

[ServiceWorker] should scope matching do substring comparison within a path element? (#734)

[ServiceWorker] Should UUID for unique IDs be mandated? (#647)

[ServiceWorker] Specify .focus() and .openWindow() behaviour (#602)

[ServiceWorker] SW spec never hooks into the "runs a worker" term that the CSP spec uses to enforce CSPs (#378)

[ServiceWorker] typo: excecution -> execution (#739)

[ServiceWorker] Update algorithm: propagation of uncaught runtime script error needs to be better specified. (#740)

[ServiceWorker] When does the openWindow promise resolve? (#728)

[spec-reviews] Clear Site Data (#62)

[spec-reviews] Create presentation-api.md (159e888)

[spec-reviews] Cross-spec device identification & association (#64)

[spec-reviews] File URI Scheme (#59)

[spec-reviews] Find out if the Batter Status API people need our feedback (#68)

[spec-reviews] Find out if the Battery Status API people need our feedback (#68)

[spec-reviews] Frame Timing API (#56)

[spec-reviews] Media TF discussion (#69)

[spec-reviews] Navigation Error Logging (#24)

[spec-reviews] Navigation Timing 2 (#18)

[spec-reviews] Review Payments Working Group Charter (#67)

[spec-reviews] Sketch out proposals for event synthesis/flow and reusable a11y behavior (#63)

[spec-reviews] Web NFC API (#22)

[spec-reviews] WebPush (#60)

[storage] Add API to allow origin to purge all storage (#4)

[storage] Allow script to request permission only if there would be no prompt (#9)

[storage] Change persistentPermission() to persistent() (#7)

[storage] Classify cookies as site storage (#8)

[storage] Encourage user agents to give out conservative estimates (#3)

[storage] Make requestPersistent() return a boolean (#7)

[storage] requestPersistent() needs to change the default box (#6)

[storage] Restrict to Secure Contexts (#5)

[storage] Use PermissionState instead of PersistentStoragePermission (#10)

[streams] Add .bytesRead to ReadableByteStream.*Reader (#367)

[streams] Add IsDisturbed predicate (#378)

[streams] Add IsReadableStreamDisturbed predicate (#385)

[streams] Byte stream update, including reference implementation (#361)

[streams] Consistency of return value of ReadableStreamController method call on closed/errored streams (#388)

[streams] Delayed setting timeous to have better chances on slower systems. (#392)

[streams] Do writable streams need separate signals for write-success vs. write-accepted? (#316)

[streams] Initialize variables of ReadableStreamReader to the final value direc… (#373)

[streams] Investigate merging RS and RBS (#379)

[streams] More tests to the suite (#391)

[streams] Notate abstract ops that can throw (#371)

[streams] Notate throwing vs. non-throwing abstract operations (#386)

[streams] Port locking infrastructure to writable streams (#319)

[streams] Port precise flow control to writable streams (#318)

[streams] ReadableByteStream needs reference implementation/tests (#355)

[streams] Real time source and skipping (#383)

[streams] Separate out exported abstract ops from internal ones (#372)

[streams] Size of NaN is either throwing a RangeError or a TypeError (#389)

[streams] Some tests behaving differently (#390)

[streams] Typo in ErrorReadableStream algorithm (#387)

[streams] Update FAQ with some extra answers (#365)

[touch-events] Add a constructor for TouchEvent and Touch (#16)

[touch-events] Add tests for TouchEvent and Touch constructors (#27)

[touch-events] Create stub touchevents.html (f9f74c4)

[touch-events] Define the ontouch* event handler attributes (#11)

[touch-events] Delete wd and v1-errata branches? (#24)

[touch-events] Move touchevents.html to index.html? (#26)

[touch-events] Redirect "latest editors draft" link to github. (#18)

[touch-events] Reformat code (#2)

[touch-events] standardize initTouchEvent (#29)

[touch-events] TouchEvent and Touch should have constructors (#10)

[touch-events] TouchInit should perhaps include pageX and pageY (#28)

[uievents] #event-type-input and #event-type-beforeinput appear to have gone missing (#2)

[uievents] beforeInput should also be triggered when no "character value" is produced (#4)

[webcomponents] [#128] Add Element.slot attribute. (2a946c7)

[webcomponents] [Custom Elements] Write-up proposal for using a "state object" (#287)

[webcomponents] [Shadow]: How should Element.requestPointerLock() work in shadow DOM? (bugzilla: 26934) (#192)

[webcomponents] [Shadow]: rename <content> to <slot> (bugzilla: 28561) (#92)

[webcomponents] [Shadow]: The return type of Event.path should leverage WebIDL sequences (bugzilla: 25458) (#101)

[webcomponents] Add "Constructor Dmitry" proposal (#294)

[webcomponents] Added proposed changes to the cascade order for Shadow DOM. (#292)

[webcomponents] Address @othermaciej's feedback to "Constructor-Dmitry" (#297)

[webcomponents] CSS Cascading Order in Shadow DOM should define behavior for closed shadow trees (#293)

[webcomponents] Custom element callbacks for builtins (#291)

[webcomponents] Enumerate the element names which don't support createShadowRoot(), instead of looking at the binding property (#110)

[webcomponents] Finalize the slots proposal (#128)

[webcomponents] Fix participates typo (#296)

[webcomponents] Fix typo and add missing selectors (#295)

[webcomponents] How the current model and the v1 model should interact? (#130)

[webcomponents] Is there a custom pseudo-elements proposal or spec anywhere? (#298)

[webcomponents] Need to update CSS Scoping for closed shadow tree (#293)

[webcomponents] Rename createShadowRoot to attachShadow (#129)

[webcomponents] Tag first published draft. (193ff07)

[xhr] Help (#24)

[xhr] Remove XMLHttpRequest from ServiceWorkerGlobalScope (#19)

Last message date: Monday, 31 August 2015 23:00:54 UTC