public-webapps-github@w3.org from December 2017 by subject

[heycam/webidl] "converting to an ECMAScript value" needs to take a realm, at least sometimes (#371)

[heycam/webidl] [wip] First pass at adding internal slots (#495)

[heycam/webidl] Add missing full stops (#482)

[heycam/webidl] Add space to class string of iterator objects (#483)

[heycam/webidl] Adding slots [initial braindump] (#258)

[heycam/webidl] Best practices for specifications listing internal slots of objects (#487)

[heycam/webidl] Can we have a way for enums to not throw if there are unknown values (#491)

[heycam/webidl] Clarify that [Unforgeable] doesn't apply to static members (#498)

[heycam/webidl] Class string of default iterator object seems to have been accidentally changed? (#419)

[heycam/webidl] Consider semantic changes to WebIDL to make suitable for ECMAScript (#484)

[heycam/webidl] Consider syntactic changes to WebIDL to make it more "JavaScript-y" (#485)

[heycam/webidl] Considering factoring WebIDL to allow use from the ECMAScript specification (#486)

[heycam/webidl] Disallow [Unforgeable] on static attributes (#497)

[heycam/webidl] Editorial: add DOMRectList to the legacy [NoInterfaceObject] list (#502)

[heycam/webidl] Editorial: cleanup platform and legacy platform object descriptions (#493)

[heycam/webidl] Editorial: Correct assertion (#500)

[heycam/webidl] Editorial: Revert "add DOMRectList to the legacy [NoInterfaceObject] list" (#503)

[heycam/webidl] Fix and clarify exposed dfn (#464)

[heycam/webidl] Fix bikeshed warnings (#492)

[heycam/webidl] Import (and fix) the promises guide (#490)

[heycam/webidl] Investigate removing [PrimaryGlobal] and requiring [Exposed] (#365)

[heycam/webidl] Make [Exposed] mandatory, remove [PrimaryGlobal] (#423)

[heycam/webidl] Make creation of all initial objects/properties/methods/etc. imperative (#467)

[heycam/webidl] Make interface prototype object creation imperative (#494)

[heycam/webidl] Meta: fix markup now that Bikeshed supports mixins (#499)

[heycam/webidl] Only install @@toStringTag on the prototype (#357)

[heycam/webidl] Proposed solution to make grammar changes less disruptive (#477)

[heycam/webidl] Prototype of @@unscopable object (#496)

[heycam/webidl] ReadableStream IDL type (#445)

[heycam/webidl] Remove definition of class strings of default iterator objects (#501)

[heycam/webidl] Syntactic changes to attributes (#488)

[heycam/webidl] Use RangeError rather than TypeError for enum mismatch (#489)

[w3c/clipboard-apis] Clipboard API mixes representations of an item with distinct items. (#55)

[w3c/clipboard-apis] Emphasize visability in the "pick target"-algorithm (#58)

[w3c/clipboard-apis] Should clipboard actions consider whether selection has focus? (#57)

[w3c/FileAPI] Consider centrally defining all users of the blob URL store (#93)

[w3c/FileAPI] Make input[type=file] assignable for File objects (#24)

[w3c/FileAPI] Make the FileList interface iterable (#94)

[w3c/FileAPI] Refactor Blob URL Store definition. (#92)

[w3c/FileAPI] Rename EndingTypes to EndingType or EndingsType (#91)

[w3c/filesystem-api] Is this spec deprecated? (#8)

[w3c/gamepad] Should fire events instead of using passive model (#4)

[w3c/IndexedDB] Support full text indexes (#44)

[w3c/manifest] "Default" Orientation (#632)

[w3c/manifest] Add support for 'serviceworkers' member (#507)

[w3c/manifest] Allow sub-domains in manifest scope ? (#631)

[w3c/manifest] Don't use enums, because they throw (#633)

[w3c/manifest] feat: add support for adaptive icons (#563)

[w3c/manifest] Multiple authors / developers (#630)

[w3c/manifest] Richer splash screen backgrounds (#589)

[w3c/manifest] Support a way to update explicitly (#446)

[w3c/permissions] A new permission for canvas data (#165)

[w3c/permissions] Discuss how query() makes abuse harder to detect. (#166)

[w3c/permissions] Introduce "Automation" section (#151)

[w3c/push-api] What type of equality checking is being performed for options. (#275)

[w3c/selection-api] No definition of hidden selections (#94)

[w3c/ServiceWorker] `updatefound` event in service worker context seems unreliable (#1255)

[w3c/ServiceWorker] Add CR Plan for V1 (#1242)

[w3c/ServiceWorker] Allow caches to opt-in to granular cleanup (#863)

[w3c/ServiceWorker] Allow overlapping scopes (#1085)

[w3c/ServiceWorker] Avoid array manipulation in parallel (#1243)

[w3c/ServiceWorker] Clean up prose about waitUntil on install & activate events (#1227)

[w3c/ServiceWorker] Clean up prose about waitUntil on install and activate events (#1248)

[w3c/ServiceWorker] consider Client behavior for windows where initial about:blank is replaced with a loaded document (#1091)

[w3c/ServiceWorker] consider fetching service worker scripts with no-cache by default (#893)

[w3c/ServiceWorker] consider firing a "clientcontrolled" event on ServiceWorkerGlobalScope (#886)

[w3c/ServiceWorker] Correct typo (#1244)

[w3c/ServiceWorker] Delete foreign_fetch_explainer.md (#1236)

[w3c/ServiceWorker] event.waitUntil vs return promise (#1148)

[w3c/ServiceWorker] fetch() file stream fails when passing through fetch handler (#1246)

[w3c/ServiceWorker] getRegistrations manipulates ES arrays in parallel steps (#1241)

[w3c/ServiceWorker] How do I get extendableEvent.waitUntil() to play nicely with async functions (#1237)

[w3c/ServiceWorker] if a worker script redirects from an in-scope URL to an out-of-scope URL, what is the worker's final controller? (#1239)

[w3c/ServiceWorker] Make the promise settlement type of WindowClient.navigate() nullable (#1253)

[w3c/ServiceWorker] matchAll manipulates ES arrays in parallel steps (#1240)

[w3c/ServiceWorker] Proposal: FetchEvent.navigationLoadType (#1167)

[w3c/ServiceWorker] Provide a one-line way to listen for a waiting Service Worker (#1222)

[w3c/ServiceWorker] Provide an easier way to listen for waiting/activating/redundant Service Workers (#1247)

[w3c/ServiceWorker] Remove fragment identifiers from script url and scope url (#1251)

[w3c/ServiceWorker] resurrected service workers don't fire an activate event which may break expectations (#1204)

[w3c/ServiceWorker] should Client.navigate() reject on uncontrolled clients? (#1254)

[w3c/ServiceWorker] should clients.claim() control reserved Clients? (#1090)

[w3c/ServiceWorker] Should ServiceWorker.scriptURL have fragment removed? (#742)

[w3c/ServiceWorker] Should the fragment identifier be stripped from the scriptURL? (#1249)

[w3c/ServiceWorker] Should we expose reserved clients? (#1216)

[w3c/ServiceWorker] Soft Update seems way to aggressive (#1250)

[w3c/ServiceWorker] spec behavior when ServiceWorkerContainer parent client is dead (#777)

[w3c/ServiceWorker] Spec FetchEvent.resultingClientId/targetClientId (#1245)

[w3c/ServiceWorker] Use Web IDL's new-ish interface mixins concept (#1252)

[w3c/ServiceWorker] what happens if an initial about:blank inherits a controller, but its navigation request does not match any service worker? (#1232)

[w3c/uievents] Add specification for AltGraph key & modifier behaviour (#147)

[w3c/uievents] Dispatch a click event when keyup or keydown? (#174)

[w3c/uievents] Dispatch mouseenter/leave/out/over when the layout (or scroll) changes (#154)

[w3c/uievents] fix hide of column 'proposed' (#175)

[w3c/uievents] Update key-event-viewer (c4604ab)

[w3c/webcomponents] <iframe> and the History API (#184)

[w3c/webcomponents] [idea] Allow custom element naming on a per-shadow-root basis. (#488)

[w3c/webcomponents] [idea] Make use of `observedAttributes` optional (#565)

[w3c/webcomponents] [Proposal] customElements#hasLocalName(Class) (#714)

[w3c/webcomponents] [templates] API for updating (#685)

[w3c/webcomponents] [templates] Contextual auto-escaping (#711)

[w3c/webcomponents] [templates] Ensure that template instantiation actually improves the platform (#704)

[w3c/webcomponents] Add a CSS subtype selector. (#719)

[w3c/webcomponents] Add an assignedElements() method (#602)

[w3c/webcomponents] Bulk property updates (#718)

[w3c/webcomponents] document.currentScript from a script in a shadow tree. (#477)

[w3c/webcomponents] Highlight code blocks, fix emphasis (#712)

[w3c/webcomponents] Scoped Custom Element Registries (#716)

[w3c/webcomponents] The is="" attribute is confusing? Maybe we should encourage only ES6 class-based extension. (#509)

[w3c/webcomponents] The way to access current script or current root, from Shadow DOM (#717)

[w3c/webcomponents] Undefined specification for @keyframe scope on slotted content (#715)

[w3c/webcomponents] WebPlatform Web Components F2F 2018 (#713)

[w3c/WebPlatformWG] Simplify text for introduction course (93c07f2)

[w3ctag/design-reviews] "With Credentials" flag possibly inconsistent with web architecture (#76)

[w3ctag/design-reviews] `Accept-CH` header is weird (#206)

[w3ctag/design-reviews] CSS Selectors 4 (#219)

[w3ctag/design-reviews] Img decoding attribute (#220)

[w3ctag/design-reviews] import.meta.url, and import.meta generally (#208)

[w3ctag/design-reviews] Intersection Observer review (#197)

[w3ctag/design-reviews] saveData attribute in Network Information API (#204)

[w3ctag/design-reviews] Sensor APIs (#207)

[w3ctag/design-reviews] Web payment method manifest (#162)

[w3ctag/design-reviews] Web Share Target API (#221)

[whatwg/dom] [Proposal] Add EventTarget.getEventListeners() (#412)

[whatwg/dom] AbortSignal "signal abort" ordering (#493)

[whatwg/dom] Confusing sentence: “In tree order is preorder, depth-first traversal of a tree.” (#552)

[whatwg/dom] Consider removing `document.origin` (#410)

[whatwg/dom] Define a mapping to a Selectors Element Tree (#542)

[whatwg/dom] Editorial: use JavaScript string length (#538)

[whatwg/dom] Improving ergonomics of events with Observable (#544)

[whatwg/dom] Inconsistency in execution of unclosed attribute selector for querySelector (#549)

[whatwg/dom] Meta: update .travis.yml (#550)

[whatwg/dom] Meta: use "good first issue" as label (#548)

[whatwg/dom] MutationObserver needs an equivalent of disconnected & connected callbacks (#533)

[whatwg/dom] Proposal: DOMChangeList (#270)

[whatwg/dom] Proposal: Element.elementIndex, Node.nodeIndex (#546)

[whatwg/dom] Proposal: ParentNode.empty() (#478)

[whatwg/dom] Proposal: RangeList (#543)

[whatwg/dom] Proposal: Spellcheck API (#547)

[whatwg/dom] root = true [*] end_of_line = lf insert_final_newline = true charset = utf-8 indent_size = 1 indent_style = space trim_trailing_whitespace = true max_line_length = 100 [Makefile] indent_style = tab [.travis.yml] indent_size = 2 (#541)

[whatwg/dom] Specify [LegacyWindowAlias=HTMLDocument] on Document (#551)

[whatwg/dom] Update WebIDL definition(s) to use new mixin syntax (#532)

[whatwg/dom] Use `interface mixins` instead of `[NoInterfaceObject]` (#545)

[whatwg/encoding] [clarification] encodeURI and pseudo-utf-16 surrogates in the astral planes (#131)

[whatwg/encoding] encodeURI (#131)

[whatwg/encoding] Figure out if anything is needed for better HTML integration (#128)

[whatwg/encoding] Make TextEncoder and TextDecoder be transform streams (#127)

[whatwg/encoding] Meta: update .travis.yml (#129)

[whatwg/encoding] Meta: update .travis.yml (#130)

[whatwg/encoding] TextEncoder#encode - write to existing Uint8Array (#69)

[whatwg/fetch] Accept headers in spec cause confusion (#274)

[whatwg/fetch] Add a diagram of the call graph for the fetch algorithms (#646)

[whatwg/fetch] Add RequestInit members to Request domintro (#620)

[whatwg/fetch] Allowing user provided CORS exceptions? (#644)

[whatwg/fetch] Constructing a Response with Content-Encoding? (#589)

[whatwg/fetch] Define data: URLs (#579)

[whatwg/fetch] Define the "Preload Cache" (#590)

[whatwg/fetch] Editorial: spell cypher as cipher (#649)

[whatwg/fetch] FetchObserver (for a single fetch) (#607)

[whatwg/fetch] Generic Accept header value */* and Service Workers (#634)

[whatwg/fetch] Isn't request.body not part of the spec? (#643)

[whatwg/fetch] Make observability examples nitpick-proof (#642)

[whatwg/fetch] Meta: update .travis.yml (#648)

[whatwg/fetch] preload, destinations, and module scripts (#486)

[whatwg/fetch] Requests cant "live" longer than 5 minutes? (#647)

[whatwg/fetch] Should Body.formData() always strip the BOM? (#650)

[whatwg/fetch] Update Fetch to support Token Binding. (#325)

[whatwg/fetch] Update WebIDL definition(s) to use new mixin syntax (#624)

[whatwg/fetch] Use `interface mixins` instead of `[NoInterfaceObject]` (#645)

[whatwg/fullscreen] Meta: update .travis.yml (#109)

[whatwg/fullscreen] Specify focus/tabbing order while in fullscreen (#108)

[whatwg/fullscreen] The values of meta viewport attribute are not reflected when in full screen mode in android chrome browser. (#111)

[whatwg/fullscreen] Unable to zoom and scroll in mobile browsers when in full screen. (#110)

[whatwg/storage] Meta: update .travis.yml (#55)

[whatwg/storage] Update WebIDL definition(s) to use new mixin syntax (#53)

[whatwg/storage] Use `interface mixins` instead of `[NoInterfaceObject]` (#54)

[whatwg/streams] Branch snapshot missing for algorithm-slots branch (#858)

[whatwg/streams] Change quote style in lipfuzz example (#862)

[whatwg/streams] Check precisely the way that transformer.transform() is called (#689)

[whatwg/streams] Constructing ReadableStream and WritableStream in TransformStream constructor (#850)

[whatwg/streams] Export interface definitions (#861)

[whatwg/streams] Fix typo in SetUpTransformStreamDefaultController (#863)

[whatwg/streams] How much latitude should implementations have in looking up transformer.transform()? (#691)

[whatwg/streams] Lookup methods in constructors (#860)

[whatwg/streams] Meta: update .travis.yml (#864)

[whatwg/streams] rethrowAssertionErrorRejection is broken (#865)

[whatwg/streams] Review request on the ReadableStream API (#433)

[whatwg/streams] Stack details are omitted in output of tap-spec (#478)

[whatwg/streams] Things to move into/add to the spec text (#228)

[whatwg/streams] WebIDL syntax for parameterized streams? (#678)

[whatwg/url] case-insensitive domain names (#357)

[whatwg/url] Clarify status of empty path segments (#358)

[whatwg/url] Consider adding a constructor to make a URL from parts (#354)

[whatwg/url] Consider percent-encoding more characters in "fragment state" (#344)

[whatwg/url] Editorial: add missing link (#362)

[whatwg/url] Meta: update .travis.yml (#361)

[whatwg/url] Meta: update copyright license and Bikeshed boilerplate (#360)

[whatwg/url] Percent-encode additional characters in "fragment state". (#347)

[whatwg/url] Scheme - String (#359)

[whatwg/xhr] Allow developers to opt-out of sync XHR with feature policy (#178)

[whatwg/xhr] Clean up remaining MIME type usage (#175)

[whatwg/xhr] Define Content-Type manipulation in terms of MIME Sniffing (#176)

[whatwg/xhr] Editorial: use "{{ExceptionType!!exception}}" {{DOMException}} throughout (#173)

[whatwg/xhr] Editorial: use HTML/XML MIME type terms (#171)

[whatwg/xhr] Fix overrideMimeType() again (#174)

[whatwg/xhr] Integrate feature policy (#177)

[whatwg/xhr] Meta: update .travis.yml (#179)

[whatwg/xhr] Parse string as FormData (#180)

[whatwg/xhr] reth (#181)

[whatwg/xhr] Use "XML MIME type" (#160)

[whatwg/xhr] Use document encoding for URL parser (#159)

[whatwg/xhr] Use the API URL character encoding for XMLHttpRequest (#172)

Last message date: Sunday, 31 December 2017 15:38:08 UTC