public-webapps-github@w3.org from September 2018 by subject

[heycam/webidl] Add dedicated IDL syntax for indexed property getters (#584)

[heycam/webidl] Async constructors? (`new Foo()` returning Promise<Foo>) (#563)

[heycam/webidl] Include the legacy namespace identifier in both interface prototype objects and platform objects. (#577)

[heycam/webidl] Is it true that dictionaries can't have a default value specified? (#585)

[heycam/webidl] Need pattern for feature detecting dictionary members (#107)

[heycam/webidl] Only install @@toStringTag on the prototype (#357)

[heycam/webidl] Should "perform some steps once a promise is settled" use %PromiseProto_then%? (#583)

[heycam/webidl] Sort out when dictionaries and records should have default values (#76)

[heycam/webidl] What about i64? (#586)

[w3c/clipboard-apis] Specify NotAllowedError when permission is not granted (#82)

[w3c/editing] Should a styled paragraph maintain its own style when inserting it in a list ? (#179)

[w3c/FileAPI] Correct typo in `revokeObjectURL` (#109)

[w3c/IndexedDB] Add IDBTransaction commit() method (#242)

[w3c/IndexedDB] Integrate with window.onerror (#49)

[w3c/manifest] Add a 'masking' purpose, for allowing the UA to supercompose such icons (#657)

[w3c/manifest] Allowing only site-triggered install prompt (#627)

[w3c/manifest] Breaking: Change requirement to block off-scope navigation. (#701)

[w3c/manifest] Can I use should show mobile browsers as well? (#717)

[w3c/manifest] Change platform android by play in exemple (#581)

[w3c/manifest] chore: Added PULL_REQUEST_TEMPLATE. (#697)

[w3c/manifest] Deleted repeated "safe" and fixed typo in definition of "safe zone" (#720)

[w3c/manifest] Editorial: Add mobile browsers to caniuse block (#719)

[w3c/manifest] Editorial: Attempt to fix the navigation scope monkey patching. (#700)

[w3c/manifest] Editorial: Remove duplicate dfn of iarc_rating_id (#718)

[w3c/manifest] editorial: use auto pluralize (#683)

[w3c/manifest] feat: add support for adaptive icons (#563)

[w3c/manifest] Make unbounded navigation scope less broad (#550)

[w3c/manifest] service worker sections: mixed up inputs and outputs, some suggestions (#706)

[w3c/manifest] Should appinstalled / beforeinstallprompt fire on native app installation? (#514)

[w3c/permissions] Add support for permissions that have an associated Feature Policy (#163)

[w3c/permissions] Adding background fetch (#183)

[w3c/pointerlock] Option needed to disable OS-level adjustment for mouse acceleration (#36)

[w3c/push-api] Allow atomic push resubscribe (#292)

[w3c/push-api] Make it clear that an endpoint must contain a secure random (#301)

[w3c/push-api] Push notifications for logged In user (#297)

[w3c/push-api] Push subscription endpoint autodiscovery in HTML page: rel="alternate" type="urn:ietf:params:push" (#299)

[w3c/push-api] pushManager.subscribe should replace applicationServerKey if different (#291)

[w3c/push-api] Retry push event (#300)

[w3c/push-api] Simplifying functional event firing (#298)

[w3c/screen-orientation] Send events before promise resolve (#120)

[w3c/ServiceWorker] Abstracting cache matching (#1341)

[w3c/ServiceWorker] Add CR Plan for V1 (#1242)

[w3c/ServiceWorker] Allow Caching of POST requests (#977)

[w3c/ServiceWorker] Beyond V1 (#1353)

[w3c/ServiceWorker] Cache transactions & fixing `addAll` (#823)

[w3c/ServiceWorker] Clarify dynamic-imported scripts are never installed (#1356)

[w3c/ServiceWorker] Making it easier to handle the state of extendable events (#1348)

[w3c/ServiceWorker] Order of messages to clients in same unit of related browsing contexts unclear (#1355)

[w3c/ServiceWorker] Preventing server-forced updates (#822)

[w3c/ServiceWorker] Process the events reliably with retries (#1352)

[w3c/ServiceWorker] Remove foreign fetch (#1188)

[w3c/ServiceWorker] Remove unused variables (#1354)

[w3c/ServiceWorker] service worker source file is requesting from the server every time any navigation occurs in the page/ an frame is embedded in the page (#1351)

[w3c/ServiceWorker] Service workers and mixed content (#493)

[w3c/ServiceWorker] should a frame navigated to about:blank inherit a service worker controller? (#1350)

[w3c/uievents] Consider to make mouseenter/leave (and pointerenter/leave) uncomposed (#208)

[w3c/uievents] Event order between "compositionend" and "input" (#202)

[w3c/uievents] Figure out what to do with focusin/focusout (#88)

[w3c/uievents] Spec event.keyCode for keypress events (#213)

[w3c/uievents] Update bikeshed (#212)

[w3c/webcomponents] Composite custom element is not defined until the parent element is connected (#765)

[w3c/webcomponents] CSS Modules (#759)

[w3c/webcomponents] DOM APIs which replace all children end up firing superfluous slotchange events (#764)

[w3c/webcomponents] How to define APIs only for custom element authors (#758)

[w3c/webcomponents] HTML Modules (#645)

[w3c/webcomponents] Need callback for form submit data (#187)

[w3c/webcomponents] Scoped Custom Element Registries (#716)

[w3c/webcomponents] The is="" attribute is confusing? Maybe we should encourage only ES6 class-based extension. (#509)

[w3c/webcomponents] Web Components F2F topics for 2018 TPAC (#763)

[w3c/WebPlatformWG] Add Keyboard Lock and Keyboard Map to charter (#122)

[w3c/WebPlatformWG] Add the User Input of Mathematics to Charter (#123)

[w3c/WebPlatformWG] Agendas: TPAC 2018 (#120)

[w3c/WebPlatformWG] CFC: Mark View-Mode Media Feature Obsolete (#121)

[w3c/WebPlatformWG] Mark ElementTraversal Rec as obsolete (#96)

[w3c/WebPlatformWG] Update work mode (#124)

[w3ctag/design-reviews] Carriage of Web Resource in ISOBMFF (#285)

[w3ctag/design-reviews] CSS Selectors 4, :focus-visible. (#233)

[w3ctag/design-reviews] DOM (#229)

[w3ctag/design-reviews] HTML General Review: Custom Elements (#244)

[w3ctag/design-reviews] HTML General Review: Web Sockets (#268)

[w3ctag/design-reviews] Intersection Observer review (#197)

[w3ctag/design-reviews] OffscreenCanvas new commit() and DedicatedWorker.requestAnimationFrame (#288)

[w3ctag/design-reviews] Request to review Image Decode API (#182)

[w3ctag/design-reviews] Review Accessibility Object Model (#134)

[w3ctag/design-reviews] Review request for WebVR (#185)

[w3ctag/design-reviews] Should WebRTC be [SecureContext] (#228)

[w3ctag/design-reviews] TAG review request of the CSP feature 'unsafe-hashes' (#291)

[w3ctag/design-reviews] Tag Review Request: Canvas TextMetrics (#302)

[w3ctag/design-reviews] TAG Review Request: Display Locking (#306)

[w3ctag/design-reviews] TAG Review Request: Form Participation API (#305)

[w3ctag/design-reviews] TAG Review Request: queueMicrotask (#294)

[w3ctag/design-reviews] TAG Review Request: RTCIceTransport & RTCQuicTransport (#296)

[w3ctag/design-reviews] TAG Review Request: RTCIceTransport (#304)

[w3ctag/design-reviews] TAG Review Request: RTCQuicTransport (#303)

[w3ctag/design-reviews] TAG Review Request: Support codec and container switching with MSE using SourceBuffer.changeType() (#298)

[w3ctag/design-reviews] TAG Review Request: User Activation API (#300)

[w3ctag/design-reviews] TAG review request: User Activation v2 (#295)

[w3ctag/design-reviews] Web Components Guidelines Doc? (#227)

[whatwg/dom] "A slot has an associated name (a string)" seems to be kept in sync manually (#690)

[whatwg/dom] "Use these attribute change steps to update a slot" was hard to find. (#689)

[whatwg/dom] `compareDocumentPosition` should allow comparison of elements in the same shadow-including root (#320)

[whatwg/dom] A faster way to find open shadow roots (or shadow hosts) (#665)

[whatwg/dom] Address feedback from Travis and Sangwhan (#702)

[whatwg/dom] Allow custom "get the parent" algorithms for EventTargets (#583)

[whatwg/dom] Allow removing event listeners by group (#469)

[whatwg/dom] Assign slotables for a tree should be invoked on node and not node's root in node remove (#691)

[whatwg/dom] Avoid setting target to the Window object (#698)

[whatwg/dom] Capturing event listeners are called during bubbling phase for shadow hosts (#685)

[whatwg/dom] Change `#time-origin` line, def <a> w/ `#dfn-time-origin` (#693)

[whatwg/dom] Change `#time-origin` to `#sec-time-origin` for <anchor> tag. (#688)

[whatwg/dom] Clarify whether a connected callback should be enqueued for the insertion in parser (#694)

[whatwg/dom] composedPath() is wrong (#684)

[whatwg/dom] Define mutation events (#305)

[whatwg/dom] Dispatch event always set the event.target to the global object after dispatch (#697)

[whatwg/dom] Document more event dispatch quirks (#687)

[whatwg/dom] Editorial: a removed node's root is itself (#692)

[whatwg/dom] Figure out what to do with XMLDocument (#278)

[whatwg/dom] Fix composedPath() once more (#696)

[whatwg/dom] Fix composedPath() once more (#699)

[whatwg/dom] Fix event path iteration (#686)

[whatwg/dom] Manage slot manipulation centrally and special case replace operations (#695)

[whatwg/dom] Proposal: ChildNode.wrapWith() (#479)

[whatwg/dom] Spec event.keyCode for keypress events (#701)

[whatwg/dom] window.event and shadow trees (#679)

[whatwg/dom] الصفحة الرئيسية (#700)

[whatwg/encoding] A (#158)

[whatwg/encoding] Bad (#160)

[whatwg/encoding] bind encoder to self (#159)

[whatwg/encoding] Concatenating two ISO-2022-JP outputs from a conforming encoder doesn't result in conforming input (#115)

[whatwg/encoding] Consider defining Japanese encoding sniffing (#157)

[whatwg/encoding] ISO-2022-JP encoder: document an oddity (#155)

[whatwg/encoding] see privat live fun (#156)

[whatwg/fetch] 204 and json (#113)

[whatwg/fetch] 5.6 garbage collection makes GC observable via service worker & resource timing (#810)

[whatwg/fetch] Add timeout option (#20)

[whatwg/fetch] After update to 3.0.0 Webpack build is failing on line 72 (#808)

[whatwg/fetch] Cache-mode and upstream Cache-Control (#722)

[whatwg/fetch] Check Feature Policy before attaching Client Hints (#811)

[whatwg/fetch] Cross-Origin Read Blocking (CORB) (#681)

[whatwg/fetch] Editorial: Use "append" to modify the header list (#807)

[whatwg/fetch] idea: Accept a iterator as a body (#809)

[whatwg/fetch] Improve description of the Conte (#812)

[whatwg/fetch] Purpose of the Content-DPR hint is not entirely clear. (#812)

[whatwg/fetch] Response content-length header almost always wrong (#67)

[whatwg/fetch] RFC: a mechanism to bypass CORS preflight (#210)

[whatwg/fetch] Specify restriction for requests with keepalive set (#679)

[whatwg/fetch] The link text for creating a new readable stream is awkward. (#806)

[whatwg/fetch] Update Fetch to support Token Binding (#715)

[whatwg/fetch] Use "append" instead of "set" to modify the header list (#758)

[whatwg/fullscreen] Add FullscreenOptions dictionary to requestFullscreen (#129)

[whatwg/fullscreen] Dispatch fullscreenchange on the fullscreen element (#122)

[whatwg/fullscreen] fun aplksi (#139)

[whatwg/fullscreen] Meta: fix Travis failure (#137)

[whatwg/fullscreen] Re-introduce the hierarchy restrictions (#140)

[whatwg/fullscreen] Reinstate the hierarchy restrictions (#91)

[whatwg/fullscreen] Report feature policy violations (#138)

[whatwg/fullscreen] Request Fullscreen take additional options (#123)

[whatwg/streams] add @@asyncIterator to ReadableStream (#954)

[whatwg/streams] add @@asyncIterator to ReadableStreamDefaultReader (#950)

[whatwg/streams] Allow aborting an ongoing pipe operation using AbortSignals (#744)

[whatwg/streams] Editorial: add some more cross-references (#953)

[whatwg/streams] WHATWG icon is broken in Chrome in combination with ServiceWorker (#955)

[whatwg/url] Add a neato informative table of various URL pieces (#337)

[whatwg/url] Enriched rendering of URLs (#417)

[whatwg/url] Grammar specification for URLs (#24)

[whatwg/url] relative URLs (#136)

[whatwg/url] Reparsing problem with non-special URL and double-dot path component (#415)

[whatwg/url] Restore formal grammar (#416)

[whatwg/xhr] Allow FormData constructor to accept array or object too (#202)

[whatwg/xhr] Do not reset override MIME type (#218)

[whatwg/xhr] How come `onreadystatechange` is the only event handler defined by default ? (#222)

Last message date: Sunday, 30 September 2018 21:30:44 UTC