public-webpayments-specs@w3.org from September 2018 by subject

[w3c/payment-handler] (Editorial) Clarify validation expectation (#324)

[w3c/payment-handler] (Editorial) fix storedInstrument per issue 316 (#323)

[w3c/payment-handler] (Editorial) link fix for issue 317 (#322)

[w3c/payment-handler] [WIP] showPaymentUI() method (#325)

[w3c/payment-handler] Add AbortPaymentEvent. (#207)

[w3c/payment-handler] Add support for communicating billing address to merchant (e.g., for VAT computation) (#314)

[w3c/payment-handler] Added more security implementation notes from Rouslan; non-normative (#320)

[w3c/payment-handler] Change payment method (#318)

[w3c/payment-handler] Code of Conduct (#326)

[w3c/payment-handler] Cross-origin iframes and feature policy. (#282)

[w3c/payment-handler] Drop PaymentInstrument in favor of MethodCapability (#302)

[w3c/payment-handler] Examples involving storedInstrument seem broken (#316)

[w3c/payment-handler] Fix Web IDL typo: bool → boolean (#319)

[w3c/payment-handler] How would iDeal work? (#251)

[w3c/payment-handler] Link for "fetching image object" is broken (#317)

[w3c/payment-handler] Links to terms and common terminology (#50)

[w3c/payment-handler] Normative what happens when users closing the window opened by PaymentRequestEvent.openWindow (#299)

[w3c/payment-handler] Notify merchant that payment method (possibly including the billing address) changed in payment handler. (#318)

[w3c/payment-handler] Only allows instrument.set() in active service worker (#224)

[w3c/payment-handler] Open Window Algorithm (#115)

[w3c/payment-handler] Payment Handler window `.focused` field (#307)

[w3c/payment-handler] PaymentManager behavior unclear (#253)

[w3c/payment-handler] Proposal: Remove requestPermission() (#246)

[w3c/payment-handler] Remove link to issue 157 (#292)

[w3c/payment-handler] Remove requestPermission() (#277)

[w3c/payment-handler] Review userHint (#273)

[w3c/payment-handler] Simplifying functional event handling (#305)

[w3c/payment-handler] Suggest changing a shape of openWindow() (#300)

[w3c/payment-handler] Support for Abort() being delegated to Payment Handler (#117)

[w3c/payment-handler] Update Example6 and Example7 (#290)

[w3c/payment-handler] Update Open Window Algorithm (#321)

[w3c/payment-handler] What mechanism allows enforcing payment handler authenticity? (#308)

[w3c/payment-handler] What should payees validate? (#310)

[w3c/payment-method-basic-card] add BasicCardErrors (#58)

[w3c/payment-method-basic-card] Define "last one wins" approach when Basic Card modifiers are equivalent (#60)

[w3c/payment-method-basic-card] Drop supportedTypes? (#59)

[w3c/payment-method-basic-card] Signaling payment handler details errors (#57)

[w3c/payment-method-basic-card] User changes payment method (#53)

[w3c/payment-method-id] Editorial: describe relationship to pay manifest (#53)

[w3c/payment-method-id] Generate an implementation report (#54)

[w3c/payment-method-id] Prepare for Proposed Recommendation (#56)

[w3c/payment-method-id] Updated the link to the test-suit (#55)

[w3c/payment-method-id] What can I do with a URL-based payment method identifier? (#52)

[w3c/payment-request] "data-test" should be changed to "data-tests" in spec (#785)

[w3c/payment-request] Add link to SecureContext test (#697)

[w3c/payment-request] Add MerchantValidationEvent.prototype.methodName (#776)

[w3c/payment-request] Add paymentMethodErrors, payerErrors, to PaymentDetailsUpdate (#768)

[w3c/payment-request] Add paymentMethodErrors, payerErrors, to PaymentDetailsUpdate (dbd585f)

[w3c/payment-request] Add support for crypto currencies (#627)

[w3c/payment-request] Can PaymentMethodChangeEventInit really have a required member? (#770)

[w3c/payment-request] Confirm test and specs align (#779)

[w3c/payment-request] Confirm tests and specs align (#779)

[w3c/payment-request] Define handling of multiple applicable modifiers (#684)

[w3c/payment-request] Define PaymentResponse.retry() method (#715)

[w3c/payment-request] Describe how to implement PaymentAddress.languageCode (#608)

[w3c/payment-request] Do we need to identify payment method in MerchantValidationEvent? (#775)

[w3c/payment-request] Editorial: fix link to basic card error dictionary in examples (#783)

[w3c/payment-request] editorial: mark languageCode at risk (#764)

[w3c/payment-request] Extract actionable items from Shopify study (#772)

[w3c/payment-request] Fix #779 : Confirm test and specs align (#784)

[w3c/payment-request] Fix #785 : data-test should be changed to data-tests in spec (#786)

[w3c/payment-request] Fix #787 : Fix the links to the `data-tests` in the spec (#788)

[w3c/payment-request] Fix link to basic card error dictionary in examples (#783)

[w3c/payment-request] Fix the links to the `data-tests` in the spec (#787)

[w3c/payment-request] fix: give dictionary member sensible defaults (#781)

[w3c/payment-request] fix: give dictionary members sensible defaults (#781)

[w3c/payment-request] fix: give PaymentMethodChangeEventInit defaults (#771)

[w3c/payment-request] Integration with Feature Policy (#600)

[w3c/payment-request] Issue #782 - Renames PayerErrorFields to PayerErrors (#789)

[w3c/payment-request] Make billing address optional (#773)

[w3c/payment-request] Modifiers and [[serializedModifierData]] not actually used anywhere. (#753)

[w3c/payment-request] Not able to add shipping options dynamically for apple pay (#778)

[w3c/payment-request] Not able to add shipping options for apple pay (#778)

[w3c/payment-request] PaymentDetailsUpdate needs to include payerErrors (#766)

[w3c/payment-request] Populate implementation report (#560)

[w3c/payment-request] Remove PaymentAddress' languageCode (#765)

[w3c/payment-request] Rename `PayerErrorFields` to be like `AddressErrors` and `BasicCardErrors` (#782)

[w3c/payment-request] Sensible defaults for dictionary members (#780)

[w3c/payment-request] Should API support billing address capture (for tax computation)? (#27)

[w3c/payment-request] Some clarifications with Payment Request API (#774)

[w3c/payment-request] support of VAT (#699)

[w3c/payment-request] Support requesting billing address (#749)

[w3c/payment-request] To address branded button issues and improve privacy, add browser support for payment method selection before the sheet (#777)

[w3c/webpayments-methods-tokenization] Add flow diagrams to the spec (#50)

[w3c/webpayments-methods-tokenization] Add more detail to cryptogram flows (#52)

[w3c/webpayments-methods-tokenization] Better orient the reader (#51)

[w3c/webpayments-methods-tokenization] Distinguish full tokenized-card from token-reference (lighter payment method) (#46)

[w3c/webpayments-methods-tokenization] How are future card on file transactions supported through dynamic data? (#44)

[w3c/webpayments-methods-tokenization] Remove supportedCryptogramTypes (#49)

[w3c/webpayments-methods-tokenization] What are the supportedCryptogramTypes? (#47)

Last message date: Sunday, 30 September 2018 15:05:25 UTC