public-webapps-github@w3.org from November 2015 by subject

[a11yapi] Introduce taxonomies (#27)

[a11yapi] Patterns (#28)

[clipboard-apis] Non Recognizable formats (#9)

[directory-upload] `getContents` poorly supports directories with many files/subdirectories (#3)

[directory-upload] Added Attributes Section (#22)

[directory-upload] directory content attribute not defined (#17)

[directory-upload] FileSystem API and this draft conflict (#19)

[directory-upload] getFilesAndDirectories should match that in FileSystem API (#7)

[directory-upload] It isn't clear whether Directory.path should include the name of the directory itself (#10)

[directory-upload] Made UI optional; created attribute and API separation (80f278a)

[directory-upload] Removed dependency on FileSystem API (#21)

[directory-upload] UI musts are a no-no (#16)

[DOM-Level-3-Events-code] Define Home key and Back key of Android smartphone (#4)

[DOM-Level-3-Events-code] Remove USB ID column from tables--not useful anymore (#6)

[DOM-Level-3-Events-key] [key] Separator (#8)

[DOM-Level-3-Events-key] Define key names for game controller of Android (#3)

[DOM-Level-3-Events-key] Define mobile phone related keys (#4)

[DOM-Level-3-Events-key] Define TV or A/V remote controller's keys (#5)

[DOM-Level-3-Events-key] DOM Level 3 KeyboardEvent key Values specification does not include core key values (#7)

[DOM-Level-3-Events-key] For user-agents on Windows OS, map the "windows key" to Meta (instead of "OS") (#9)

[DOM-Level-3-Events-key] Proposal key names for Android (#6)

[DOM-Level-3-Events-key] Typo: "key of often" [sic] (#10)

[dom] "If child’s parent is not parent, throw a NotFou..." (#98)

[dom] Add a validation step when a new DOMTokenList is created (#107)

[dom] Add EventListenerOptions (#82)

[dom] Attributes do not need a name slot for web compat (#110)

[dom] Change DOMTokenList's add() return value. (#114)

[dom] Consider DOMTokenList#replace (#28)

[dom] Do not remove child from its parent when replacing a node by itself (#121)

[dom] Document.documentURI and Document.URL attributes behaviour (#118)

[dom] DOMSettableTokenList needs an associated content attribute (#81)

[dom] DOMTokenList hook to validate added token is in a supported set of keywords (#103)

[dom] DOMTokenList validation for object creation and attribute updates (#106)

[dom] DOMTokenList/DOMSettableTokenList and associated attribute or attribute’s local name (#91)

[dom] Exception in DOMTokenList.add() and DOMTokenList.remove() algo (#93)

[dom] Fix #110: turn attribute's name slot into a qualified name "concept" (aaa22ab)

[dom] Fix #119: Merge DOMSettableTokenList into DOMTokenList (#120)

[dom] Fix queuing of mutation records when removing a node from its parent (#122)

[dom] Fix some references around Document interface. (#108)

[dom] Fix the adoption step when replacing node by child into parent (#121)

[dom] Formatting attributes and methods in prose (#92)

[dom] HTMLCollection.namedItem() vs supported property names (#104)

[dom] Let DOMTokenList's add() return false when there are no supported tokens (#112)

[dom] Let DOMTokenList.prototype.add() return false if there are no supported tokens (#111)

[dom] Make Attr a Node again (#102)

[dom] Merge DOMSettableTokenList into DOMTokenList (#119)

[dom] Possible typo: "as a node tree" to "as node trees" (#113)

[dom] Provide getAttributeNames() which returns an Array<DOMString> (#115)

[dom] removeEventListener doesn't handle currently dispatching events (#84)

[dom] setAttributeNode and setAttributeNodeNS can be an aliases (#117)

[dom] setAttributeNode should not change order of existing attributes (#116)

[dom] Spec for DOMTokenList stringifier disagrees with every single implementation (#105)

[dom] Specify CharacterData interface instead of implementers (#109)

[dom] Using [Exposed=Window] (#89)

[dom] When iterator collection is set? (#86)

[editing] change of event names beforeInput -> beforeEdit -> beforeInput? (#87)

[editing] list all required editTypes for beforeEdit/Edit events (#79)

[editing] Selection API - difference between collpase() and setPosition (#94)

[encoding] "13.2.2 iso-2022-jp encoder" (#15)

[encoding] "gb18030 ranges" have problematic definitions (#17)

[encoding] Add do not flush flag to encode API, accept DOMString (#14)

[encoding] Clarify scope of document in preface (#10)

[encoding] Serializing internal TextDecoder state? (#7)

[encoding] Signaling EOF in the streaming case is unspecified (or too unclear) (#12)

[encoding] Streaming should be a flag on the decoder instead of being a flag on the decode() call (#13)

[encoding] The title of the document needs to be more than one (commonly used) word (#11)

[encoding] UTf7 supports (#16)

[fetch] "cors-with-forced-preflight" is a mode (#152)

[fetch] Aborting a fetch (#27)

[fetch] Add about:unicorn easter egg. (de21fbc)

[fetch] Cache mode: fromCache (#40)

[fetch] Cache mode: security review (#39)

[fetch] Cache state: partial content (#38)

[fetch] Developer-controlled streams for request/response (#88)

[fetch] download progress while using body.arrayBuffer / etc (#158)

[fetch] Exempt HSTS-upgraded resources from mixed content blocking (#150)

[fetch] Expose body `transmitted` through API surface (#160)

[fetch] fetch() needs to send a */* header (#142)

[fetch] Fixed typos. (#163)

[fetch] force-Origin-header flag set for no-cors requests (#91)

[fetch] Handling of data URLs (#111)

[fetch] Handling Partial Content / 206 (#144)

[fetch] improve example (#157)

[fetch] need setHeader( request => newHeaders ) function called before request sent (#156)

[fetch] need setHeaderFunction( request => newHeaders ) function called before request sent (#156)

[fetch] Network policies should be enforced asynchronously (#161)

[fetch] Only-if-cached (#159)

[fetch] OpenEndedDictionary clarification (#164)

[fetch] Option to require response.ok (#103)

[fetch] Persisting headers on redirect (#139)

[fetch] Proposal: Support GET bodies (#83)

[fetch] Provide opt-in for Expect = "100-continue" (#41)

[fetch] Redirected range requests and preflights. (#145)

[fetch] Remove about:unicorn (#147)

[fetch] Separate 'report-only' and 'enforce' CSP execution (#155)

[fetch] The empty string is rejected as header values (#115)

[fetch] um... blasphemy but... what about .xml() ? (#151)

[fetch] Use the URL from the response, if it has one (#146)

[fetch] what should fetch() do if request's window has been destroyed or stopped? (#153)

[fetch] Why are headers a special data-structure? (#154)

[fetch] Why not support Basic Authentication in the API? (#162)

[fetch] XHR option to trigger busy indicators (#19)

[FileAPI] Add a FileList.drop(index) method (#25)

[FileAPI] Bikeshedding the spec (#5)

[FileAPI] Include file creation time and last access time. (#26)

[FileAPI] Persistent blob urls (#27)

[FileAPI] Remove FileList (Migrate to | typedef FileList FrozenArray<File>; | (#19)

[FileAPI] Stop using DOMError (#11)

[filesystem-api] Update IANA registration of filesystem: URL scheme (#6)

[findtext] note about character counts [I18N-ISSUE-496] (#4)

[gamepad] The API is not thread-safe and can not be fixed. (#18)

[img-conversion] "create" is keyword in blind binding.. (#17)

[img-conversion] Blink new features (#20)

[img-conversion] canDecodeType and canEncodeType (#18)

[img-conversion] create function (#19)

[img-conversion] createImageBitmap (#16)

[img-conversion] Should ImageData.create() accept an ArrayBuffer/ArrayBufferView? (#21)

[IndexedDB] Introduce a more general query mechanism beyond keys/ranges (#45)

[IndexedDB] Latest editor's draft is 404 (#61)

[IndexedDB] Support transaction timeouts (#43)

[manifest] Add integrity to image objects (#411)

[manifest] Chaals patch 1 (#416)

[manifest] grouping, precision (#414)

[manifest] Handleing capabilities with Manifoldjs (#412)

[manifest] oops (9c3f445)

[manifest] Proper desc, cleanup (#413)

[manifest] Update README with the new spec name and WG (#415)

[permissions] Add "wakeLock" to enum PermissionName (#53)

[permissions] Add screen sharing permissions (#45)

[push-api] Add a brief clarification about the expected X9.62 representation (#171)

[push-api] Add authentication secret (#174)

[push-api] Change references to webapp => service worker (#15)

[push-api] Force confidentiality and integrity protection (encryption) (#55)

[push-api] Mark `PushMessageData` methods as throwable (#165)

[push-api] Message encryption (#130)

[push-api] Multiple consecutive messages (#168)

[push-api] Only expose PushMessageData in Service Workers (#175)

[push-api] Review permissions text (#52)

[push-api] Review use of webapp vs. Service Worker (#172)

[push-api] Rewriting push event handling; allowing data to be optional. (#166)

[push-api] Should have a normative reference to the Promise specification (#60)

[push-api] Updating references to Promise and JSON.parse (#173)

[ServiceWorker] "no-cors" CSS SOP violation (#719)

[ServiceWorker] Add example for Service-Worker-Allowed (#775)

[ServiceWorker] Add examples for Service-Worker-Allowed header. Fixes #775. (fbee35e)

[ServiceWorker] Add note that activate event cannot fail SW activation (#776)

[ServiceWorker] Add SW to the spec (#772)

[ServiceWorker] Cache Request/Response consistency (#469)

[ServiceWorker] CacheStorage.has should not reject to indicate there is no such cache with cacheName (#781)

[ServiceWorker] CacheStorage.has() should not reject to indicate there is no such cache with cacheName (#781)

[ServiceWorker] Capture Window Client cannot use attributes/methods directly (#633)

[ServiceWorker] Client.postMessage should return a Promise (#677)

[ServiceWorker] Complicated sentence is complicated (#773)

[ServiceWorker] Define the extended HTTP headers. Fixes #717. (12063af)

[ServiceWorker] Define the lifetime of a blob URL created inside a service worker (#688)

[ServiceWorker] Disabling the secure origin check via flags (#779)

[ServiceWorker] Document the headers being introduced (#717)

[ServiceWorker] Expose environment ids? (#643)

[ServiceWorker] FetchEvent IDL issues (#680)

[ServiceWorker] functional events do not wait for activate to complete (#786)

[ServiceWorker] getRegistration IDL is wrong (#764)

[ServiceWorker] How are non-secure context Clients observable? (#791)

[ServiceWorker] Invoke the has focus steps instead of hasFocus() method directly. Fixes #633. (3d0ee14)

[ServiceWorker] Is fetchEvent.client a performance concern? (#723)

[ServiceWorker] Make secure context requirements more explicit (#754)

[ServiceWorker] matchAll() runs Request constructor off the main thread (#672)

[ServiceWorker] OCSP fetches bypass service worker (#564)

[ServiceWorker] Pattern for handling fingerprinted assets in cache? (#657)

[ServiceWorker] pending fetch events may be dispatched to exiting worker (#785)

[ServiceWorker] Possible run-to-completion violation in "Handle Service Worker Client Unload" (#746)

[ServiceWorker] Race when registering multiple service workers for the same scope (#783)

[ServiceWorker] Receivers of ranged responses must ensure all ranges come from the same underlying resource (#703)

[ServiceWorker] register() should not allow file://, wss://, etc (#780)

[ServiceWorker] requestIdleCallback (equivalent) for ServiceWorkerGlobalScope (#790)

[ServiceWorker] Service Worker Scope (#782)

[ServiceWorker] serviceworker for iframes with srcdoc (#765)

[ServiceWorker] ServiceWorkerRegistration.update() is unclear when uninstalling flag set (#784)

[ServiceWorker] should service worker still install if onerror event handle cancels error from uncaught exception? (#778)

[ServiceWorker] should update on navigation or the subsequent updatefound event be delayed until document DOM is loaded? (#788)

[ServiceWorker] Soft Update and Register can race when setting registration scriptURL (#789)

[ServiceWorker] Some grammar. (e7ddda2)

[ServiceWorker] spec behavior when ServiceWorkerContainer parent client is dead (#777)

[ServiceWorker] The prose for Clients.matchAll() distinguishes an omitted dictionary type argument (#792)

[ServiceWorker] The user agents? (#774)

[ServiceWorker] UA shouldn't be required to invoke Soft Update on every navigation (#715)

[ServiceWorker] what should the document base URI for an intercepted navigation (#787)

[ServiceWorker] WindowClient.navigate() for the same origin but off-scope clients (#752)

[ServiceWorker] Workers & SharedWorkers within ServiceWorkers (#678)

[spec-reviews] Audio Output Devices API (#91)

[spec-reviews] Bluetooth API Security Model (#90)

[spec-reviews] Credential Management API (#49)

[spec-reviews] Feedback on Keygen (#82)

[spec-reviews] Geofencing FPWG (#89)

[spec-reviews] Navigation Timing 2 (#18)

[spec-reviews] Notifications API (#94)

[spec-reviews] Promise rejection tracking events (#96)

[spec-reviews] Review Web Annotations specs (#93)

[spec-reviews] Security Questionnaire (#77)

[spec-reviews] Streams General issue (#92)

[spec-reviews] Web Background Sync API (#95)

[streams] Clean up more web platform tests (#408)

[streams] Clean up more web platform tests (0f26f4a)

[streams] Custom tee function (#401)

[streams] error should pass e to ErrorReadableStream (#403)

[streams] Fix parameter name in example WritableStream (#402)

[streams] Fixed typo (#404)

[streams] How generic is pipeTo? (#407)

[streams] Is the reference implementation usable yet ? (#406)

[streams] Rename ReadableByteStream (#405)

[streams] Use promise_test in web-platform-tests. (#400)

[touch-events] Add tests for TouchEvent and Touch constructors (#27)

[touch-events] Added legacy interface initTouchEvent (#47)

[touch-events] Canceling a touchmove should not prevent dispatching of clicks (#43)

[touch-events] Convert idl to new respec format (double comma in some dictionary members) (#31)

[touch-events] Import and replace Touch&TouchEvent constructor tests from w3c (#45)

[touch-events] Need tests for ontouch*, the GlobalEventHandlers (#44)

[touch-events] Remove tests from this repository in favour of wpt. (#46)

[touch-events] Some dictionary members don't display properly (#31)

[touch-events] standardize initTouchEvent (#29)

[uievents-code] Rename OSLeft/Right to MetaLeft/Right (#7)

[uievents] "Legacy" appendices should be normative (#50)

[uievents] Add reference to Edit Events spec (#59)

[uievents] Broken links make documentation useless (#53)

[uievents] Bug filing script doesn't select the component (#43)

[uievents] D3E and corelation with DOM4(W3C)/DOM(WHATWAG) and DOM3 Core (#19)

[uievents] Expose 'direction-inversion' in wheel events (#57)

[uievents] Expose 'inertial scrolling state' in wheel events (#58)

[uievents] Expose modern 'wheel' event parameters (inertial scrolling, direction inversion) (#56)

[uievents] Update refs to uievents-key and -code (#60)

[url] Clarification on URL.host setter's behavior (#75)

[url] IDNA (#53)

[url] Link all of "application/x-www-form-urlencoded parsing" for clarity (#73)

[url] The text of these standard appears vulnerable to mismatching other standards (#74)

[url] The text of this standard appears vulnerable to mismatching other standards (#74)

[webcomponents] [Custom]: Consider creating registries for HTML documents created through DOMImplementation in some cases (bugzilla: 23018) (#236)

[webcomponents] [Shadow] Section 2.4 - CSS inherit by default? (#314)

[webcomponents] attributeChangedCallback may be expensive for some attributes (#350)

[webcomponents] Clarify which registry is used for the result of create*Document() (#353)

[webcomponents] Need "slotting changed" event (#288)

[webcomponents] Resize events needed? (#352)

[webcomponents] Restrict the types of nodes that could be assigned to a slot (#351)

[webcomponents] Style attributes in Shadow DOM Cascade Order Proposal (#316)

[webcomponents] Typo in semantics (#349)

[webidl] 'Reject' definition. (#73)

[webidl] Add a [SecureContext] operator attribute (#65)

[webidl] DOMTimeStamp confusion (#2)

[webidl] Fix some problems with iterable declarations. (#72)

[webidl] Fragments (#56)

[webidl] Merge pull request #69 from bzbarsky/nix-Date (d1902ff)

[webidl] Sort out when dictionaries should have default values (#76)

[webidl] typo fix (#53)

[webidl] Web Platform WG now replaces Web Applications WG (#74)

[webidl] Why don't default iterator prototypes chain up to `%IteratorPrototype%`? (#75)

[WebPlatformWG] Add myself as attendee and major agenda items (#5)

[WebPlatformWG] Added hayato as an attendee (#10)

[WebPlatformWG] Added name to 29 Jan WC meeting (#8)

[WebPlatformWG] Adding rnwia as an attendee (#6)

[WebPlatformWG] Update 29janWC.md (#7)

[WebPlatformWG] Update 29janWC.md (#9)

[workers] Should Shared Workers be removed? (#2)

[xhr] Consider setting omit-Origin-header-flag for same origin requests (#31)

Last message date: Monday, 30 November 2015 22:25:35 UTC