public-webapps-github@w3.org from December 2014 by subject

[editing-explainer] Add a section for "new low-level APIs" to Editing Explainer (#3)

[editing-explainer] Add link to charter. (#23)

[editing-explainer] Add links to some TF resources. (#35)

[editing-explainer] BeforeInput or CommandEvent? (#9)

[editing-explainer] behavior of text nodes inside cE=typing (#22)

[editing-explainer] Consistent Shape for Intention Events (#12)

[editing-explainer] ContentEditable with UserSelect=None needs to be documented (#20)

[editing-explainer] Does ClipboardEvents need to match the shape of other Intention Events (#8)

[editing-explainer] execCommand or something new to fire IntentionEvents? (#5)

[editing-explainer] How can sites access browser spellchecking? (#36)

[editing-explainer] How can we integrate with rich forms and validation? (#6)

[editing-explainer] How do we feature detect Responsive Input Events? (#32)

[editing-explainer] how does cE=typing handle autocorrect and spelling suggestions? (#37)

[editing-explainer] How does cE=typing support IME text replacement? (#34)

[editing-explainer] How does cE=typing work with overtype (insert key is on) (#28)

[editing-explainer] How should custom controls declare their intention? (#18)

[editing-explainer] intents originating from components resp. scripts (#16)

[editing-explainer] Need to spec the data in beforeInput event (#29)

[editing-explainer] Should beforeFocus be another Responsive Input Event? (#27)

[editing-explainer] Should beforeInput Event happen if there is no selection? (#26)

[editing-explainer] Should Device-Specific Input Events say what Responsive Input Event they will cause? (#25)

[editing-explainer] Should execCommand be spec'd to do nothing in cE=typing? (#33)

[editing-explainer] Should sites be able to control Responsive Input Language? (#31)

[editing-explainer] Should undo/redo be beforeInput events? (#30)

[editing-explainer] Should we include the default result in the Intention Event? (#10)

[editing-explainer] What should be the shape of contentEditable? (#4)

[editing-explainer] What should be the target element for Responsive Input Events? (#24)

[editing-explainer] What should be the term for "Intentions" (#7)

[editing-explainer] Where can text be inserted? (and how? can UA create text nodes?) (#21)

[manifest] added text about installable web apps (#290)

[manifest] Allow multiple application contexts per app (#294)

[manifest] Clarify that start URL is not always `start_url`'s value (#293)

[manifest] Cleaned up markup and cross refs (#295)

[manifest] Cookies and data collection policies (#281)

[manifest] Define identity of a web app (closes #272) (#297)

[manifest] Define identity of a web app (closes #272) (dc34c95)

[manifest] Define identity of a web app. (#272)

[manifest] define URL Scope (closes #114) (#291)

[manifest] expanded navigation scope text (#296)

[manifest] expanded navigation scope text (e3b2821)

[manifest] Icon density parsing should have a developer warning (#282)

[manifest] Integration with service workers (#161)

[manifest] Link space (#288)

[manifest] Link space / "deep linking" (#288)

[manifest] Manifest icon's 'type' should be a valid IMAGE mime type, not a valid mime type (#287)

[manifest] manifest should be queried when app is launched from home screen (#292)

[manifest] Need to define how to apply the manifest (#226)

[manifest] specified applying a manifest (closes #226) (#289)

[manifest] specified applying a manifest (closes #226) (e5c4dcd)

[manifest] URL for updating badge/tag (e.g. number of messages waiting) (#268)

[manifest] URL Scope to which the manifest applies (#114)

[manifest] What is the identity of an app? (#272)

[manifest] When created, navigate to start url (b9fde73)

[permissions] Redundant assertion (#2)

[push-api] .getRegistration() should not reject if there is no registration (but return a null object) (#96)

[push-api] Add and Encryption Key array to the PushRegistration interface (#89)

[push-api] Add optional userVisibleOnly parameter to register & hasPermission (#87)

[push-api] endpoint should be of type URL not DOMString (#93)

[push-api] Make PushEventInit inherit from ExtendableEventInit (#90)

[push-api] Mention what to do in register() and getRegistration() if there is no active SW (#100)

[push-api] Move unregister() to PushRegistration. (#97)

[push-api] Push registration should require active Service Worker (#92)

[push-api] removed wrong curly bracket in example (#91)

[push-api] Rename (un)register to (un)subscribe (#98)

[push-api] Rename PushRegistrationManager to PushManager. (#99)

[push-api] ServiceWorkerRegistration.pushRegistrationManager is very verbose (#47)

[push-api] Technique to Detect Endpoint Prior to register() (#95)

[push-api] unregister() should be available on the PushRegistration object (#94)

[push-api] Use ExtendableEventInit instead of EventInit (#78)

[screen-orientation] The orientation type 'Natural' should only lock to x-primary (#83)

[selection-api] Add a "Selection interface" section (#29)

[selection-api] Add Selection.type to the spec (#14)

[selection-api] caret-based selection movement (#27)

[selection-api] Fixed typo. (#24)

[selection-api] Make some arguments optional (#30)

[selection-api] Need a way to get combining character status from Range or offset (#31)

[selection-api] Need to be able to tell if the caret is displayed at the beginning or the end of the line (#32)

[selection-api] Remove "Specification" from the title (#15)

[selection-api] Should we include the default result in the beforeSelectionChange Event? (#26)

[selection-api] Specify baseNode/baseOffset/extentNode/extentOffset? (#34)

[selection-api] Specify Selection.empty() as an alias of removeAllRanges() (#36)

[selection-api] Specify Selection.modify()? (#37)

[selection-api] Specify Selection.setPosition()? (#38)

[selection-api] Specify Selection.type? (#35)

[selection-api] Specify where the caret should be placed in the markup (#28)

[selection-api] support selection.containsNode(obj, true) (#39)

[selection-api] unsigned long is never negative (#33)

[ServiceWorker] "The double square bracket notation ([[name of method or name of property]]) is used throughout the specification to indicate user agent's internal data structures." (#529)

[ServiceWorker] "The user agent may terminate service workers at any time it has no event to handle." (#527)

[ServiceWorker] `waitUntil()` for FetchEvent? (#584)

[ServiceWorker] A programmatic and reliable way to unregister all ports (even it's used from others tabs) (#579)

[ServiceWorker] A way to coordinate the refresh of all controlled windows to facilitate an upgrade (#422)

[ServiceWorker] Add an API to take over uncontrolled pages (or pages controlled by another service worker) (#586)

[ServiceWorker] Allowing multiple scopes (& should scopes be primary key?) (#566)

[ServiceWorker] Background caching (#574)

[ServiceWorker] Backpressure on fetch integrated with Streams (#452)

[ServiceWorker] Can Cache.add() committing at response resolution lead to duplicate requests? (#361)

[ServiceWorker] Can caches store and retrieve results that are still being written to the cache? (#573)

[ServiceWorker] Cancelling HTTP fetch (#592)

[ServiceWorker] consider exposing size for cache entries (#587)

[ServiceWorker] Create service worker from Blob/String URL (#578)

[ServiceWorker] Default scope to register() (#595)

[ServiceWorker] Define promise type of ServiceWorkerClient::focus() (#571)

[ServiceWorker] Drop client from fetchEvent/request? (#575)

[ServiceWorker] fetch() cache control options (#398)

[ServiceWorker] Grammatical fix (#591)

[ServiceWorker] How many workers can be registered in the same page or scope (#582)

[ServiceWorker] How many workers can be registered in the same page or scope? (#582)

[ServiceWorker] IDL nit: missing semicolon (#593)

[ServiceWorker] IDL: define ContextFrameType (#572)

[ServiceWorker] Inclusion of `referer` in preflight `Access-Control-Request-Headers` despite not being set (#596)

[ServiceWorker] Message-driven communication between workers and consumers (#580)

[ServiceWorker] Prefetching resources using SW (#570)

[ServiceWorker] Prevent opaque requests being used in response to client requests (#590)

[ServiceWorker] Privacy consideration about the "cache" parameter of the Request object (#585)

[ServiceWorker] Rename the Client interface (#350)

[ServiceWorker] Security consideration about the `cache` parameter of `Request` (#585)

[ServiceWorker] service-worker.d.ts.... (#576)

[ServiceWorker] ServiceWorker's postMessage method is not defined (#479)

[ServiceWorker] ServiceWorkerClient can't be a MessageEvent.source because it's not a WindowProxy or MessagePort (#453)

[ServiceWorker] ServiceWorkerClient to Client (#588)

[ServiceWorker] Should DedicatedWorkers select their own ServiceWorkerRegistration? (#423)

[ServiceWorker] Should skipWaiting() wait for an "in-progress request" to finish? (#569)

[ServiceWorker] skipWaiting() on an installed worker should abort Install step "Wait until no service worker client is using registration." (#594)

[ServiceWorker] Typo in explainer, code example, catch portion (#577)

[ServiceWorker] Use "client request"… (#589)

[ServiceWorker] What happens if there's an appcache manifest? (#275)

[ServiceWorker] Where to put client / context (#318)

[ServiceWorker] Why is required a page reload to enable SW controller? (#583)

[ServiceWorker] Why is required a page reload to enable SW controlling? (#583)

[ServiceWorker] window.caches and window.fetch should be [Replaceable] (#535)

[ServiceWorker] window.fetch (#581)

[streams] Add popover on branch and commit snapshots (#221)

[streams] Allow object with methods to be passed as (writeable) sink (#256)

[streams] Clarify how/whether Stream/TransformStream may read/write "messages" (#249)

[streams] Document globals created by this spec (#254)

[streams] Fix ReadableStream constructor if not getting a promise as startResult (#250)

[streams] Garbage collection (#252)

[streams] How will ReadableByteStream work with seekable resources? (#253)

[streams] Make .ready fulfill-only (#248)

[streams] Make .ready fulfill-only? (#245)

[streams] Reorganize examples (#255)

[streams] Should we "lock" readable streams while piping? (#241)

[streams] typo (#257)

[streams] WIP: exclusive reader interface (#251)

[url] "full stop code points" (#13)

[url] Add method to return delegation boundary of a URL (#39)

[url] Added inScope static (#22)

[url] address comments (#24)

[url] Address more comments (#26)

[url] any update to 3986 must meet requirements for updating IETF Standard (#27)

[url] are naming in APIs a problem IETF should solve (#31)

[url] ASCII whitespace is no longer defined (#11)

[url] Basic URL parser doesn't return anything (#10)

[url] be clearer about problem-statement draft purpose, and plan of work (#29)

[url] be explicit about change control issue (#37)

[url] clarify "parameterization" problem (#32)

[url] clarify "scheme specific definitions" problem (#34)

[url] domainToUnicode cannot be defined in terms of domainToASCII (#16)

[url] Editors' listing and status (#5)

[url] fix ID references, fix WG element, fix AREA element, remove unneeded emp... (#19)

[url] IETF examples of using "URL" rather than "URI" (#30)

[url] list more radical rewrite as a possible outcome (#35)

[url] make explicit proposal about moving URL-LS into IETF (#38)

[url] mention RFC 4395, typos, lc/uc, add comments (#21)

[url] note kinds of interop issues (#33)

[url] note possibility of implementation-dependent file: (#28)

[url] Parser seems to return strings rather than data types (#14)

[url] point to W3C bugzilla as evidence of past WHATWG/W3C work (#36)

[url] remaining comments from Larry (#23)

[url] RFC 3987 topics not included in the URL standard (#18)

[url] test URL-encoding of forms in HTML (#25)

[url] Update url-problem-statement.xml (#17)

[url] URL comparison methods (#20)

[url] What does invoke mean? (#15)

[url] What is "result"? (#5)

[url] What is authoring requirements even about? (#2)

[url] Why is Hosts not a separate section? (#9)

[url] Writing IPv4 addresses (#12)

[webcomponents] acknowledgement for semantics content (#30)

[webcomponents] added guts of custom elements semantics section (#26)

[webcomponents] change acc name advice (#31)

[webcomponents] Change pub date to 16-Dec-2014 (#28)

[webcomponents] extended examples and added developer advice section (#29)

[webcomponents] fixed code examples (#27)

[webidl] Numeric type reform strawperson (#33)

[webidl] Stringifier says it requires DOMString, but should also allow USVString (#35)

[webidl] Transferables (#34)

Last message date: Wednesday, 31 December 2014 19:29:35 UTC