public-webapps-github@w3.org from December 2015 by subject

[a11yapi] Patterns (#28)

[a11yapi] Update README.md (#26)

[directory-upload] Bikeshed: getFilesAndDirectories() (#25)

[directory-upload] easier way to determine if something is a directory? (#24)

[directory-upload] Easier way to get files without complicated asynchronous traversal code (#26)

[directory-upload] Fix typo (#23)

[directory-upload] It isn't clear whether Directory.path should include the name of the directory itself (#10)

[dom] "Element? closest(DOMString selectors);" (#133)

[dom] Add EventListenerOptions and passive event listeners (#82)

[dom] Change DOMTokenList's add() return value. (#114)

[dom] Clarify what Document constructor does? (#137)

[dom] Close #123: remove feature detection from add() and add supports() (ff4f0e8)

[dom] consider renaming "namespace" params into "namespaceURI" (#136)

[dom] Cross-browser inconsistencies with createHTMLDocument (#124)

[dom] Disconnect single target instead of all (#126)

[dom] Document.defaultCharset (#58)

[dom] Document.documentURI and Document.URL attributes behaviour (#118)

[dom] Explicitly call out descendants for getElementsByClassName https://www.w3.org/Bugs/Public/show_bug.cgi?id=27334 (dcb8ff3)

[dom] Fix #119: Merge DOMSettableTokenList into DOMTokenList (#120)

[dom] Fix a typo in the replace a node algorithm (#128)

[dom] Fix a typo in the replace algorithm (#138)

[dom] fix minor typo (#135)

[dom] Fix replace algorithm (closes #129) (#130)

[dom] Fix the set an attribute algorithm (#139)

[dom] High resolution timing for events (#23)

[dom] Let DOMTokenList.prototype.add() return false if there are no supported tokens (#111)

[dom] Node#baseURI need not be nullable (#131)

[dom] Provide getAttributeNames() which returns an Array<DOMString> (#115)

[dom] Reference the Touch Events spec (#125)

[dom] Remove feature detection from add() and add supports() (#123)

[dom] rename before() and after() of ChildNode (#134)

[dom] setAttributeNode and setAttributeNodeNS can be an aliases (#117)

[dom] Small correct for Mutation observers (#132)

[dom] Some fix for replace algo and question (#129)

[dom] Some tweaks for Nodes (#127)

[encoding] "13.2.2 iso-2022-jp encoder" (#15)

[encoding] "gb18030 ranges" have problematic definitions (#17)

[encoding] BufferSource is not specified (#24)

[encoding] Clarify result of division in algorithms (#20)

[encoding] Consider removing TextEncoder support for UTF-16 (#18)

[encoding] Fix #20: rather than relying on integer division, use floor() (929a3ff)

[encoding] GB 18030 2000 vs 2005 (#22)

[encoding] iso-2022-jp encoder XSS risks (#15)

[encoding] Serializing internal TextDecoder state? (#7)

[encoding] Treatment of U+2022 is incorrect in Shift_JIS, EUC-JP and ISO-2022-JP (#21)

[encoding] Treatment of U+2022 is suspicious in Shift_JIS, EUC-JP and ISO-2022-JP (#21)

[encoding] Unclear text in utf-8 decoder (#19)

[encoding] Use floor() more (#23)

[fetch] "Let internalResponse be response's internal res..." (#171)

[fetch] "Let preflightResponse be the result of performi..." (#174)

[fetch] Aborting a fetch (#27)

[fetch] Add "must-revalidate" to RequestCache enumeration (#165)

[fetch] Add flag to indicate delay-tolerant Request, to enable request coalescing. (#184)

[fetch] Add option to automatically abort response stream if the data stopped arriving for longer than a specified time (#180)

[fetch] Add option to reject the fetch promise automatically after a certain time elapsed (with no API for arbitrary aborts) (#179)

[fetch] Add timeout option (#20)

[fetch] added a couple missing backticks (#177)

[fetch] Difference between xhr and fetch in response headers for multipart requests (#170)

[fetch] Document usage for GET requests with URI parameters (#56)

[fetch] Fix Response body IDL (#181)

[fetch] fixed an outdated url in HTTP fetch spec (#173)

[fetch] Handling of data URLs (#111)

[fetch] Header guards (#182)

[fetch] Not clear what CSP directive is limiting iframes/imports (#166)

[fetch] OpenEndedDictionary clarification (#164)

[fetch] Public API for Headers guard (#183)

[fetch] Question about credentials mode of no-cors mode requests. (#168)

[fetch] Re-arrange some HTTP-network Fetch substeps (#176)

[fetch] Remove about:unicorn (#147)

[fetch] Replace "flags" with "booleans" (#175)

[fetch] Should `body` parameter in the Response constructor nullable? (#178)

[fetch] Should `new Headers(undefined)` throw? (#185)

[fetch] Should Headers(undefined) throw? (#185)

[fetch] specify types of streams (#167)

[fetch] Status code to use in a response indicating rejection of a cross-origin access (#172)

[fetch] typo in no-cors credentials handling (#169)

[FileAPI] Persistent blob urls (#27)

[findtext] Too many parameters/complexity? (#18)

[findtext] Usage (or not) of Promise in ``search`` (#19)

[img-conversion] License is wrong (#22)

[manifest] Allow developers to detect when the user has added the site to their home screen (or equivalent) (#417)

[manifest] Handleing capabilities with Manifoldjs (#412)

[packaging-on-the-web] ECMAScript 2015 is not Draft anymore (#27)

[permissions] Faking permissions (#54)

[permissions] Options for "double-keying" permissions (#55)

[push-api] "the URL-safe base64 encoding" is not defined (#177)

[push-api] Add authentication secret (#174)

[push-api] Adding base64 reference (#178)

[push-api] issue (#176)

[screen-orientation] Fullscreen Element Stack Not Found in Fullscreen (#88)

[selection-api] The node argument of collapse and setPosition should be nullable (#64)

[ServiceWorker] A header/something to kill SWs (#614)

[ServiceWorker] Add ServiceWorker.prototype.registration (#798)

[ServiceWorker] Allow custom cache keys for request caching (#805)

[ServiceWorker] allow self-signed certificates (#691)

[ServiceWorker] Can create caches in the persistent storage? (#803)

[ServiceWorker] Can we add some options to ClientQueryOptions? (#801)

[ServiceWorker] consider exposing size for cache entries (#587)

[ServiceWorker] Editorial: Reword normative uses of "can" (#795)

[ServiceWorker] Foreign fetch (#751)

[ServiceWorker] Have clients.claim() wait until controllers have changed before resolving (#799)

[ServiceWorker] How are non-secure context Clients observable? (#791)

[ServiceWorker] Implement API to reject PUSH_PROMISEs sent by the server over HTTP/2 (#796)

[ServiceWorker] navigations that are not intercepted should still allow interception on further redirects (#793)

[ServiceWorker] pending fetch events may be dispatched to exiting worker (#785)

[ServiceWorker] Promise on navigator.serviceWorker that resolves when page is controlled (#799)

[ServiceWorker] Race when registering multiple service workers for the same scope (#783)

[ServiceWorker] ServiceWorker scope documentation in explainer.md (#797)

[ServiceWorker] should installing workers be persisted if browser is killed? (#794)

[ServiceWorker] Should soft update algorithm be run when handling any kind of functional event? (#802)

[ServiceWorker] should update on navigation or the subsequent updatefound event be delayed until document DOM is loaded? (#788)

[ServiceWorker] should update() during top level script evaluation be ignored? (#800)

[ServiceWorker] Soft Update and Register can race when setting registration scriptURL (#789)

[ServiceWorker] The prose for Clients.matchAll() distinguishes an omitted dictionary type argument (#792)

[ServiceWorker] unregister() in service worker navigation fetch event (#804)

[ServiceWorker] WindowClient.navigate() for the same origin but off-scope clients (#752)

[ServiceWorker] Workers & SharedWorkers within ServiceWorkers (#678)

[spec-reviews] Audio Output Devices API (#91)

[spec-reviews] Credential Management API (#49)

[spec-reviews] CSP (#42)

[spec-reviews] Feedback on Keygen (#82)

[spec-reviews] HTTP 451 Status (#99)

[spec-reviews] Presentation API Request for Feedback (#61)

[spec-reviews] Promise rejection tracking events (#96)

[spec-reviews] Review FIDO spec (#97)

[spec-reviews] W3C Push API - data payloads (#98)

[spec-reviews] Web Background Sync API (#95)

[streams] .ready still active after drain? (#415)

[streams] Add spec texts for ReadableByteStreamController.close() and operations reachable from it (#416)

[streams] Byte streams tracking bug (#300)

[streams] Call ErrorReadableStream only when the state is "readable" (#419)

[streams] cancel.js test can be flaky (#413)

[streams] Consider moving stuff into ReadableStreamController (#364)

[streams] Fill the internal slots section of ReadableByteStreamController (#417)

[streams] Improved tests abour erroring a RS when enqueing (#420)

[streams] Made cancel test not timing error prone (#414)

[streams] Made SharedWorker fail if not present (#412)

[streams] Move stuff into controller to make RS and RBS closer (#418)

[streams] Port precise flow control to writable streams (#318)

[streams] Target for web-platform-tests streams API tests (#411)

[streams] type of Chunk.value (#410)

[streams] type of Chunk.value? (#409)

[touch-events] Added initTouchEvent to change list (#49)

[touch-events] Added legacy interface initTouchEvent (#47)

[touch-events] Added legacy method initTouchEvent (#47)

[touch-events] Clean up tests for @ms2ger feedback (#57)

[touch-events] createTouch has all the params as required, should probably have them optional (#58)

[touch-events] Deprecate createTouch and createTouchList? (#48)

[touch-events] Determine how best to make the tests mobile-friendly (#56)

[touch-events] Moved createTouch* to legacy section (#52)

[touch-events] New ReSpec warning about inittouchevent (#50)

[touch-events] Removed initTouchEvent from spec, added back original note (#55)

[touch-events] Removed undefined link initTouchEvent (#51)

[touch-events] rotationAngle range of 0-90 seems counterintuitive - add a diagram? (#53)

[touch-events] standardize initTouchEvent (#29)

[touch-events] Standardize initTouchEvent? (#29)

[touch-events] TouchEvent constructor is very unusual since it converts one type of object (sequence) to another type (TouchList) (#54)

[uievents-code] 'IntlHash' should be dropped from the spec (#9)

[uievents-code] Mismatch between code value, Volume(Down|Up|Mute) and key value AudioVolume(Down|Up|Mut) (#8)

[uievents-key] AudioVolume(Down|Up|Mute) shouldn't be changed from Volume(Down|UpMute)? (#14)

[uievents-key] AudioVolume(Down|Up|Mute) shouldn't be changed from Volume(Down|Up|Mute)? (#14)

[uievents-key] Is "Separator" key removed from Whitespace Keys section intentionally? (#12)

[uievents-key] Odd definition of '0' in Multimedia Numpad Keys section (#13)

[uievents-key] Typo: TVSatelliteBC -> TVSatelliteBS (#11)

[uievents] "Modifier Keys" link in KeyboardEvent.getModifierState description is a 404 (#63)

[uievents] Expose 'direction-inversion' in wheel events (#57)

[uievents] Expose 'inertial scrolling state' in wheel events (#58)

[uievents] Firing of click event after mousedown/up has two different definitions (#61)

[uievents] fixing typos (#64)

[uievents] When .getModifierState("OS") should be true? (#28)

[uievents] Whethere KeyboardEvent.location depends on .code or .key? (#62)

[webcomponents] [Custom]: Consider adding inserted/removed callback (bugzilla: 24866) (#222)

[webcomponents] [Shadow] activeElement behavior seems to break encapsulation (#358)

[webcomponents] [Shadow]: Add "closed" flag to createShadowRoot (bugzilla: 20144) (#100)

[webcomponents] [Shadow]: Need an equivalent definition of 'in a Document' for shadow trees (bugzilla: 26365) (#57)

[webcomponents] [Shadow]: rename <content> to <slot> (bugzilla: 28561) (#92)

[webcomponents] Closed flag proposal breaks ability to audit and automate tests of web pages (#354)

[webcomponents] Combining :host-context and :host (#359)

[webcomponents] Define the behavior of '::slotted' (the former name is '::content'). (#331)

[webcomponents] It is unclear how tree of tress whose root tree is not a document tree should behave. (#356)

[webcomponents] Shadow dom: use css containment feature by default (#355)

[webcomponents] Shadow dom: use css containment features by default (#355)

[webcomponents] Style attributes in Shadow DOM Cascade Order Proposal (#316)

[webcomponents] Support /deep/ in static profile (bugzilla: 28591) (#78)

[webcomponents] Support renaming, aliasing, or namespacing imported elements (#344)

[webcomponents] Unclear regarding Shadow boundary-piercing combinators (#357)

[webidl] Add a [SecureContext] operator attribute (#65)

[webidl] All supported property names should be enumerable or none of them (#82)

[webidl] Fix typo in special operations (#81)

[webidl] Legacy callback interface objects are badly defined (#78)

[webidl] Make the length attribute mandatory for interfaces that support indexed properties (#80)

[webidl] Make the length property for interfaces that support indexed properties (#80)

[webidl] Move the overload resolution algorithm into a separate section. (#77)

[webidl] Unenumerable supported property names are badly defined (#79)

[WebPlatformWG] Added name to 29 Jan WC meeting (#8)

[WebPlatformWG] Need PAG for "Web Components vs Extract Widget patent"? (#4)

[xhr] Abandon hope of removing sync XHR from the web platform? (#20)

[xhr] Consider setting omit-Origin-header-flag for same origin requests (#31)

[xhr] Don't use "JavaScript global environment" (#33)

[xhr] how to fix this ? (#36)

[xhr] https://www.facebook.com/demir.seda.52?fref=ts (#32)

[xhr] https://www.facebook.com/profile.php?id=100006069395933&fref=ts (#37)

[xhr] https://www.facebook.com/profile.php?id=100006069395933&fref=ts (#38)

[xhr] Include more PR instructions (3280fa2)

[xhr] Resture the filename argument to FormData.append(name, blob) (#25)

[xhr] Should XHR store and send HTTP header names in lower case? (#34)

[xhr] Status 0 is missing a message (#35)

[XMLHttpRequest] Github pages version? (#1)

Last message date: Thursday, 31 December 2015 22:34:03 UTC