public-webapps-bugzilla@w3.org from November 2013 by subject

[Bug 12837] Define unloading document cleanup steps

[Bug 13912] What order are attributes in?

[Bug 14949] [Meta]: Component Model needs an Explainer document

[Bug 14968] [Meta]: Specify how custom elements work

[Bug 14978] [Meta]: Specify how shadow DOM works

[Bug 15418] sort out HTTP auth

[Bug 15476] [Templates]: Specify how templates work

[Bug 16312] use of undocumented 'switch' convention for rule formulation is ambiguous

[Bug 18242] Not clear what "script that invoked the method" means exactly in the case of e.g. a.setTimeout(b.postMessage, 0) // called from c

[Bug 18938] The Status of this Document section should reference http://html5.org/specs/dom-parsing.html and explain the relationship between the two documents

[Bug 20257] IDBCursor should walk on secondary ordering of index value

[Bug 20322] Document the force preflight flag

[Bug 20567] Change [[Prototype]] for concept-node-adopt?

[Bug 20976] Define Node.baseURI properly

[Bug 21083] Proposal key names for Android

[Bug 21114] Dead key names are not enough for Linux

[Bug 21134] Define key names which launches specific application

[Bug 21140] Define key names for keyboard layout change keys

[Bug 21264] referrer source is wrong

[Bug 21650] Require that XHR is available in workers

[Bug 21740] Guidance on DOMError and promises

[Bug 21830] KeyboardEvent.locale is too general.

[Bug 22028] Consider adding hasComposition() in InputMethodContext

[Bug 22059] Composition dictionary should be changed

[Bug 22093] Consider adding candidatewindowshow/update/hide events and getCandidateWindowClientRect()

[Bug 22254] [Shadow]: WebIDL code blocks are missing an "idl" classname

[Bug 22268] [Shadow]: Consider a <content> selector for "nodes not otherwise distributed"

[Bug 22344] [Shadow]: Distribute into <shadow>, project into older shadow root

[Bug 22646] So if we want to say on a per-object basis whether it ought to be exposed to workers (which I think is useful) lets introduce "exposed to document environments", "exposed to worker environments", and [...]

[Bug 22715] [Shadow]: [Meta] New features and improvements

[Bug 22716] [Shadow]: [Meta] Cleanup, refactoring, and polish

[Bug 23202] Add @@unscopeables sugar

[Bug 23204] Add option for orientation

[Bug 23234] Mark document response entity body as HTML document

[Bug 23240] Normatively specify that right/middle mouse button presses do not cause click/dblclick events

[Bug 23250] No way with mutation observers to watch mutations to an element's parent

[Bug 23256] [Custom]: Coordinate with SVG WG and Math WG about dashed element names

[Bug 23310] bugs in WebIDL fragments

[Bug 23346] Use TypeError for argument validation

[Bug 23358] A hook for objects that can enter a "dead" mode

[Bug 23363] requestFullscreen and dialog.showModal interaction

[Bug 23367] Move exceptions into IDL

[Bug 23416] Introduce new concept of neutered

[Bug 23431] File API should say what to do with the query string in blob: URLs

[Bug 23450] Add Specification Note Describing "Save As" Behavior for File Objects

[Bug 23564] IDL for open() doesn't match implementation reality

[Bug 23575] The paragraph about patent policy is duplicated.

[Bug 23601] Define a variable to replace "with prejudice"

[Bug 23623] Support [Clamp] for sequences

[Bug 23625] [Shadow]: Consider removing apply-author-styles flag

[Bug 23669] [Custom]: "leftView" type of callbacks should not be called on "this document has a browsing context"

[Bug 23682] Fix the current [ArrayClass], [] and sequence<T> mess

[Bug 23683] Investigate restricting sequence<T> to iterables

[Bug 23691] Drop nextElementSibling from DocumentType

[Bug 23694] Should element.getElementById() consider the element itself when searching

[Bug 23697] KeyboardEventInit in UI Events doesn't include keyCode/charCode/which but in D3E, it includes them

[Bug 23697] New: KeyboardEventInit in UI Events doesn't include keyCode/charCode/which but in D3E, it includes them

[Bug 23698] New: Rename ParentNode to ContainerNode or some other unambiguous name

[Bug 23698] Rename ParentNode to ContainerNode or some other unambiguous name

[Bug 23701] New: Remove TreatUndefinedAs

[Bug 23701] Remove TreatUndefinedAs

[Bug 23704] New: Define username/password better

[Bug 23705] MutationObserver observe option validation does not match implementations

[Bug 23705] New: MutationObserver observe option validation does not match implementations

[Bug 23707] New: Use a switch for the checks on children of a document

[Bug 23707] Use a switch for the checks on children of a document

[Bug 23712] DOMTokenList needs a way to conditionally set or remove

[Bug 23712] New: DOMTokenList needs a way to conditionally set or remove

[Bug 23718] New: Stream interface should be decoupled into WritableStream and ReadableStream

[Bug 23718] Stream interface should be decoupled into WritableStream and ReadableStream

[Bug 23719] Consider adding pull style flow control method to Stream

[Bug 23719] New: Consider adding pull style flow control method to Stream

[Bug 23720] Make it able to issue multiple write()s on a Stream without waiting for completion

[Bug 23720] New: Make it able to issue multiple write()s on a Stream without waiting for completion

[Bug 23724] Merge skip() method into read() by adding "none" type to StreamReadType

[Bug 23724] New: Merge skip() method into read() by adding "none" type to StreamReadType

[Bug 23725] Consider strongly-defined createStream to add generic stream support for APIs

[Bug 23725] New: Consider strongly-defined createStream to add generic stream support for APIs

[Bug 23726] Integration between XMLHttpRequest and Streams API

[Bug 23726] New: Integration between XMLHttpRequest and Streams API

[Bug 23731] New: [Streams API] Should readEncoding be merged into readType?

[Bug 23731] Should readEncoding be merged into readType?

[Bug 23732] Consider adding best-effort scatter/gather mode

[Bug 23732] New: [Streams API] Consider adding best-effort scatter/gather mode

[Bug 23735] [Streams API] Failure signaling to object URL created from Stream

[Bug 23735] Failure signaling to object URL created from Stream

[Bug 23735] New: [Streams API] Failure signaling to object URL created from Stream

[Bug 23736] [Streams API] Add fork() method instead of having pipe(Stream[]) overload

[Bug 23736] Add fork() method instead of having pipe(Stream[]) overload

[Bug 23736] New: [Streams API] Add fork() method instead of having pipe(Stream[]) overload

[Bug 23743] New: Divide "arraybuffer" StreamReadType into "arraybuffer/exact" and "arraybuffer"

[Bug 23743] Split the functionality to read exact N bytes into readExact() method

[Bug 23746] New: Typo: Mediamedia Keys should be Multimedia Keys

[Bug 23746] Typo: Mediamedia Keys should be Multimedia Keys

[Bug 23747] New: ZoomToggle key is a "Media Controller Keys"?

[Bug 23747] ZoomToggle key is a "Media Controller Keys"?

[Bug 23748] New: Shouldn't getModifierState() definition refer Modifiers Keys which are defined in .key value?

[Bug 23748] Shouldn't getModifierState() definition refer Modifiers Keys which are defined in .key value?

[Bug 23749] Keypad's Add, Subtract, Multiply, Divide, Equals and Decimal are not defined in the latest ED

[Bug 23749] New: Keypad's Add, Subtract, Multiply, Divide, Equals and Decimal are not defined in the latest ED

[Bug 23750] New: ScrollLock key should be defined in 6.3.2 Modifier Keys

[Bug 23750] ScrollLock key should be defined in 6.3.2 Modifier Keys

[Bug 23751] "Select" key is not defined in the latest ED

[Bug 23751] New: "Select" key is not defined in the latest ED

[Bug 23752] New: [Templates]:

[Bug 23763] New: Separate MIME type from Stream or not

[Bug 23763] Separate MIME type from Stream or not

[Bug 23766] Define new key name "VideoModePrevious"

[Bug 23766] New: Define new key name "VideoModePrevious"

[Bug 23767] [Shadow]: Empty shadow insertion point should behave like <shadow><content leftover></content></shadow>

[Bug 23767] New: [Shadow]: Empty shadow insertion point should behave like <shadow><content leftover></content></shadow>

[Bug 23768] [Shadow]: Consider using respec.js

[Bug 23768] New: [Shadow]: Consider using respec.js

[Bug 23769] [Shadow]: Event retargeting algorithm should consider the case of multiple shadow roots.

[Bug 23769] New: [Shadow]: Event retargeting algorithm should consider the case of multiple shadow roots.

[Bug 23770] [Shadow]: A shadow tree of a younger shadow root should be a child tree of a shadow tree of the older shadow root in tree of trees.

[Bug 23770] New: [Shadow]: A shadow tree of a younger shadow root should be a child tree of the older shadow root in tree of trees.

[Bug 23771] "TreatUndefinedAs=Null" seems pointless

[Bug 23771] New: "TreatUndefinedAs=Null" seems pointless

[Bug 23772] Just return read result when there's data synchronously readable

[Bug 23772] New: Just return read result when there's data synchronously readable

[Bug 23778] [Custom]: Avoid difference in "created" callback ordering in parsing vs. cloning

[Bug 23778] New: [Custom]: Avoid difference in "created" callback ordering in parsing vs. cloning

[Bug 23780] Check XMLHttpRequest and Notification don't break given the new script settings object stuff

[Bug 23781] id and class should be case-insensitive in quirks

[Bug 23781] New: id and class should be case-insensitive in quirks

[Bug 23787] Clarify that which HTTP entity body is referred in ProgressEvent spec

[Bug 23787] New: Clarify that which HTTP entity body is referred in ProgressEvent spec

[Bug 23789] [Shadow]: Migrate WebIDL definitions to the format supported by ReSpec.

[Bug 23789] New: [Shadow]: Migrate WebIDL definitions to the format supported by ReSpec.

[Bug 23790] New: Remove size argument from read() and introduce pullAmount attribute instead

[Bug 23790] Remove size argument from read() and introduce pullAmount attribute instead

[Bug 23792] Event dispatching algorithm doesn't support the load event fired at window

[Bug 23792] New: Event dispatching algorithm doesn't support the load event fired at window

[Bug 23793] "For each element e in elementSet, append the el..."

[Bug 23793] New: "For each element e in elementSet, append the el..."

[Bug 23797] [Shadow]: Make ReSpec handle all local definitions and linking.

[Bug 23797] [Shadow]: Make ReSpec handle all local definitions and linkings.

[Bug 23797] New: [Shadow]: Make ReSpec handle all local definitions and linkings.

[Bug 23798] [Shadow]: Use the feature of 'References' supported by ReSpec and remove Dependencies section

[Bug 23798] New: [Shadow]: Use the feature of 'References' supported by ReSpec and remove Dependencies section

[Bug 23799] New: [Streams API] Feature req: in-band control signal

[Bug 23800] [Shadow]: Needs a similar tool to ReSpec, but which resolves 'Definitions and Linking' for external definitions.

[Bug 23800] [Shadow]: Needs a similar tool to ReSpec, which resolves 'Definitions and Linking' for external definitions.

[Bug 23800] New: [Shadow]: Needs a similar tool to ReSpec, but which resolves 'Definitions and Linking' for external definitions.

[Bug 23808] [Custom]: Should be able to instantiate any custom element from just its name

[Bug 23808] New: [Custom]: Should be able to instantiate any custom element from just its name

[Bug 23809] [Custom]: Ability to look up information about custom elements which have been registered

[Bug 23809] New: [Custom]: Ability to look up information about custom elements which have been registered

[Bug 23810] New: When adopting, "If node is an element, it is affected by a base..."

[Bug 23810] When adopting, "If node is an element, it is affected by a base..."

[Bug 23811] "To fire an event named e means that an event using" which event?

[Bug 23811] New: "To fire an event named e means that an event using" which event?

[Bug 23813] [Shadow]: Use the 'autolink' feature and get rid of hardcoded links to external definitions.

[Bug 23813] New: [Shadow]: Use the 'autolink' feature and get rid of hardcoded links to external definitions.

[Bug 23814] New: [Explainer]: Scoped evaluation of Script tag for custom elements and decorator events

[Bug 23829] New: Split current draft into 2 specs

[Bug 23829] Split current draft into 2 specs

[Bug 23830] New: Move attributes of Composition interface to CompositionEvent

[Bug 23834] New: Use @@unscopeables sugar for remove() et al

[Bug 23835] [Shadow]: Make the spec pass the validation of https://github.com/mozilla/html5-lint.

[Bug 23835] New: [Shadow]: Make the spec pass the validation of https://github.com/mozilla/html5-lint.

[Bug 23839] [Custom]: Template document should not share registry with its document

[Bug 23839] New: [Custom]: Template document should not share registry with its document

[Bug 23853] New: Please clarify the interpretation of the WebIDL undefined Date in the File constructor

[Bug 23853] Please clarify the interpretation of the WebIDL undefined Date in the File constructor

[Bug 23860] New: Remove getElementById() from Element

[Bug 23860] Remove getElementById() from Element

[Bug 23861] New: [Shadow] The "Events that are Always Stopped" list looks rather random

[Bug 23863] New: [Shadow] ORIGINAL-TARGET is not defined anywhere

[Bug 23864] New: [Shadow] "TouchEvent is not subject to this rule." in 6.7 doesn't make sense

[Bug 23878] figure out termination of requests when documents become inactive

[Bug 23878] New: figure out termination of requests when documents become inactive

[Bug 23879] example of distinguishability is wrong

[Bug 23879] New: "Consider the effective overload set shown in th..."

[Bug 23886] Needs to define key value when dead key is pressed twice

[Bug 23886] New: Needs to define key value when dead key is pressed twice

[Bug 23887] [Shadow] Put only the final destination insertion point to the event path

[Bug 23887] New: [Shadow] Put only the final destination insertion point to the event path

[Bug 23900] New: WebRTC DataChannels are not called out as producers/consumers

[Bug 23900] WebRTC DataChannels are not called out as producers/consumers

[Bug 23905] New: "6.1.2 Keyboard Layout" uses old key names "Left", "Right", "Down" and "Up"

[Bug 23906] [proposal] Add (Mouse|Keyboard)Event.accelKey

[Bug 23906] New: [proposal] Add (Mouse|Keyboard)Event.accelKey

[Bug 23907] New: How do web apps distinguish if a keydown event causes text input?

[Bug 23908] New: What's the good key value of printable keys with Meta key (Command key) on Mac?

[Bug 23909] New: Which is expected whether keydown event is fired before or after native IME handles it

[Bug 23910] New: What's the good .key value while IME is open?

[Bug 23911] New: [Proposal] Add KeyboardEvent.isComposing attribute

[Bug 23912] New: "3.3 Synchronous and asynchronous events" use 'Del' which is older key name

[Bug 23913] beforeinput should be fired only when the DOM change is caused by direct input by keypress or composition

[Bug 23913] New: beforeinput should be fired only when the DOM change is caused by direct input by keypress or composition

[Bug 23915] New: DOMTokenList "tokens" never updated

[Bug 23936] New: [LC Comment] Source reference to DOM L2 Core

[Bug 23943] New: It's too difficult to search the code which access KeyboardEvent.key

[Bug 23946] New: Lift the ban on query parts in “blob:” URIs

Last message date: Saturday, 30 November 2013 22:08:56 UTC