public-webapps-github@w3.org from January 2015 by subject

[editing-explainer] Add "intention" integration point to 'beforeinput' event's interface (#42)

[editing-explainer] added some comments to point out intents from components (#15)

[editing-explainer] beforeinput should be fired only when the DOM change is caused by direct input by keypress or composition (#43)

[editing-explainer] D3E defines input event should be fired immediately after the DOM as been updated but it shouldn't be so if the editor value is changed by setting value attribute (#41)

[editing-explainer] Document "unsafe to dispatch events" in D3E if it's possible (#44)

[editing-explainer] Fix URL of ContentEditable spec. (#45)

[editing-explainer] How can sites access browser spellchecking? (#36)

[editing-explainer] How do we feature detect Responsive Input Events? (#32)

[editing-explainer] how does cE=typing handle autocorrect and spelling suggestions? (#37)

[editing-explainer] How does cE=typing support IME text replacement? (#34)

[editing-explainer] Links should use <a> tag and not MD syntax (#40)

[editing-explainer] Need to spec the data in beforeInput event (#29)

[editing-explainer] Prevent recursive beforeInput calls (#44)

[editing-explainer] removed the protocol to link to respec (#38)

[editing-explainer] Should beforeInput Event happen if there is no selection? (#26)

[editing-explainer] Should Device-Specific Input Events say what Responsive Input Event they will cause? (#25)

[editing-explainer] Should execCommand be spec'd to do nothing in cE=typing? (#33)

[editing-explainer] Should sites be able to control Responsive Input Language? (#31)

[editing-explainer] Should the term be Device Independent Events? (#7)

[editing-explainer] Target range in device independent events (#39)

[editing-explainer] What should be the term for "Intentions" (#7)

[manifest] [Meta] Test suite (#210)

[manifest] [meta] transition doc. to CR at W3C (#308)

[manifest] Allow multiple application contexts per app (#294)

[manifest] Allow name to be a String or Language Map (#211)

[manifest] check against security/privacy questions (#305)

[manifest] Clarified opening deep link (closes #301) (#302)

[manifest] Clarify display-mode relationship to iframes and legacy content (#309)

[manifest] Clarify launching from a deep link. (#301)

[manifest] Conditional system for handling future extensions (#168)

[manifest] Consider making display a space-separated list of tokens (#304)

[manifest] Define identity of a web app (closes #272) (#297)

[manifest] Define identity of a web app (closes #272) (#299)

[manifest] Define identity of a web app (closes #272) (a2e8c31)

[manifest] Define identity of a web app. (#272)

[manifest] density doesn't make a lot of sense for SVG (#279)

[manifest] Editorial cleanup (#300)

[manifest] Enhanced privacy/security considerations (closes #305) (#306)

[manifest] Enhanced privacy/security considerations (closes #305) (63f8448)

[manifest] Explained how density relates to SVG (closes #279) (#298)

[manifest] Explained how density relates to SVG (closes #279) (c4fa442)

[manifest] Include languages into manifest (#208)

[manifest] Integration with service workers (#161)

[manifest] Link space / "deep linking" (#288)

[manifest] Preparing for CR (#307)

[manifest] Redefined identity to make it os centric (closes #272) (#303)

[manifest] shortcuts to content vs shortcut to app (#167)

[manifest] Use input / output model for algos (#227)

[packaged-webapps] Remove x180E (#3)

[packaged-webapps] x180E no longer a Unicode whitespace (#2)

[packaging-on-the-web] "scope" attribute (#9)

[packaging-on-the-web] Add example showing Streamable Package Format for packaged web app (#8)

[packaging-on-the-web] Clarify zip streaming discussion. Fixes #14. (#15)

[packaging-on-the-web] fixing typo (#20)

[packaging-on-the-web] Is it safe to deploy over plain-text HTTP? (#19)

[packaging-on-the-web] Need to clarify how this relates to HTTP2 (#1)

[packaging-on-the-web] Populating Caches (#10)

[packaging-on-the-web] Security use cases for packaging (#21)

[packaging-on-the-web] Streaming Packaging Format (#12)

[packaging-on-the-web] Use new archive/ top-level media type? (#13)

[packaging-on-the-web] Vary header use (#16)

[packaging-on-the-web] When is the SPF stream finished? Is Content-Length enough? (#18)

[packaging-on-the-web] Why not use `Content-Encoding`? (#17)

[packaging-on-the-web] Zip CAN be streaming (#14)

[push-api] .getRegistration() should not reject if there is no registration (but return a null object) (#96)

[push-api] Better description of pushsubscriptionchange, with more likely reason. (#110)

[push-api] Consider exposing meta-information on push message (#81)

[push-api] Consider renaming pushregistrationlost (#82)

[push-api] Define PermissionDeniedError. (#106)

[push-api] Discovering relevant service timers (#111)

[push-api] endpoint should be of type URL not DOMString (#93)

[push-api] events should be part of PushSubscription (#104)

[push-api] Figure out why tidy produces inconsistent formatting (#39)

[push-api] Link to definition of secure origin instead of mentioning https only (#79)

[push-api] Mention what to do in register() and getRegistration() if there is no active SW (#100)

[push-api] Multiple registrations per origin/SW (#71)

[push-api] Permission checks in the push API (#75)

[push-api] Push API should be allowed without dependency on service worker (#84)

[push-api] Push API should support SW event.waitUntil (#85)

[push-api] Push subscription should require active Service Worker (#92)

[push-api] Push-api / HTML5-Notification Permissions (#3)

[push-api] PushRegisterMessage => PushError (#18)

[push-api] PushRegistration should have an attribute for ExpirationTime (#86)

[push-api] pushregistrationlost use case (#74)

[push-api] PushSubscription should have an attribute for ExpirationTime (#86)

[push-api] pushsubscriptionchange (was pushregistrationlost) use case (#74)

[push-api] Refer to reusable definition of PermissionDeniedError once that becomes available (#107)

[push-api] Remove PushManager#hasPermission in favor of Permissions API (#109)

[push-api] Rename (un)register to (un)subscribe (#98)

[push-api] Rename pushsubscriptionlost to pushsubscriptionchange. (#105)

[push-api] Rename registration to subscription to align with Web Push protocol. (#102)

[push-api] Require an active service worker for subscribe and getSubscription. (#108)

[push-api] Require an active service worker for subscribe. (#108)

[push-api] Resolve with null if not registered. (#101)

[push-api] See if dfn.js can help (#40)

[push-api] Should push registration wait for Service Worker activation? (#38)

[push-api] Technique to Detect Endpoint Prior to register() (#95)

[push-api] The endpoint is of type USVString. (#103)

[selection-api] Add APIs to save/restore selection (#43)

[selection-api] Add APIs to save/restore selectiona (#42)

[selection-api] caret-based selection movement (#27)

[selection-api] Need a way to get BiDi dir from Range (#21)

[selection-api] Need a way to get combining character status from Range or offset (#31)

[selection-api] Support multi range selection (#41)

[selection-api] support selection.containsNode(obj, true) (#39)

[selection-api] Why does getRangeAt must return a reference to (not a copy of) the range? (#40)

[ServiceWorker] [[register]] entry settings object's API (#336)

[ServiceWorker] [Exposed] annotations on InstallEvent an ServiceWorker make no sense (#395)

[ServiceWorker] Add an API to take over uncontrolled pages (or pages controlled by another service worker) (#586)

[ServiceWorker] Backpressure on fetch integrated with Streams (#452)

[ServiceWorker] Batch adding to a cache should fail if one request in the batch overwrites another (#379)

[ServiceWorker] Cache object grammar (#494)

[ServiceWorker] caches.create should return existing cache if it already exists (#458)

[ServiceWorker] Can caches store and retrieve results that are still being written to the cache? (#573)

[ServiceWorker] Can we change the body attribute of Request/Response to a method? (#606)

[ServiceWorker] Can we replace event.default() with something less magic? (#607)

[ServiceWorker] Cancelling HTTP fetch (#592)

[ServiceWorker] Changing ServiceWorkerClient.hidden to visibilityState (#498)

[ServiceWorker] Clarify if Cache put()/add()/addAll() should mark Request body used (#550)

[ServiceWorker] clarify ServiceWorkerGlobalScope.caches is per-origin (#415)

[ServiceWorker] Client versus resource for workers, frames, etc. (#345)

[ServiceWorker] Clients & postMessage (#609)

[ServiceWorker] consider exposing size for cache entries (#587)

[ServiceWorker] Default scope to register() (#595)

[ServiceWorker] Do not want ServiceWorker to interrupt a specific request (#598)

[ServiceWorker] Errors inside Promises are not thrown (#600)

[ServiceWorker] Expose ServiceWorkerRegistration within ServiceWorkerGlobalScope (#421)

[ServiceWorker] FetchEvent.respondWith() should check the used flag of the response (#567)

[ServiceWorker] Hints in beforeevicted to let the SW of a web app pick among several house cleaning options? (#611)

[ServiceWorker] IDL: define ContextFrameType (#572)

[ServiceWorker] Inclusion of `referer` in preflight `Access-Control-Request-Headers` despite not being set (#596)

[ServiceWorker] installing/waiting/activating state transition event and state lead to confusion. (#539)

[ServiceWorker] Is the ServiceWorker also a client? (#603)

[ServiceWorker] loaction.reload(true) should reload without ServiceWorker (#597)

[ServiceWorker] location.reload(true) should reload without ServiceWorker (#597)

[ServiceWorker] Make ExtendableEvent#waitUntil generic (#554)

[ServiceWorker] Make it clear that Cache and caches are to be available on page (#297)

[ServiceWorker] Merge service worker client into "environment settings object" (#516)

[ServiceWorker] Move installEvent.replace() onto ServiceWorkerClients (#518)

[ServiceWorker] Multi-author sites (#468)

[ServiceWorker] Need a linkable section for "start up a service worker if it is not running" (#501)

[ServiceWorker] Need for linkable and reusable section that defines the https restriction (#601)

[ServiceWorker] new ServiceWorkerClient makes no sense? (#511)

[ServiceWorker] Possible ambiguity with "run these steps asynchronously" (#403)

[ServiceWorker] Privacy consideration about the "cache" parameter of the Request object (#585)

[ServiceWorker] Promises inside Service workers don't throw errors (#600)

[ServiceWorker] Remove registration from Client? (#608)

[ServiceWorker] Rename clients.getAll() (#610)

[ServiceWorker] Rename InstallPhaseEvent to ExtendableEvent (#448)

[ServiceWorker] Resolving null & using WindowClient (8e7dfc9)

[ServiceWorker] Service-Worker-Allowed header (#604)

[ServiceWorker] ServiceWorker objects and workers (#528)

[ServiceWorker] ServiceWorkerClient can't be a MessageEvent.source because it's not a WindowProxy or MessagePort (#453)

[ServiceWorker] ServiceWorkerClient to Client (#588)

[ServiceWorker] ServiceWorkerClientQueryParams includeUncontrolled and algorithm are at odds (#428)

[ServiceWorker] ServiceWorkerClients.getAll should be sorted by recency (#499)

[ServiceWorker] ServiceWorkerGlobalScope needs Exposed=ServiceWorker or Exposed=Worker or something (#391)

[ServiceWorker] Should an IFRAME without src be controlled by SW when its parent is controlled? (#612)

[ServiceWorker] Should DedicatedWorkers select their own ServiceWorkerRegistration? (#423)

[ServiceWorker] Spec for openWindow(). Part of #603. (6fd0399)

[ServiceWorker] Specify .focus() and .openWindow() behaviour (#602)

[ServiceWorker] Timing of events relative to initial script load (#605)

[ServiceWorker] unregister() then register() same-scope, different script URL that fails: what do you expect to happen? (#396)

[ServiceWorker] What's the interaction with referrer policy (#404)

[ServiceWorker] window.fetch (#581)

[ServiceWorker] WindowClient.focus() resolves with updated WindowClient. (#599)

[spec-reviews] Beacon (#23)

[spec-reviews] Browser Fingerprinting Document (#38)

[spec-reviews] CSP (#42)

[spec-reviews] CSS Font Loading (#20)

[spec-reviews] CSS Regions (#35)

[spec-reviews] CSS Variables (#41)

[spec-reviews] Custom Elements (#16)

[spec-reviews] http-problem (#37)

[spec-reviews] JSON Form Submission (#40)

[spec-reviews] Manifest spec (#30)

[spec-reviews] multipart/form-data (#34)

[spec-reviews] Navigation Error Logging (#24)

[spec-reviews] Navigation Timing 2 (#18)

[spec-reviews] Subresource Integrity (#43)

[spec-reviews] Update Web Animations.md (#39)

[spec-reviews] Wake lock (#32)

[spec-reviews] Web NFC API (#22)

[spec-reviews] WebAppSec reviews (#36)

[spec-reviews] WebRTC (#14)

[spec-reviews] WebRTC Identity Provider Selection (#28)

[streams] [Reader] Should resolve readyPromise on getReader() call? (#258)

[streams] Add a test showing that waiting → waiting is completely fixed (d29eafa)

[streams] Add ability to exclusively lock a readable stream (63372f5)

[streams] Add IsReadableStreamLocked abstract operation (#259)

[streams] Add missing methods to the ReadableByteStream class definition (#273)

[streams] Add read() method to ReadableByteStream (#214)

[streams] Add way to get URL of current spec commit snapshot (#223)

[streams] Add, re-do, and reorganize a bunch of examples (#270)

[streams] Allow object with methods to be passed as (writeable) sink (#256)

[streams] Clarify how/whether Stream/TransformStream may read/write "messages" (#249)

[streams] Convert readable stream pull() to promise-returning (#272)

[streams] Define "tee"ing a stream (#271)

[streams] Document globals created by this spec (#254)

[streams] Factor out portions of a test suite that can be run against already-constructed streams (#264)

[streams] First class source sink objects (#265)

[streams] Fixed cancel test on errored stream (#274)

[streams] Garbage collection (#252)

[streams] How will ReadableByteStream work with seekable resources? (#253)

[streams] Is Node's "unshift" necessary? (#3)

[streams] Make reader.closed return the result of racing closedPromise and lockRel... (#267)

[streams] Make released stream readers look like closed streams (e119976)

[streams] Make stream readers look closed when released (#260)

[streams] Make the promise returned by rs.ready consult rs.ready again on resoluti... (#268)

[streams] Promises based transform() (#185)

[streams] Reader fixups (#262)

[streams] ready fulfilling when state ends up being "waiting" due to reading in the same turn (#263)

[streams] Rename [[reader]] internal slot to [[readableStreamReader]] (3e5e0fc)

[streams] Reorganize examples (#255)

[streams] Replace { input, output } with { writable, readable } (35c68a4)

[streams] Requirement on promises equality (#266)

[streams] Should delegate functions of underlying sink/source return promises or call given functions (#130)

[streams] Should readable streams start right away? (#269)

[streams] Should we "lock" readable streams while piping? (#241)

[streams] Some minor refinements plus thought process (33c2985)

[streams] Spec brand checks (#261)

[url] Add a "relativizer" function to the API (#41)

[url] Adding Ruby 'uri' standard library to tested implementations (#45)

[url] Cannot find module 'pegjs' (#40)

[url] Import Node.js tests (#42)

[url] Old python URI parser from SWAP (#43)

[url] rdflib.js has a URI parser and relativizer (#44)

[url] Update csharp test to identify .net fwk version (#46)

[url] URL comparison methods (#20)

[webcomponents] [Shadow DOM] Add Attributes section (#32)

[webcomponents] change acc name advice (#31)

[webcomponents] inflexible extends as fixed element type (#33)

[webcomponents] Is there going to be a Chinese version? (#34)

[webcomponents] updated after feedback (c8db797)

[webidl] Fix a typo in editorial note for @@toStringTag (#39)

[webidl] Fix DOMException-related nits. (#36)

[webidl] Fix https://www.w3.org/Bugs/Public/show_bug.cgi?id=23133 (#37)

[webidl] Followup for bug https://www.w3.org/Bugs/Public/show_bug.cgi?id=23133 to to deal with inherited interfaces that are [NoInterfaceObject]. (#38)

[webidl] Make the DOMException constructor accept a name (#22)

[webidl] MapClass should not put Map.prototype in the prototype chain (#11)

[webidl] Only use the named properties object as [[Prototype]] if it exists. (#40)

[webidl] Remove a duplicate word. (#41)

[webidl] Stringifier says it requires DOMString, but should also allow USVString (#35)

Last message date: Saturday, 31 January 2015 09:49:54 UTC