public-webapps-bugzilla@w3.org from December 2013 by subject

[Bug 14968] [Meta]: Specify how custom elements work

[Bug 14978] [Meta]: Specify how shadow DOM works

[Bug 20683] [Imports]: Write HTML Imports spec

[Bug 22028] Consider adding hasComposition() in InputMethodContext

[Bug 22059] Composition dictionary should be changed

[Bug 22073] 'Meta' key is the same as the 'OS' or 'Win' key

[Bug 22093] Consider adding candidatewindowshow/update/hide events and getCandidateWindowClientRect()

[Bug 22522] WebIDL, error handling, and promises

[Bug 22716] [Shadow]: [Meta] Cleanup, refactoring, and polish

[Bug 23167] Define key name for TV

[Bug 23186] EventListener argument of addEventListener and removeEventListener should not be nullable

[Bug 23257] Review Dead Key Examples and Composition Event use in light of recent changes

[Bug 23258] Consider composition event order relative to IME API info when choosing to update DOM after compositionupdate...

[Bug 23367] Move exceptions into IDL

[Bug 23565] cloneNode IDL does not match reality

[Bug 23718] Stream interface should be decoupled into WritableStream and ReadableStream

[Bug 23720] Make it able to issue multiple write()s on a Stream without waiting for completion

[Bug 23724] Merge skip() method into read() by adding "none" type to StreamReadType

[Bug 23732] Consider adding best-effort scatter/gather mode

[Bug 23743] Split the functionality to read exact N bytes into readExact() method

[Bug 23748] Shouldn't getModifierState() definition refer Modifiers Keys which are defined in .key value?

[Bug 23750] ScrollLock key should be defined in 6.3.2 Modifier Keys

[Bug 23751] "Select" key is not defined in the latest ED

[Bug 23772] Just return read result when there's data synchronously readable

[Bug 23790] Remove size argument from read() and introduce pullAmount attribute instead

[Bug 23829] Split current draft into 2 specs

[Bug 23853] Please clarify the interpretation of the WebIDL undefined Date in the File constructor

[Bug 23863] [Shadow] ORIGINAL-TARGET is not defined anywhere

[Bug 23886] Needs to define key value when dead key is pressed twice

[Bug 23887] [Shadow] Put only the final destination insertion point to the event path

[Bug 23905] "6.1.2 Keyboard Layout" uses old key names "Left", "Right", "Down" and "Up"

[Bug 23906] [proposal] Add (Mouse|Keyboard)Event.accelKey

[Bug 23907] How do web apps distinguish if a keydown event causes text input?

[Bug 23908] What's the good key value of printable keys with Meta key (Command key) on Mac?

[Bug 23909] Which is expected whether keydown event is fired before or after native IME handles it

[Bug 23912] "3.3 Synchronous and asynchronous events" use 'Del' which is older key name

[Bug 23913] beforeinput should be fired only when the DOM change is caused by direct input by keypress or composition

[Bug 23946] Lift the ban on query parts in “blob:” URIs

[Bug 23973] New: [Streams API] Introduce in-band error signaling

[Bug 23974] New: [Streams API] Don't inherit object URL feature

[Bug 23975] New: [Streams API] Remove read as Blob support

[Bug 23977] New: [Streams API] Generic object stream

[Bug 23999] "Either when an element is created that has a cl..."

[Bug 23999] New: "Either when an element is created that has a cl..."

[Bug 24000] DOMException should extend ES Error

[Bug 24000] New: DOMException should extend ES Error

[Bug 24002] New: [imports]: import attribute on the LinkImport interface should be |Document?| instead of |Document|

[Bug 24003] New: [Imports]: Element removed flag's behavior is not clear if multiple HTMLLinkElement refers to the same import

[Bug 24008] New: [Streams API] Partially decreasing numBytesBeingReturned without calling next read()

[Bug 24009] New: [Shadow]: RELATED-PATH is not defined in "related target resolution algorithm"

[Bug 24010] New: [Shadow]: What if there is no common ancestor?

[Bug 24011] New: [Shadow]: Typos

[Bug 24012] New: [Shadow]: lowest common inclusive ancestor tree needs to include shadow trees?

[Bug 24018] [Custom]: No way to pass parameters to constructor

[Bug 24018] New: [Custom]: No way to pass parameters to constructor

[Bug 24019] [Custom]: No way to associate class/constructor function

[Bug 24019] New: [Custom]: No way to associate class/constructor function

[Bug 24020] [Custom]: A tag name should be associated with the constructor and not the prototype

[Bug 24020] New: [Custom]: A tag name should be associated with the constructor and not the prototype

[Bug 24021] [Streams API] Fix process pendingWriteQueue alrogithm

[Bug 24021] New: [Streams API] Fix process pendingWriteQueue alrogithm

[Bug 24022] New: [Streams API] Lazily encode write()-en DOMString

[Bug 24023] [Streams API] Returned promise of write() should be fulfilled with current available space size rather than how many bytes were written

[Bug 24023] New: [Streams API] Returned promise of write() should be fulfilled with current available space size rather than how many bytes were written

[Bug 24028] Element.matches("!invalid!") should throw SyntaxError, not TypeError

[Bug 24028] New: Element.matches("!invalid!") should throw SyntaxError, not TypeError

[Bug 24042] [imports]: Parser should not wait on external resources inside imports

[Bug 24042] New: [imports]: Parser should not wait on external resources inside imports

[Bug 24043] [Custom]: Need to check writable too.

[Bug 24043] New: [Custom]: Need to check writable too.

[Bug 24044] How do browsers decide combining character from non-combining character at computing .key value of dead key?

[Bug 24044] New: How do browsers decide combining character from non-combining character at computing .key value of dead key?

[Bug 24054] New: [Streams API] APIs that may use lots of resource should have some pressure on the app for consumption

[Bug 24072] Clarify handling of neutered objects

[Bug 24072] New: Clarify handling of neutered objects

[Bug 24074] New: new Worker('data:...') should not throw

[Bug 24077] New: second-argument-null.html worker test is incorrect

[Bug 24077] second-argument-null.html worker test is incorrect

[Bug 24079] New: Test for initErrorEvent is invalid

[Bug 24087] [Custom]: Rename document.register to registerElement

[Bug 24087] New: [Custom]: Rename document.register to registerElement

[Bug 24101] New: Missing word in "Return the readAsText() method, but continue to process the steps in this algorithm"

[Bug 24102] New: Specify the targets for events

[Bug 24102] Specify the targets for events

[Bug 24114] New: [imports]: add support for async loading

[Bug 24116] New: Add additional form of Extended Attribute

[Bug 24139] New: buglet in named property visibility algorithm

[Bug 24141] Consider the interaction of ArrayClass and concat()

[Bug 24141] New: Consider the interaction of ArrayClass and concat()

[Bug 24147] New: "The URL and documentURI attributes must return ..."

[Bug 24150] "createAttribute" "setAttributeNode" have no complete alternative

[Bug 24150] New: "createAttribute" "setAttributeNode" have no complete alternative

[Bug 24174] New: < should be quoted in attribute values

[Bug 24176] New: Clarify that custom SVG elements must extend an existing SVGElement

[Bug 24178] [Custom]: No way to differentiate attribute namespaces in attributeChanged callback

[Bug 24178] New: [Custom]: No way to differentiate attribute namespaces in attributeChanged callback

[Bug 24181] New: [Shadow]: There's isn't a way to append shadow elements in SVG

Last message date: Tuesday, 31 December 2013 00:14:35 UTC