W3C home > Mailing lists > Public > www-style@w3.org > June 2015

Re: [css-display] feedback on box-suppress

From: fantasai <fantasai.lists@inkedblade.net>
Date: Sat, 20 Jun 2015 18:09:29 -0400
Message-ID: <5585E499.50607@inkedblade.net>
To: www-style@w3.org
On 02/18/2015 06:04 PM, Tab Atkins Jr. wrote:
> On Sun, Feb 1, 2015 at 3:29 PM, Mats Palmgren <mats@mozilla.com> wrote:
>> On 09/27/2014 07:31 PM, fantasai wrote:
>>> We have a couple of key issues open that we would particularly like
>>> feedback on:
>>>     A. Naming of the box-hiding-and-showing property. Please send us
>>>     suggestions for improvement! (Or comments on what you like about
>>>     the current name. We're pretty unsure atm, but want it to be
>>>     easily understandable.)
>>>     http://www.w3.org/TR/css-display-3/#box-suppress
>> 'box-suppress: hide' has multiple issues noted in the spec[1] so I wonder
>> if it would be better to move it to the next level of the spec?
>> 'box-suppress: show | discard' OTOH is straightforward to implement and
>> is something that authors have been asking for for a long time.
>> My 2 cents on the naming: 'box-suppress: discard' sounds like a double
>> negation and I find it hard to understand what it does from just reading
>> the words. I would prefer a positive term instead, like
>> 'box-construction: normal | none' or 'box-features: all | none'.
>> ('none' is to associate it with 'display: none' to make it easy to
>> remember what it does).
> 'box-construction: normal | none' is a better name than the current, I
> think.  fantasai, opinions?

I don't think it's as user-friendly as the current list of keywords.
   show | discard | hide
is pretty explicit about the differences among the keywords, whereas
normal | none really isn't self-evident at all.

All in favor of a better property name, though!
(I don't have any good suggestions.)

Received on Saturday, 20 June 2015 22:10:07 UTC

This archive was generated by hypermail 2.4.0 : Friday, 25 March 2022 10:08:54 UTC