Re: [push] Consider renaming "push notification" to "push message" in the Push API spec

I agree, Push Message is the term that is used in other standards e.g. OMA Push. The use of the term notification was a reflection of the current simplified API design which provides only a trigger to the application, as a "notification" that some data is available at the server. As we consider the introduction of an optional payload into the API, the term Push Message becomes more appropriate.

Bryan Sullivan

On Mar 10, 2014, at 11:23 PM, "Jeffrey Yasskin" <<>> wrote:

The term "push notification" in
seems to confuse people into thinking that the user will be
notified/bothered when such a message arrives. This is reinforced by
the fact that iOS uses "push notification" for exactly that: a way to
notify the user based on a message from a server. See

Since the spec already uses the name "PushMessage" for the thing
delivered by a push notification
it seems like "push message" would be a good replacement for the
current ambiguous name.

Jeffrey Yasskin

P.S. I'm not subscribed to public-webapps@, so please cc me if you
want me to reply.

Received on Thursday, 13 March 2014 08:57:58 UTC