[push] Consider renaming "push notification" to "push message" in the Push API spec

The term "push notification" in
seems to confuse people into thinking that the user will be
notified/bothered when such a message arrives. This is reinforced by
the fact that iOS uses "push notification" for exactly that: a way to
notify the user based on a message from a server. See

Since the spec already uses the name "PushMessage" for the thing
delivered by a push notification
it seems like "push message" would be a good replacement for the
current ambiguous name.

Jeffrey Yasskin

P.S. I'm not subscribed to public-webapps@, so please cc me if you
want me to reply.

Received on Monday, 10 March 2014 22:22:36 UTC