[OEP, ALL] Naming Conventions for OWL code

While reviewing various OEP notes, I noticed that they use different
naming conventions. e.g.  healthValues vs. health_values

It is clearly a good idea for a single note to use a clear and
consistent naming convention.

Do we also want to have a single one across all notes?

With a single convention, it is easier for people reading more than one
Yet, multiple naming conventions are a reality, so it may be good
practice for people to see different conventions.

I lean towards a consistent naming convention. If we adopt one, then it
should be documented somewhere and referenced in each of the notes.
This would not work so well, if different authors had strong preferences
about naming conventions.

Also, we should point out that we are NOT recommending this as the right
one, just one among variuos that work just fine.

Any thoughts?


Received on Saturday, 5 March 2005 17:38:14 UTC