Re: Issue 169: Propose http method in the operation interface to simplify http binding.

On Thu, Jul 01, 2004 at 12:08:33AM -0700, David Orchard wrote:
> As I said earlier, just because the "webMethod" is set to PUT does not mean that the actual
> protocol method used in the binding is PUT.  PUT is the constrained/generic semantics at 
> the abstract level, but the realization may be different.  Case in point is Atom. 

Ah right, I forgot you were covering that case.  I'm not convinced it's
worth the effort, but I won't begrudge you the opportunity to prove me
wrong. 8-)

My objective here is just to ensure that there's an unambiguous means
of determining the operation.

> I had suggested at one point that the "name" could be optional, but I know
> believe that would be a bad decision.  The name is the identifier for the relationship between
> inputs, outputs, faults, and optionally generic operations.  I think naming these things and
> being able to refer to them is good.

I could live with it being there, but I'd really want to see some clear
language in the spec describing the difference between the semantics of
"name" with and without the proposed new attribute.  Because I'm
convinced that without that, developers won't understand the difference,
and so will use the name to interpret the semantics of a successful

Mark Baker.   Ottawa, Ontario, CANADA.

  Seeking work on large scale application/data integration projects
  and/or the enabling infrastructure for same.

Received on Sunday, 4 July 2004 23:29:04 UTC