Re: Issue 169: Propose http method in the operation interface to simplify http binding.

"David Orchard" <> writes:
> I agree with the friendly amendment.  
> And I'm ok with with whatever name people want for the attribute, beit
> "webMethod", "restMethod", "genericMethod", "constrainedMethod",
> "httpMethod", "uniformMethod".  My guess is that genericMethod is
> actually the most accurate and least controversial, but I'll accept
> whatever name has the best chance at consensus.
> Cheers,
> Dave

I see little difference between @genericMethod and the operation/@name
attribute that already exits. 

Why not go all the way and recommend people to do what Mark always 
wanted? Allow/enable/encourage people to name their method GET/PUT

    <operation name="GET"> .. </operation>

Actually we wouldn't need to do anything to enable this IIRC. You
might say that that's not "special enough" .. but then unless 
the operation is mapped to HTTP GET/PUT its not special anyway.


Received on Thursday, 1 July 2004 09:51:06 UTC