RE: ISSUE: owl:Class name misleading; try owl:Set?

My two sense:

1. Classes in OWL _ARE NOT_ the same as sets, as the word is generally defined and used in mathematics, so it would be disastrously wrong to change owl:class to owl:set -- this distinction ought to be kept clear to the general public.

2. The matter of how misleading sameClassAs can be as mentioned below is indeed tricky, because it exactly highlights the intensional/extensional distinction -- thinking of intension and extension as two functions on the class of classes, we mean by sameClassAs that the two items have different values from the perspective of the intension function, but the same value from the perspective of the extension function, so owl:sameExtensionAs is more precise. But is it really requiring too much understanding of logic to use that name when at the same time we expect users to grok intensional and extensional distinctions if they are going to use full OWL correctly?

-- Ziv

>-----Original Message-----
>From: Jim Hendler []
>Sent: Thursday, 02 January, 2003 17:14
>To: Jeff Heflin; Peter F. Patel-Schneider
>Subject: Re: ISSUE: owl:Class name misleading; try owl:Set?
>At 9:53 -0500 1/2/03, Jeff Heflin wrote:
>>"Peter F. Patel-Schneider" wrote:
>>>  owl:sameMember[s]As might be a better name for owl:sameClassAs.
>>I agree that sameClassAs is a very misleading name. At the very least,
>>we need to mention in the Guide and the Reference that it only means
>>that the extensions of two classes are equal. In particular we need to
>>point out that it does not mean that the property values of 
>two classes
>>However, it would be far better to not have a confusing name. 
>>I would strongly support renaming sameClassAs to either 
>sameMembersAs or
>hmm, I use the sameClassAs to mean classes in different ontologies 
>are actually the same as part of out ontology mapping work, and I 
>notice other examples of markup that does the same.  i.e. I often use 
>things like
>ont1:Car owl:sameClassAs ont2:Automobile;
>sameMembersAs would not seem to me to make sense here, and 
>sameExtensionsAs, while probably technically correct, is way too 
>geeky for me to support (or, more appropriately, requires too much 
>knowledge of logic to decide when to use).  I would call this one of 
>those "if it ain't broke, don't fix it" situations and leave it as it 
>  -JH
>Professor James Hendler				  
>Director, Semantic Web and Agent Technologies	  301-405-2696
>Maryland Information and Network Dynamics Lab.	  301-405-6707 (Fax)
>Univ of Maryland, College Park, MD 20742	  240-731-3822 (Cell)

Received on Thursday, 2 January 2003 14:35:33 UTC