W3C home > Mailing lists > Public > www-style@w3.org > February 2015

Re: [css-display] feedback on box-suppress

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Wed, 18 Feb 2015 15:04:40 -0800
Message-ID: <CAAWBYDB7eWMYzFfnVG6xVT5emrvcgqessnP89ddZL1uq=76Uug@mail.gmail.com>
To: Mats Palmgren <mats@mozilla.com>
Cc: "www-style@w3.org" <www-style@w3.org>
On Sun, Feb 1, 2015 at 3:29 PM, Mats Palmgren <mats@mozilla.com> wrote:
> On 09/27/2014 07:31 PM, fantasai wrote:
>> We have a couple of key issues open that we would particularly like
>> feedback on:
>>    A. Naming of the box-hiding-and-showing property. Please send us
>>    suggestions for improvement! (Or comments on what you like about
>>    the current name. We're pretty unsure atm, but want it to be
>>    easily understandable.)
>>    http://www.w3.org/TR/css-display-3/#box-suppress
> 'box-suppress: hide' has multiple issues noted in the spec[1] so I wonder
> if it would be better to move it to the next level of the spec?
> 'box-suppress: show | discard' OTOH is straightforward to implement and
> is something that authors have been asking for for a long time.
> My 2 cents on the naming: 'box-suppress: discard' sounds like a double
> negation and I find it hard to understand what it does from just reading
> the words. I would prefer a positive term instead, like
> 'box-construction: normal | none' or 'box-features: all | none'.
> ('none' is to associate it with 'display: none' to make it easy to
> remember what it does).

'box-construction: normal | none' is a better name than the current, I
think.  fantasai, opinions?

And yeah, we might have to kick the 'hide' value to the next level.
The Houdini work will likely involve marking properties as affecting
layout/paint/etc, which will probably give us a nice primitive to
build it off of in a precise way.

Received on Wednesday, 18 February 2015 23:05:28 UTC

This archive was generated by hypermail 2.4.0 : Friday, 25 March 2022 10:08:51 UTC