Re: [selectors-4] :blank pseudo-class

20.08.2015, 01:20, "fantasai" <>:
> The current :blank pseudo-class should probably be renamed
> and :blank used to indicate blank (omitted) form fields.

The current tendency of using terms that are short and "look cool", but have unclear meaning and/or unobvious differences from each other (and therefore confusing), is probably not quite a good idea.

Actually, this is probably one of reasons why such topics arise in the first place: names are too abstract.

`:empty` itself could probably be renamed to something more specific like `:no-child-nodes`.

Then `:blank` could be renamed to `:no-children` (in line with `Element.children` in DOM) or `:no-child-elements`.

It's probably much better to have a name which is reasonably longer but perfectly clear than one which is shorter but unclear or confusing.

Received on Thursday, 20 August 2015 18:31:11 UTC