- From: François REMY <francois.remy.dev@outlook.com>
- Date: Thu, 8 Aug 2013 18:17:03 -0700
- To: "'Tab Atkins Jr.'" <jackalmage@gmail.com>, "'www-style list'" <www-style@w3.org>
± You'd do "rectElement.values.x.px = 5", etc. This might work well, and it has ± the benefit of being consistent between the two APIs. We could even push ± this into plain HTML eventually as well. The downside being that if doesn't propagate directly to other constructions like "getComputedStyle()", "getSpecifiedStyle()/currentStyle" or even "getOverrideStyle()/runtimeStyle". If I can bikeshed this even more, I would introduce the "om" property (for object model) on the CSSStyleDeclaration interface (for CSS properties) and on SVGElement (for SVG attributes). rectElement.om.x.px = 5 if(getComputedStyle(rectElement).om.fontSize.pct != 1.0) { // font-size has changed since parent element } Thoughts?
Received on Friday, 9 August 2013 01:17:37 UTC