On Thu, Aug 8, 2013 at 6:17 PM, François REMY <francois.remy.dev@outlook.com> wrote: > ± You'd do "rectElement.values.x.px = 5", etc. This might work well, and it has > ± the benefit of being consistent between the two APIs. We could even push > ± this into plain HTML eventually as well. > > The downside being that if doesn't propagate directly to other constructions like "getComputedStyle()", "getSpecifiedStyle()/currentStyle" or even "getOverrideStyle()/runtimeStyle". Why wouldn't it? Those just return CSSStyleDeclaration objects, so they'd all get .values properties too. > If I can bikeshed this even more, I would introduce the "om" property (for object model) on the CSSStyleDeclaration interface (for CSS properties) and on SVGElement (for SVG attributes). > > rectElement.om.x.px = 5 > > if(getComputedStyle(rectElement).om.fontSize.pct != 1.0) { > // font-size has changed since parent element > } > > Thoughts? It's shorter, but also less clear. ~TJReceived on Friday, 9 August 2013 01:34:30 UTC
This archive was generated by hypermail 2.4.0 : Monday, 23 January 2023 02:14:30 UTC