Re: addEventListener naming

On Sun, 13 Sep 2009, Anne van Kesteren wrote:
> On Sun, 13 Sep 2009 13:59:31 +0200, Olli Pettay <>
> wrote:
> > I agree with Jonas. I wouldn't want to see listen() and unlisten() 
> > added to the spec.
> Agreed. I'd rather we have a much tighter focus on getting better 
> interoperability on DOM Level 2 Events and document more of what is 
> already implemented (e.g. key events) than spend time on adding new 
> features that only have marginal benefit.

The main reason I'd recommend against adding aliases is that the Web 
platform is already huge and complicated. Adding an alias only adds a 
potential new source of bugs, it doesn't add any new features; this 
therefore just leads to more complexity in the platform. Even if the 
browsers manage to implement this flawlessly, it's still just more to 
explain when writing the platform's reference book.

Ian Hickson               U+1047E                )\._.,--....,'``.    fL       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'

Received on Sunday, 13 September 2009 20:57:24 UTC