W3C home > Mailing lists > Public > public-ws-chor@w3.org > September 2004

ISSUE: Minor renaming on interaction exchange type field

From: Gary Brown <gary@enigmatec.net>
Date: Thu, 2 Sep 2004 11:28:09 +0100
Message-ID: <003f01c490d7$8ee7c9a0$4b00a8c0@LATTITUDEGary>
To: <public-ws-chor@w3.org>

(Possibly something that can be resolved on tonights issues discussion,
without having to raise a bugzilla)

When a type is referenced in most places in the CDL language, the attribute
is called 'informationType' - to maintain a level of abstraction above the
type system actually being used.

However, the 'exchange' part of the 'interaction' construct has an attribute
'messageContentType'. Although this name identifies the fact that a message
is being transferred, it was not clear whether this was an informationType
or could be an XML schema type. Only by looking at the example did I see
that it referred to an informationType.

Therefore I would propose that this attribute should be changed to
'informationType' for clarity purposes. I don't think this would detract
from the meaning of the type field, as it is part of an element called
'exchange' which implies information is being exchanged, and the element
contains a 'send' and 'receive' variable definition.

Received on Thursday, 2 September 2004 10:28:26 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:30:27 UTC