W3C home > Mailing lists > Public > public-vocabs@w3.org > January 2015

Someone please look at my site

From: The Bicycling Guitarist <chris@thebicyclingguitarist.net>
Date: Fri, 16 Jan 2015 11:58:43 -0800
Message-ID: <21AC302964EF4D11A131782348F70EF3@danaPC>
To: <public-vocabs@w3.org>
I have been trying for more than a year to implement structured data throughout my site. I have posted in the Google forum about this but haven’t gotten any responses to any of my most recent questions. 

On www.TheBicyclingGuitarist.net/songs/redbaron.htm  I have two videos each marked up as workExample of the same song but do not know if that is correct. 

The most important page of my site is the home page of course at www.TheBicyclingGuitarist.net/  Again I am not sure if I have marked up as much as I should the way I should. I also found that the Google structured data testing tool reports an error when I use genre as a property of MusicGroup even though the schema.org page says it is okay and the Stuctured Data Linter reads it without reporting it as an error. 

I also found that the example given on the schema.org breadcrumb page generates an html error in the w3c unicorn validator. I found an easy fix that works in Unicorn and still gives the structured data in the Google SDTT. See any of my pages’ breadcrumb navigation for an example (I moved the separator character inside the li). Again, not sure if this is okay, but the bottom line is that the code as supplied does not validate according to w3c, and my fix does and still gives the structured data.

Some WW2 veterans shared stories I published for them including one at www.TheBicyclingGuitarist.net/china-burma-india/newman.htm. Some of my Studies pages have a lot of markup too such as www.TheBicyclingGuitarist.net/ishi/ and www.TheBicyclingGuitarist.net/studies/colorphotos.htm 


Basically every page of my site is as marked up as I can figure how to do, but I do want to know if I am doing this correctly and in the proper spirit of the intention of schema.org. Am I marking up too much maybe when I add meta tags for encodingFormat and contentSize to AudioObject mp3 files on my song pages? Any suggestions on how to improve what I am doing will be greatly appreciated. thanks
Received on Friday, 16 January 2015 20:00:52 UTC

This archive was generated by hypermail 2.3.1 : Friday, 16 January 2015 20:00:53 UTC