[presentation-api] PresentationReceiver: rename getConnection() and getConnections()

mounirlamouri has just created a new issue for 
https://github.com/w3c/presentation-api:

== PresentationReceiver: rename getConnection() and getConnections() 
==
CC @avayvod @mfoltzgoogle @sicking

I have looked at the receiver side of the API fairly rarely and every 
time I am to remember that getConnection() is actually waiting for a 
connection while getConnection***s*** return the list of active 
connections. I would suggest to rename them to:
```idl
interface PresentationReceiver {
  Promise<PresentationConnection> waitForConnection();
  Promise<sequence<PresentationConnection>> connections();
};
```

I'm dubious about ```waitForConnection``` because it's basically the 
same as the ```connectionavailable``` event or did I miss the subtlety
 here?

See https://github.com/w3c/presentation-api/issues/201

Received on Tuesday, 6 October 2015 15:05:31 UTC