Re: What issue does Revelytix have with the syntactic sugar for rr:tableName?

Hi David,

On 6 Dec 2011, at 19:23, David McNeil wrote:
>> It *is* already in the spec and has been for many months. There were no objections raised when this feature when it was first proposed. The R2RML ED went to Last Call, including this feature, with the consensus of the WG.
> To complete the story...
> And a comment came up during Last Call.

It was your comment.

> We discussed the feature in the "face-to-face" and there was agreement that there were several un-answered questions about the feature. We didn't have time to resolve the issues in the face-to-face. An issue was created to capture those questions.

As far as I remember, it was you who brought up those questions. Let me answer them now as best as I can.

>> 1. Should we have this feature at all?

Yes. The feature is convenient and makes simple mappings more readable.

>> 2. Should it use different property names (e.g., rr:logicalTableName and rr:logicalTable=>rr:name)?

No, that just bloats the namespace for no gain in functionality or clarity. Users will be confused which to use where.

>> 3. Should it apply just to rr:tableName, or also to rr:sqlQuery and rr:sqlVersion?

There is no harm in leaving it as it is.

>> 4. The handling of this sugar in the B.2 table is non-obvious (see ISSUE-74)

It certainly can be improved but it's good enough. If no one volunteers a better alternative then it should just stay as it is.

> Now I would expect the process would be to work the issue, rather than to dismiss the issue.

I am not dismissing the issue. I am asking what the issue is. If you only have some unanswered questions then surely we don't need to track them with an issue  you can ask them anytime. If you perceive a problem with the specification, then a tracked issue is warranted, but then you need to say what the problem is.


Received on Tuesday, 6 December 2011 21:29:09 UTC