W3C home > Mailing lists > Public > public-prov-wg@w3.org > November 2011

Re: PROV-ISSUE-147 (Replace recipe): Change the name if "Recipe" [Data Model]

From: Timothy Lebo <lebot@rpi.edu>
Date: Wed, 16 Nov 2011 12:07:35 -0500
Message-Id: <0CACA427-E8BE-44B9-870C-D0238AD9589C@rpi.edu>
To: Provenance Working Group WG <public-prov-wg@w3.org>
I very much like Jim's proposal for prov:usedPlan and prov:Plan to replace prov:hadRecipe and prov:Recipe.

Besides the discussion about the difference between a ProcessExecution and Entity, I don't see any objections and saw many favorable responses.

Would be be able to vote on this name change for an existing construct that the group has already approved?

Thanks,
Tim


On Nov 7, 2011, at 12:52 PM, Jim McCusker wrote:

> On Mon, Nov 7, 2011 at 12:20 PM, Luc Moreau <L.Moreau@ecs.soton.ac.uk> wrote:
>> For a techie, maybe. But the the workflow script
>> is an input. So not a plan.
>> 
>> The other issue is that the workflow script can  be seen as an entity. But I understood the plan to be outside dm.
> 
> I think it's reasonable to say that that Plan is a subclass of Entity,
> and hadPan should be a subproperty of used (maybe hadPlan should be
> usedPlan).
> 
> Jim
> -- 
> Jim McCusker
> Programmer Analyst
> Krauthammer Lab, Pathology Informatics
> Yale School of Medicine
> james.mccusker@yale.edu | (203) 785-6330
> http://krauthammerlab.med.yale.edu
> 
> PhD Student
> Tetherless World Constellation
> Rensselaer Polytechnic Institute
> mccusj@cs.rpi.edu
> http://tw.rpi.edu
> 
> 
Received on Wednesday, 16 November 2011 17:08:18 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:51:04 UTC