Sensors simplified (or not)

Looking at the similarity of all the Sensor APIs (Ambient Noise, 
Temperature, etc.), and thinking about extensibility I thought I'd merge 
all the interfaces into 1. Something like:

interface SensorReading {
     readonly attribute float? value;
     readonly attribute float? min;
     readonly attribute float? max;
     readonly attribute float? normalizedValue;

(don't mind the names for now.)

The value is meant to be a physical value with a unit (set by each 
sensor's specification). min and max should also be in that unit. But 
there are many sensors for which the native API doesn't report a 
physical value. For instance, the brightness is sometimes reported as a 
% value (OS X, IIRC). In other cases, the proximity sensor reports 2 
values: near and far (Android). That's why I added normalizedValue, 
which is meant to be a unit-less value from 0.0 to 1.0

- Is that a good model?
- Is there a better alternative?
- If not, are there better names than "SensorReading" and "normalizedValue"?


Received on Wednesday, 10 February 2010 16:13:34 UTC