W3C home > Mailing lists > Public > public-css-testsuite@w3.org > April 2014

Re: testharness.js in csswg-test repository

From: kawabata taichi <kawabata.taichi@gmail.com>
Date: Tue, 15 Apr 2014 17:07:33 +0900
Message-ID: <CA+PRW9_NYBr-bj5ic3pmUj7B80wyMnHNAwTFxbfF41SpPo4Uxw@mail.gmail.com>
To: Gérard Talbot <css21testsuite@gtalbot.org>
Cc: Rebecca Hauck <rhauck@adobe.com>, Public CSS Test suite mailing list <public-css-testsuite@w3.org>
Dear Talbot,

I've just right now examined the document you mentioned!

All what I did is as follows::

(1) fork 'csswg-test' and 'web-platform-tests' at Github web site.

(2) execute cloning commands.

: % git clone --recursive https://github.com/kawabata/csswg-test.git
: % git clone --recursive https://github.com/kawabata/web-platform-tests

However, there is no directory such as "csswg-test/resources" as
mentioned in [1]. (There exists "web-platform-tests/resources",
though, and there indeed 'testharness.js' in that directory.)

(3) I tried to fetch upstreams as follows, but with not much luck.

: git remote add upstream https://github.com/w3c/csswg-test.git
: git fetch upstream

Anyway, when I make a test in "web-platform-tests", it worked well.
I've considered that I copy my tests in "web-platform-tests" to
"csswg-tests"
and then commit the test.

But if it is not a proper way, I appreciate if you could let me know.

With best regards,


On Tue, Apr 15, 2014 at 4:46 PM, Gérard Talbot
<css21testsuite@gtalbot.org>wrote:

> Rebecca,
>
> Yesterday, I got an email from Kawabata Taichi that goes like this:
>
> "
> I'm kawabata, and I've been working for creating Tests for CSS Ruby.
> I've got one serious problem relating to the test of CSS Ruby.
>
> (...)
>
> In short, it seems there is no testharness.js way in csswg-test repository,
> and I'm wondering how can I contribute about ruby.
> "
>
> I have read and looked in
> Testharness.js Tutorial: Getting Started
> http://testthewebforward.org/docs/testharness-tutorial.
> html#getting-started
>
> and in
> Github Test Submission: Clone the submodules
> http://testthewebforward.org/docs/github-101.html#clone-the-submodules
>
> and "testharness files in should be in the resources directory."
>
> Rebecca: are the documentation files updated and correct?
>
> Rebecca: wouldn't it be more exact to use the "subdirectories" word (or
> "sub-directories" ... or "folders") instead of "submodules" word? Just
> asking...
>
> Kawabata: did you do:
> $ git clone --recursive https://github.com/username/csswg-test.git
>
> Kawabata: if you have an empty resources directory at the root of your
> cloned repo, can you do:
> $ cd test-repo-root
> $ git submodule init
> $ git submodule update
>
>
-- 
---------------------------------------------------------------------
川幡 太一 (KAWABATA, Taichi) E-mail: kawabata.taichi@gmail.com
Received on Tuesday, 15 April 2014 08:08:01 UTC

This archive was generated by hypermail 2.4.0 : Friday, 20 January 2023 19:58:20 UTC