Re: [csswg-drafts] [selectors4] Name the “functional pseudo-class like :matches() with 0 specificity”

Hi all,

I know that when it comes to names, we all have opinions. However, the group has been discussing this for months (possibly over a year) at this point. We've recently discussed it again F2F, and narrowed it down to :if and :where. I think it's highly unlikely that we will go back and reconsider other names at this point. Therefore, it would be far more productive to argue which one of these is a better choice. 

Personally, I see myself using this A LOT so I think brevity is important. [Roman Komarov seems to think the same]( So, I would vote for `:if()`. Also, I think `:if()` stands much better when it's by itself than `:where()`.
However, the community so far seems to favor :where():

I do worry a little that this is because they hope to see if used for something else though, or because many of them are programmers and are used to if from there (whereas if has a much stronger association with natural language, if your brain has not been tainted by programming languages).

GitHub Notification of comment by LeaVerou
Please view or discuss this issue at using your GitHub account

Received on Friday, 6 July 2018 03:02:46 UTC