Re: [csswg-drafts] [selectors4] Name the “functional pseudo-class like :matches() with 0 specificity”

My last two suggestions weren’t serious.

 But I liked `:is()` more than `:if()`. Sorry, but `:if()` just feels wrong to me. I think for Web authors, knowing a little (or more) JavaScript is more common than not. And you don’t need to know a lot of it to see `if(foo) {  }` as script instead of CSS. `:if()` makes me expect there should also be an `:else()`. Or maybe a `:then()`

The older proposal of `@if` and `@else` for media queries seemed more natural to me.

GitHub Notification of comment by bradkemper
Please view or discuss this issue at using your GitHub account

Received on Friday, 6 July 2018 03:45:39 UTC