W3C home > Mailing lists > Public > public-credentials@w3.org > November 2019

Re: Proof purposes (was Re: Proposed work item: did:key DID Method)

From: Manu Sporny <msporny@digitalbazaar.com>
Date: Tue, 26 Nov 2019 11:56:42 -0500
To: public-credentials@w3.org
Message-ID: <935f4ae1-e938-b04e-10e7-340a3a160459@digitalbazaar.com>
On 11/26/19 4:30 AM, Markus Sabadello wrote:
> And "keyAgreementMethod" instead of "keyAgreement" etc.?

Yes, we clearly have an issue with naming consistency in the spec and
will need to go one way or the other (and there are valid arguments for
going either way).

I think the general argument against tacking "method" onto the end of
everything was that we'd end up needlessly placing method at the end of
lots of properties on the DID Document.

However, tacking method onto the end of everything that is actually a
verification method makes it more clear that it's a method and not
something like a proof or list of public keys or anything else.

... this discussion is clearly going to devolve into bike-shedding[1]
territory. :)

-- manu


Manu Sporny (skype: msporny, twitter: manusporny)
Founder/CEO - Digital Bazaar, Inc.
blog: Veres One Decentralized Identifier Blockchain Launches
Received on Tuesday, 26 November 2019 16:56:46 UTC

This archive was generated by hypermail 2.4.0 : Thursday, 24 March 2022 20:24:56 UTC