W3C home > Mailing lists > Public > public-credentials@w3.org > November 2019

Re: Proof purposes (was Re: Proposed work item: did:key DID Method)

From: Dave Longley <dlongley@digitalbazaar.com>
Date: Tue, 26 Nov 2019 14:13:30 -0500
To: Manu Sporny <msporny@digitalbazaar.com>, public-credentials@w3.org
Message-ID: <daba16d6-5aba-c0a0-945f-fe4ccb325f9b@digitalbazaar.com>

On 11/26/19 11:56 AM, Manu Sporny wrote:
> On 11/26/19 4:30 AM, Markus Sabadello wrote:
>> And "keyAgreementMethod" instead of "keyAgreement" etc.?
> Yes, we clearly have an issue with naming consistency in the spec and
> will need to go one way or the other (and there are valid arguments for
> going either way).
> I think the general argument against tacking "method" onto the end of
> everything was that we'd end up needlessly placing method at the end of
> lots of properties on the DID Document.
> However, tacking method onto the end of everything that is actually a
> verification method makes it more clear that it's a method and not
> something like a proof or list of public keys or anything else.
> ... this discussion is clearly going to devolve into bike-shedding[1]
> territory. :)

In general, my view of the history for naming these things was that
`method` was avoided until it was felt necessary to make a distinction
between a set of assertions and a set of verification methods that were
authorized for the purpose of making such assertions.

It may be an imperfect result ... but one whereby changing it now could
prove problematic for some non-trivial number of implementations. This
includes anyone building on top of VC 1.0; that spec shipped with
`authentication` and `assertionMethod`. We may also find that after must
discussion we'd wind right back up with the same naming compromise.

Dave Longley
Digital Bazaar, Inc.
Received on Tuesday, 26 November 2019 19:13:36 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:19:03 UTC