www-dom@w3.org from April to June 2014 by subject

(Errata?) DOM Level 3 lineNumber

[Bug 16488] Consider adding parent() / ancestor() method

[Bug 17541] Carefully think through how Range.insertNode should behave when the node to be inserted is already at the beginning of the range

[Bug 23167] [D3E-key] Define key name for TV

[Bug 23697] KeyboardEventInit in UI Events doesn't include keyCode/charCode/which but in D3E, it includes them

[Bug 23748] Shouldn't getModifierState() definition refer Modifiers Keys which are defined in .key value?

[Bug 23750] ScrollLock key should be defined in 6.3.2 Modifier Keys

[Bug 23751] "Select" key is not defined in the latest ED

[Bug 23781] id and class should be case-insensitive in quirks

[Bug 23886] Needs to define key value when dead key is pressed twice

[Bug 23906] [proposal] Add (Mouse|Keyboard)Event.accelKey

[Bug 23908] What's the good key value of printable keys with Meta key (Command key) on Mac?

[Bug 23909] Which is expected whether keydown event is fired before or after native IME handles it

[Bug 23910] What's the good .key value while IME is open?

[Bug 23911] [Proposal] Add KeyboardEvent.isComposing attribute

[Bug 24028] Element.matches("!invalid!") should throw DOMException "SyntaxError", not JavaScript TypeError

[Bug 24044] How do browsers decide combining character from non-combining character at computing .key value of dead key?

[Bug 24247] "guidelines for selecting and defining key values" is a dead link

[Bug 24637] [imports] "style sheet that is blocking scripts" should be generalized to support HTML Imports

[Bug 24738] D3E spec should define if keypress is fired when preceding beforeinput is consumed by preventDefault()

[Bug 24739] [D3E-code] Define code values for the special keys on Sun keyboard

[Bug 24739] Define code values for the special keys on Sun keyboard

[Bug 24740] Define code values for the special keys on Mac keyboard

[Bug 24797] Stop using AbstractView

[Bug 24810] "invoke MutationObserver object" should be updated for microtasks

[Bug 25168] Should XML Serialization be allowed to produce invalid XML?

[Bug 25180] Handle <template> element serialization

[Bug 25210] Targets for abort event is correct?

[Bug 25225] New: No way to convert between XML and HTML documents

[Bug 25229] New: Shouldn't NumpadComma be NumpadSeparator?

[Bug 25229] Shouldn't NumpadComma be NumpadSeparator?

[Bug 25244] New: What do Attr objects serialize?

[Bug 25244] What do Attr objects serialize?

[Bug 25287] [Proposa] InputEvent should have isComposing too

[Bug 25287] New: [Proposa] InputEvent should have isComposing too

[Bug 25288] New: Should change the definition of InputEvent.isComposing

[Bug 25288] Should change the definition of InputEvent.isComposing

[Bug 25291] New: Should define input event should be fired after compositionend

[Bug 25291] Should define input event should be fired after compositionend

[Bug 25294] DOMParser.parseFromString with application/whatever+xml

[Bug 25294] New: DOMParser.parseFromString with application/whatever+xml

[Bug 25295] New: Small bugs in the descriptions

[Bug 25295] Small bugs in the descriptions

[Bug 25303] New: Small bugs in the descriptions

[Bug 25303] Small bugs in the descriptions

[Bug 25338] D3E spec should recommend that KeyboardEvent.code of some keys whose label are different from PC's keyboard should be mapped from the key labels on Mac keyboard

[Bug 25338] New: D3E spec should recommend KeyboardEvent.code mapping of some keys whose label are different from PC's keyboard

[Bug 25340] Define new code name NumpadEqual or NumpadEquals

[Bug 25340] New: Define new code name NumpadEqual or NumpadEquals

[Bug 25346] New: Redefine initMouseEvent()

[Bug 25346] Redefine initMouseEvent()

[Bug 25357] New: Target for event type is not complete

[Bug 25357] Target for event type is not complete

[Bug 25358] "Context info: UIEvent.view" sometimes only has defaultView

[Bug 25358] New: "Context info: UIEvent.view" sometimes only has defaultView

[Bug 25359] New: Use [Unforgeable] and [NewObject] annotations in D3E

[Bug 25359] Use [Unforgeable] and [NewObject] annotations in D3E

[Bug 25363] Event click in table (adjustment default action)

[Bug 25363] New: Event click in table (adjustment default action)

[Bug 25365] About trusted="false" in two event orders

[Bug 25365] New: About trusted="false" in two event orders

[Bug 25366] Cancelable for mousemove (add note)

[Bug 25366] New: Cancelable for mousemove (add note)

[Bug 25368] New: Self-referential Informative reference appears at the bottom of the document

[Bug 25368] Self-referential Informative reference appears at the bottom of the document

[Bug 25373] "NonConvert" (key) vs. "NoConvert" (code)

[Bug 25373] New: "NonConvert" (key) vs. "NoConvert" (code)

[Bug 25392] "Unset the stop propagation flag, stop immediate..."

[Bug 25392] New: "Unset the stop propagation flag, stop immediate..."

[Bug 25405] Input Event Types (some correct)

[Bug 25405] New: Input Event Types (some correct)

[Bug 25408] New: Small typos

[Bug 25408] Small typos

[Bug 25412] Allow some recursion in NodeIterator/TreeWalker

[Bug 25412] New: Allow some recursion in NodeIterator/TreeWalker

[Bug 25421] New: Split the key/code value tables out of the primary DOM3 Events spec.

[Bug 25421] Split the key/code value tables out of the primary DOM3 Events spec.

[Bug 25428] New: hasFeature removal was premature

[Bug 25430] New: NodeIterator mutation algorithm is totally broken

[Bug 25430] NodeIterator mutation algorithm is totally broken

[Bug 25435] #concept-node-insert references index child, which may be null

[Bug 25435] New: #concept-node-insert references index child, which may be null

[Bug 25448] Keyboard Event Types (some correct)

[Bug 25448] New: Keyboard Event Types (some correct)

[Bug 25451] DOM spec header

[Bug 25451] New: DOM spec header

[Bug 25457] Adding "AutocompleteError" to error names table

[Bug 25457] New: Adding "AutocompleteError" to error names table

[Bug 25470] [imports]: improve description of async to clarify execution order

[Bug 25470] New: [imports]: improve description of async to clarify execution order

[Bug 25477] KeyboardEvent.initKeyboardEvent() needs correct

[Bug 25477] New: KeyboardEvent.initKeyboardEvent() needs correct

[Bug 25485] New: D3E and corelation with DOM4(W3C)/DOM(WHATWAG) and DOM3 Core

[Bug 25491] createEvent and case significance

[Bug 25491] New: createEvent and case significance

[Bug 25499] New: Upgrade event tables for better description

[Bug 25499] Upgrade event tables for better description

[Bug 25510] New: Spec readability: Move glossary to the bottom

[Bug 25510] Spec readability: Move glossary to the bottom

[Bug 25529] New: Cloning should be atomic

[Bug 25539] Broken links and other correct

[Bug 25539] New: Broken links and other correct

[Bug 25559] New: Spec readability: Drop some obvious "stylistic conventions" definitions (Notes, Warnings, Examples)

[Bug 25559] Spec readability: Drop some obvious "stylistic conventions" definitions (Notes, Warnings, Examples)

[Bug 25564] New: Remove vestiges of the 'char' attribute (4 occurrences)

[Bug 25564] Remove vestiges of the 'char' attribute (4 occurrences)

[Bug 25565] [DOM-P&S] Another small bugs

[Bug 25565] New: [DOM-P&S] Another small bugs

[Bug 25566] New: [imports]: Supporting more than just the script-src CSP directive in imports.

[Bug 25567] [imports]: Specify how media queries and html imports work together

[Bug 25567] New: [imports]: Specify how media queries and html imports work together

[Bug 25582] [DOM-P&S] Two short questions

[Bug 25582] New: [DOM-P&S] Two short questions

[Bug 25593] Access to event listeners in the EventTarget

[Bug 25593] New: Access to event listeners in the EventTarget

[Bug 25601] key value "Spacebar" vs. code value "Space"

[Bug 25601] New: key value "Spacebar" vs. code value "Space"

[Bug 25603] key value "MediaTrack(Next|Previous)" vs. code value "Media(Next|Previous)Track"

[Bug 25603] New: key value "MediaTrack(Next|Previous)" vs. code value "Media(Next|Previous)Track"

[Bug 25655] New: Proposal for UIEvent "role" property

[Bug 25656] [D3E] Another corrections and suggestions

[Bug 25656] New: [D3E] Another corrections and suggestions

[Bug 25657] [D3E] click event after mousedown and mouseup events (more detail)

[Bug 25657] New: [D3E] click event after mousedown and mouseup events (more detail)

[Bug 25683] New: Document "unsafe to dispatch events" in D3E if it's possible

[Bug 25704] "When an element's id attribute is removed, unse..."

[Bug 25704] New: "When an element's id attribute is removed, unse..."

[Bug 25723] [D3E]Case-sensitive or case-insensitive for getModifierState() method?

[Bug 25723] New: [D3E]Case-sensitive or case-insensitive for getModifierState() method?

[Bug 25827] New: action vs notification

[Bug 25843] .code value, "Meta" is really necessary?

[Bug 25843] New: .code value, "Meta" is really necessary?

[Bug 25844] New: Clarify or change the use of "default action" to avoid confusion

[Bug 25869] DOMClassList.toggle 'force' parameter is "wonky API design"

[Bug 25869] New: DOMClassList.toggle 'force' parameter is "wonky API design"

[Bug 25888] New: The definition of .key value of "RomanCharacters"

[Bug 25888] The definition of .key value of "RomanCharacters"

[Bug 25927] New: Specify the Event Loop integration for various non-deprecated events, incl. hit testing

[Bug 25928] New: Converge with CSSOM-View

[Bug 25942] New: Below the fold: a summary of w3's list

[Bug 25958] New: TypeError or SyntaxError for querySelector() and querySelectorAll()

[Bug 25958] TypeError or SyntaxError for querySelector() and querySelectorAll()

[Bug 25967] New: Testing DOM L3 Events

[Bug 25968] New: Needs clearer definition of virtual keyboard's KeyboardEvent.code value if it doesn't emulate physical key event completely

[Bug 25974] DOMError removal language could be improved

[Bug 25974] New: DOMError removal language could be improved

[Bug 26019] New: No way to initialize modifier states except "Alt", "Control", "Shift" and "Meta" at constructing DOM event with constructor

[Bug 26101] New: say what to do with event initializer dictionaries that have members without a default value

[Bug 26141] New: [D3E-Key] Needs more explanation of "MediaSelect"

[Bug 26187] implicit close for <rb>/<rtc> elements.

[Bug 26187] New: implicit close for <rb>/<rtc> elements.

[Bug 26218] New: When .getModifierState("OS") should be true?

[Bug 26225] New: Normative requirement about click event in a note

[Bug 26227] New: Define that click doesn't fire on disabled elements

[D3E] event loop and tasks

[D3E] minutes from 13 May 2014 call

[D3E] minutes from 17 June 2014 call

[D3E] minutes from 20 May 2014 call

[DOM-P&S] Please review latest ED vis-à-vis LC#2 by April 11

[DOM-Parsing] XMLSerializer production of non-well-formed XML

[DOM3Events] another week closer to LC?

[DOM3Events] Debrief after WebApps F2F?

[DOM3Events] Last Telco before WebApps F2F meeting...

[DOM3Events] Minutes from 2014-Apr-15 call [Was: Debrief after WebApps F2F?]

[DOM3Events] minutes from 6 May 2014 call

[DOM3Events] Telco reminder for May 20th, 2014

[DOM3Events] Telco reminder tomorrow

[dom] MutationObservers -- observing certain property changes

Another DOM L3 Events Telco tomorrow.

CfC: publish Candidate Recommendation of DOM Parsing and Serialization; deadline June 4

Document.origin Status

DOM L3 Events Telco reminder

DOM L3 Events Tests

DOMError Status

Elements array and query/queryAll methods

Fwd: [dom] MutationObservers -- observing certain property changes

PSA: publishing FPWD of D3E Keyboard {key,code} Values specs and WD of UI Events

PSA: publishing FPWD of D3E KeyboardEvent {key,code} Values specs and WD of UI Events

Reminder DOM L3 Teleconference Meeting tomorrow...

Reminder Telco tomorrow (May 6)

RfC: LCWD of DOM Parsing and Serialization; deadline May 22

Last message date: Monday, 30 June 2014 03:09:39 UTC