W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Selector API names - strawman

From: Robin Berjon <robin@berjon.com>
Date: Thu, 11 Jan 2007 12:33:54 +0100
Message-Id: <779B3B5A-8B2F-4084-9645-7BFA69ED18C1@berjon.com>
To: Public Web API <public-webapi@w3.org>


while I hate naming discussions just as much as the next guy, the  
last proposal out is so deeply inept that I see no other option than  
to reopen this.

Here is a proposal that is intended to satisfy both the brevity  
nazis, and those who like meaningful method names. I don't really  
like them myself, but I can live with them.

  - Document.css()
  - Document.cssAll()
  - Element.css()
  - Element.cssAll()

Same length, but with meaning.

Robin Berjon - http://berjon.com/
"Never doubt that a small group of thoughtful, committed people can
  change the world; indeed, it's the only thing that ever has."
                         -- Margaret Mead
Received on Thursday, 11 January 2007 11:34:25 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC