W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API updates

From: Doug Schepers <doug.schepers@vectoreal.com>
Date: Thu, 11 Jan 2007 10:20:50 -0500
Message-ID: <45A655D2.6010503@vectoreal.com>
To: Anne van Kesteren <annevk@opera.com>
Cc: Dave Massy <Dave.Massy@microsoft.com>, "Web API WG (public)" <public-webapi@w3.org>

Hi, Anne-

Anne van Kesteren wrote:
> On Wed, 10 Jan 2007 19:14:46 +0100, Dave Massy 
> <Dave.Massy@microsoft.com> wrote:
>> Looking at the feedback on
>> http://lists.w3.org/Archives/Public/public-webapi/ and Anne's blog entry
>> at http://annevankesteren.nl/2006/12/selectors-api-naming it seems that
>> the majority of people would agree with these principles and the
>> suggested names based on getElementBySelector.
> Just to make sure I understand what "majority" is I took my weblog entry 
> and counted the various names. +1 are those in favor of the proposal, 0 
> are those that didn't express any opinion and -1 are those against the 
> proposal. Where "proposal" is the shorter name:

Given the new information that comments on your blog are preferentially 
weighted over posts to this W3C list, I've now registered my opinion 
there. :)

Consider me a -1 for "shorter over more descriptive" and a -2 for 
".get()" and ".getAll()" (which adroitly marries the worst of both worlds).


Research and Standards Engineer
6th Sense Analytics
mobile: 919.824.5482
Received on Thursday, 11 January 2007 15:21:04 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC