W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API updates

From: Ian Hickson <ian@hixie.ch>
Date: Wed, 10 Jan 2007 17:54:08 -0800
Message-ID: <403d38e20701101754j6fbdd182l89fc89e6df93ea2b@mail.gmail.com>
To: "Anne van Kesteren" <annevk@opera.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>

On 1/9/07, Anne van Kesteren <annevk@opera.com> wrote:
>
> I resolved the naming debate by going for:
>
> * Document.get()
> * Document.getAll()
> * Element.get()
> * Element.getAll()
>
> These names are short, don't clash with autocomplete and provide a
> superset of the functionality given by the other get* methods.

I don't know that I like those names, but I support the editor's
decision. I do not think that arguing over these names is a productive
use of the working group's time.

-- 
Ian Hickson
Received on Thursday, 11 January 2007 03:33:26 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT