W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selector API names - strawman

From: Maciej Stachowiak <mjs@apple.com>
Date: Tue, 16 Jan 2007 22:56:47 -0800
Message-Id: <2323038A-AF64-4749-8BB4-8ADA0C126AC6@apple.com>
Cc: Public Web API <public-webapi@w3.org>
To: Robin Berjon <robin@berjon.com>

On Jan 11, 2007, at 3:33 AM, Robin Berjon wrote:

> Hi,
> while I hate naming discussions just as much as the next guy, the  
> last proposal out is so deeply inept that I see no other option  
> than to reopen this.
> Here is a proposal that is intended to satisfy both the brevity  
> nazis, and those who like meaningful method names. I don't really  
> like them myself, but I can live with them.
>  - Document.css()
>  - Document.cssAll()
>  - Element.css()
>  - Element.cssAll()

I don't think these are an improvement. 1) css is not a verb 2) this  
sounds like it would return style declarations, not elements. These  
names are worse than vague, they are actively misleading.

I like match/matchAll better than get/getAll or css/cssAll to be honest.

Why don't we just go back to the original versions?

Received on Wednesday, 17 January 2007 06:57:06 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC