W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selector API names - strawman

From: Doug Schepers <doug@schepers.cc>
Date: Fri, 12 Jan 2007 01:29:29 -0500
Message-ID: <45A72AC9.10306@schepers.cc>
To: Public Web API <public-webapi@w3.org>


Robin Berjon wrote:
> Here is a proposal that is intended to satisfy both the brevity nazis, 
> and those who like meaningful method names. I don't really like them 
> myself, but I can live with them.
>  - Document.css()
>  - Document.cssAll()
>  - Element.css()
>  - Element.cssAll()
> Same length, but with meaning.

No, no, no.  Burn that strawman.  I'd much rather have ".match()" and 
".matchAll()" (or just about anything else).  I have a suspicion that 
".css*()" would *really* confuse people into thinking it's a way of 
setting CSS style properties, or getting elements by classname, or just 
about anything other than a generic selector language.

Again, my suggestion is ".nodeBySelector()" and ".nodelistBySelector()" 
(or something like that).  ".nodeByMatch()"/".nodelistByMatch()"?

Received on Friday, 12 January 2007 06:29:43 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC